Dnsmasq



  • [LEFT]I can not put my server running.
    Because the pxe does not work , or the menu is displayed but can not register a client.
    So I gave a change to the notorious dnsmasq , but now freeze.
    here is my config.[/LEFT]
    [CODE]administrator@fogserver:~$ sudo nano /etc/dnsmasq.d/ltsp.conf
    GNU nano 2.2.6 Ficheiro: /etc/dnsmasq.d/ltsp.conf

    Don’t function as a DNS server:

    port=0

    Log lots of extra information about DHCP transactions.

    log-dhcp

    Set the root directory for files available via FTP.

    tftp-root=/tftpboot

    The boot filename, Server name, Server Ip Address

    dhcp-boot=undionly.kpxe,fogserver,10.1.8.1

    rootpath option, for NFS

    #dhcp-option=17,/images

    kill multicast

    #dhcp-option=vendor:PXEClient,6,2b

    Disable re-use of the DHCP servername and filename fields as extra

    option space. That’s to avoid confusing some old or broken DHCP clients.

    dhcp-no-override

    PXE menu. The first part is the text displayed to the user. The second is the timeout, in seconds.

    pxe-prompt=“Press F8 for boot menu”, 3

    The known types are x86PC, PC98, IA64_EFI, Alpha, Arc_x86,

    Intel_Lean_Client, IA32_EFI, BC_EFI, Xscale_EFI and X86-64_EFI

    This option is first and will be the default if there is no input from the user.

    pxe-service=X86PC, “Boot from network”, undionly

    This range(s) is for the public interface, where dnsmasq functions

    as a proxy DHCP server providing boot information but no IP leases.

    Any ip in the subnet will do, so you may just put your server NIC ip here.

    Since dnsmasq is not providing true DHCP services, you do not want it

    handing out IP addresses. Just put your servers IP address for the interface

    that is connected to the network on which the FOG clients exist.

    If this setting is incorrect, the dnsmasq may not start, rendering

    your proxyDHCP ineffective.

    dhcp-range=10.1.8.1,proxy
    [/CODE]
    my /tftpboot folder
    [CODE]drwxrwxrwx 2 fog root 4096 Dez 3 15:15 .
    drwxr-xr-x 25 root root 4096 Dez 3 10:19 …
    -rwxrwxrwx 1 fog root 840 Dez 3 10:19 boot.txt
    -rwxrwxrwx 1 root root 290 Dez 3 10:19 default.ipxe
    -rwxrwxrwx 1 fog root 389009 Dez 3 10:19 ipxe.kkpxe
    -rwxrwxrwx 1 fog root 389057 Dez 3 10:19 ipxe.kpxe
    -rwxrwxrwx 1 fog root 388044 Dez 3 10:19 ipxe.krn
    -rwxrwxrwx 1 fog root 389073 Dez 3 10:19 ipxe.pxe
    -rwxrwxrwx 1 fog root 25340 Dez 3 10:19 memdisk
    -rwxrwxrwx 1 fog root 16794 Dez 3 10:19 pxelinux.0.old
    -rwxrwxrwx 1 fog root 165088 Dez 3 10:19 snponly.efi
    -rwxrwxrwx 1 fog root 101989 Dez 3 10:19 undionly.kkpxe
    lrwxrwxrwx 1 root root 19 Dez 3 15:15 undionly.kpxe -> undionly.kpxe.INTEL
    -rwxrwxrwx 1 fog root 0 Dez 3 12:36 undionly.kpxe.INTEL
    -rwxrwxrwx 1 fog root 102037 Dez 3 10:19 undionly.kpxe.REAL
    -rwxrwxrwx 1 fog root 102053 Dez 3 10:19 undionly.pxe
    -rwxrwxrwx 1 fog root 147728 Dez 3 10:19 vesamenu.c32
    administrator@fogserver:/tftpboot$[/CODE]
    [LEFT]Now ipxe don’t boot.[/LEFT]
    [ATTACH=full]1533[/ATTACH]
    [LEFT]
    Some advice or help please.
    Thanks
    Pedro Valente[/LEFT]

    [url="/_imported_xf_attachments/1/1533_20141203_154418.jpg?:"]20141203_154418.jpg[/url]


  • Developer

    Good luck, you only need dnsmasq if you need to resolve to your file, if lets say for some reason your offered file is not received completely.

    I use dnsmasq because there are IP helpers in my network that over ride my dhcp settings. I also use an out dated netware environment that has limitations on the boot file name length.

    This length issue is also present in dnsmasq, that is why you have to symlink undionly.kpxe to undionly.0

    Yes it is true that in the ltsp.conf file you have supplied the boot file name in its entirety, but when we began working to provide the undionly.kpxe as a boot file name, dnsmasq still had limitations. I do not know if these limitations are still present.

    I hate to see you give up on trying to get dnsmasq to work, I feel it’s a wonderful solution, and with the use of dnsmasq you do not need to even edit the dhcp information to include the fog server or it’s boot file, dnsmasq works as a proxy dhcp server and issues the proper boot information to the client. If you choose to take it up again, dnsmasq that is, I would be happy to help you troubleshoot.



  • Thanks Jaymes,
    Yes I restart dnsmasq.
    Now, I remove the server name, and make the symlink to undionly.0 (don’t understand why have to do it to this file?) in the ltsp.conf Irefer to undionly.kpxe.
    The proxy thing, I don’t know, may be in my newtork this doesn’t work?
    thanks again.
    [ATTACH=full]1535[/ATTACH]
    P.S. I have my dhcp with
    [B]next-server 10.1.8.1;[/B] and [B]filename “undionly.kpxe”[/B];
    EDIT:
    I ask IT dhcp server personal to remove those options but now no offers.
    So I give up dsnmasq.
    Try without it.
    Thanks again Jaymes.

    [url="/_imported_xf_attachments/1/1535_20141203_162141.jpg?:"]20141203_162141.jpg[/url]


  • Developer

    Did you restart dnsmasq after updating your ltsp.conf?

    Try removing the server name from the ltsp.conf file and restart the service again.

    There is suppose to be a line in the screenshot you provided Directly after DHCP: X.X.X.X there should be a PROXY: and its value should be the same as the FOG server IP address.

    I also do not see a proper symlink to undionly.0, you will need to create a symlink to the file you are using, it appears that you are attempting to use undionly.kpx.INTEL

    to use this file you need to issue the following command to your terminal\

    [code]cd /tftpboot
    sudo ln -s undionly.kpxe.INTEL undionly.0[/code]

    [url="/_imported_xf_attachments/1/1534_DNSMASQ.jpg?:"]DNSMASQ.jpg[/url]


Log in to reply
 

411
Online

39002
Users

10717
Topics

101762
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.