/default.ipxe.......... connection timed out



  • Hello all! I come grovelling for help from the OpenSource masters in my time of need. haha!

    As the title says, I have been having an issue with PXE booting client machines. They will boot, get assigned an IP via DHCP, seems to get grabbed by iPXE (even configures correctly it seems!), then stops at the loading “default.ipxe” part with the error “Connection timed out ([url]http://ipxe.org/4c126035[/url])”

    I have been able to get FOG to work before using v0.32 on a LinuxMint desktop in an isolated network [via switch] (maybe 2 years ago). As well as today using some virtual machines with FOG v1.2.0 on an Ubuntu server in an isolated network.


    In my lab environment I have:

    • VMware ESXi 5.1 host cluster
    • One VM Server (Ubuntu Server x64 14.04.1 LTS)
    • One VM Client (No OS installed, simply a new VM with minimal specs)
    • Isolated portgroup on a “vDistributed Switch” with no internet connection

    This is the process by which the above (working) lab environment was setup:
    I install Ubuntu server x64 as a terminal only server, assign static IP address as appropriate for the network, connect it to a portgroup that has internet access, install VMware tools, do dist-upgrade, then proceed to install FOG_1.2.0. Going through the install I decide to setup the Ubuntu server as the DHCP server as this will be on an isolated network, all other options are left as default as well.
    Once fog is installed I boot my VM client and it immediately jumps from getting an IP to loading /default.ipxe to showing the FOG menu. IT WORKS! :D

    BUT if I follow the same procedure except I don’t make the Ubuntu server the DHCP server - instead setting options 66 = <serverIP> / 67 = undionly.kpxe on my Windows 2000 DHCP server - then it fails at the line:

    " /default.ipxe… Connection timed out ([url]http://ipxe.org/4c126035[/url])"


    I have read that my issue is caused by the TFTP service not running/listening, but I don’t understand how my LAN vs an private VM network (essentially a switch) can mean the difference between tftp working properly or not…

    Any help would be appreciated in solving this!

    Thank you everyone!


  • Developer

    [quote=“Ashley Rimmington, post: 39862, member: 27226”]Sorry for the misunderstanding on my part! Glad to say it worked like a charm!
    Thank you so much for your help guys. :)

    Just a thought here:
    Might I suggest making this a part of the default install for a windows environment install? I say this because my server is available for me to configure (which made me think that the link above didn’t apply since mine wasn’t “unmodifiable”) but when following default install procedure the system didn’t work in the end. With this dnsMASQ setup it works beautifully though!

    It just feels to me that this may be a required step for a windows server based DHCP setup.

    Thanks again![/quote]

    You are quite welcome!

    But not necessarily true. Every environment is different. Most have the ability to edit the DHCP scope and have their file delivered correctly. Sometimes users don’t have access to the DHCP Scope because it is managed by someone else, or a third party and this is where DNSMASQ shines. Sometimes the file is not delivered completely and DNSMASQ helps to resolve the issue (I suspect this is the issue you actually faced.)

    A Further problem I see, is that Ubuntu 12.04.4, 12.04.5 and 14.04, 14.10 have started including dnsmasq-base in the installation to help with dns resolution. This is a poor decision by conical, IMHO, and has lead to issues with installing and starting DNSMASQ. This would lead to causing FOG installation to fail unless you render your internet useless and try to install FOG… no wait FOG needs the internet to download modules for installation, this sounds bad already :/

    What I think was happening in your environment, is probably what is happening in mine. The file was not being passed entirely and DNSMASQ has helped to resolve this issue. I think DNSMASQ would be a good default module to install with FOG by asking a few questions and creating the file according to the responses, but having FOG install DNSMASQ and use it by default could be nasty and ugly.

    I’m glad DNSMASQ worked for you though :)



  • Sorry for the misunderstanding on my part! Glad to say it worked like a charm!
    Thank you so much for your help guys. :)

    Just a thought here:
    Might I suggest making this a part of the default install for a windows environment install? I say this because my server is available for me to configure (which made me think that the link above didn’t apply since mine wasn’t “unmodifiable”) but when following default install procedure the system didn’t work in the end. With this dnsMASQ setup it works beautifully though!

    It just feels to me that this may be a required step for a windows server based DHCP setup.

    Thanks again!


  • Developer

    Dnsmasq, as Tom stated, does not replace anything in your environment. It will act as a proxy DHCP server and offer ip address and network information to machines in the Pre eXecution Environment (PXE).

    Dnsmasq will act as a “secretary” if you will for a lack of better terms, and it will point the hosts to the correct file and server.

    Dnsmasq doesn’t replace any elements in the environment, it just helps to resolve your hosts to your correct boot information.

    Dnsmasq is a simple install, then you edit the /etc/exports file and paste the ltsp.conf file contents from the wiki and go.


  • Senior Developer

    You wouldn’t be switching to DNSMasq.

    You’re using it to provide tftp. It does not take the place of your DHCP server.



  • Hello again, thank you for your answer! Unfortunately we are mostly a Windows house, and DHCP is one of the systems that is “required” to run on Windows. Are there any options other than switching to dnsMASQ?


  • Developer

    I would recommend using DNSMASQ to help to resolve to your bootfile and server. You can find the installation instructions

    [url]http://fogproject.org/wiki/index.php/Using_FOG_with_an_unmodifiable_DHCP_server/_Using_FOG_with_no_DHCP_server#DNSMASQ_settings_for_iPXE[/url]



  • Contents of the [/tftpboot/default.ipxe] file:


    #!ipxe
    cpuid --ext 29 && set arch x86_64 || set arch i386
    params
    param mac0 ${net0/mac}
    param arch ${arch}
    isset ${net1/mac} && param mac1 ${net1/mac} || goto bootme
    isset ${net2/mac} && param mac2 ${net2/mac} || goto bootme
    :bootme
    chain [url]http://<FOG[/url] Server IP>/fog/service/ipxe/boot.php##params

    I also checked my /var/log/foginstall.log for errors and found nothing obvious…
    As well I’ve checked the apache2 error.log and it doesn’t show anything after a PXE client’s boot attempt.
    I’ll post them once I’ve managed to transfer them off the server.


  • Senior Developer

    What are the contents of the /tftpboot/default.ipxe file?


Log in to reply
 

382
Online

38980
Users

10712
Topics

101676
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.