Clients can't find pxe server <noob>



  • Probably a stupid question, but I’m having real difficulty figuring out what is going wrong.

    I’ve tried installing fog on a Ubuntu 14.10 64 bit installation and everything seems fine. I can create the images, define the hosts, I’ve gotten the hostnames to resolve by adding them to /etc/hosts (otherwise I get “can’t resolve hostname” errors). I’ve got upload image tasks set up. The problem is that when I boot the respective clients they just sit there in the PXE screen with DHCP. <more dots added as time goes on>. There seems to be something really obvious I’m missing.

    Reading that Ubuntu 14.04 isn’t recommended, I’ve tried the same thing on Ubuntu 12.04.5 32 bit and get the same outcome.

    I’ve tried giving the clients static IP in the router’s DHCP table. I’ve tried taking the secondary router out of the equation (I have two routers in my house). Nothing seems to work.

    One more thing. All I really want is to be able to PXE boot from ISO files I’ve downloaded from the internet rather than image a machine. Particularly because I’m trying to load an OS onto a netbook and for some reason imaging the ISO onto a USB is proving problematic (Rufus doesn’t recognise the ISO for example.) Perhaps FOG isn’t for me?



  • I’d actually tried Yumi but must have only used the Syslinux ISO access. It worked with the GRUB access. Thanks.

    Probably not worth it to use PXE if I can’t use the router’s DHCP.

    Thanks.


  • Developer

    i believe DNSMasq would work for this home network, but it really sounds like fog isn’t what you’re looking for
    if, as you say, booting your install disk from a usb stick would be all you need, i recommend Yumi for creating it



  • Yep, it’s a home network.

    Thanks, it seems to be working that far with the DHCP on Ubuntu. I guess now to work out how to get it to do what I want.



  • [quote=“Simon33, post: 39125, member: 27154”]Oh, it’s a Netgear CG3100D-2 with an integral cable modem.[/quote]

    I could be wrong, but I don’t see any way of getting PXE to work over that modem/router combo - they’re not really made to do PXE whereas business/commercial grade networking gear is. Is this just something you’re using at home? If so, you could create an isolated network where the FOG server handles DHCP for imaging and is connected directly to a switch. You can then just connect the machines you wish to image to the switch for imaging. Used commercial switches with gigabit ports (Cisco, etc) can be found on eBay - I picked up a D-Link DGS-1248T for ~$50 shipped. You’d have to connect the FOG server to the internet to run OS updates or upgrade FOG. Someone else may be able to help you with another solution

    [url]http://www.fogproject.org/wiki/index.php/FOG_on_an_Isolated_Network[/url]



  • Oh, it’s a Netgear CG3100D-2 with an integral cable modem.



  • As far as I can see there is no option in the router for this. Should I then disable the DHCP on the router and use the FOG DHCP?



  • [quote=“Simon33, post: 39122, member: 27154”]I’m using FOG 1.2.0 and the DHCP is supplied by the primary router.[/quote]

    Does your router have somewhere to specify the options needed to PXE boot? For Windows Server I know this is DHCP option 66/67, where you tell it the IP of the FOG server and point it to the undionly.kpxe file. I’ve never done it without a DHCP server so I probably won’t be much help there. It sounds like it’s not receiving the bootfile via tftp that it needs to boot from FOG



  • I’m using FOG 1.2.0 and the DHCP is supplied by the primary router.



  • [quote=“Simon33, post: 39120, member: 27154”]Probably a stupid question, but I’m having real difficulty figuring out what is going wrong.

    I’ve tried installing fog on a Ubuntu 14.10 64 bit installation and everything seems fine. I can create the images, define the hosts, I’ve gotten the hostnames to resolve by adding them to /etc/hosts (otherwise I get “can’t resolve hostname” errors). I’ve got upload image tasks set up. The problem is that when I boot the respective clients they just sit there in the PXE screen with DHCP. <more dots added as time goes on>. There seems to be something really obvious I’m missing.

    Reading that Ubuntu 14.04 isn’t recommended, I’ve tried the same thing on Ubuntu 12.04.5 32 bit and get the same outcome.

    I’ve tried giving the clients static IP in the router’s DHCP table. I’ve tried taking the secondary router out of the equation (I have two routers in my house). Nothing seems to work.

    One more thing. All I really want is to be able to PXE boot from ISO files I’ve downloaded from the internet rather than image a machine. Particularly because I’m trying to load an OS onto a netbook and for some reason imaging the ISO onto a USB is proving problematic (Rufus doesn’t recognise the ISO for example.) Perhaps FOG isn’t for me?[/quote]

    Which version of FOG are you using and are you using FOG for DHCP, or something else?


Log in to reply
 

363
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.