Could not boot: Exec format error (2e008001)



  • Hey guys,

    at the moment I’m trying to get FOG running, because we’d like to use it to deploy images. After setting up a Main-Server, 3 Storage-Nodes and doing some configuration, I now tried to boot a Client via PXE. This step failed and I have no idea how to fix it: “Could not boot: Exec format error”.

    My configuration:

    • Windows-DHCP-Server: Boot option 066 is set to the IP adress of the FOG server, 067 contains “undionly.kpxe”
    • The FOG-Server and the Client are on the same subnet
    • The client is currently a VM running on a ESXi-Host
    • FOG 1.2.0 on Ubuntu 13.10

    What I’ve tried:

    • I downloaded the latest iPXE files (iPXE 1.0.0+ (3a02) -> same error
    • Using the latest kernel available via webinterface -> same error
    • Reading related posts on the forum (and internet) if I can get any hint

    I hope, anybody has any idea and can help me. Thank you in advance!
    Enexor


  • Senior Developer

    Glad to help you find it.



  • Oh yes, I finally found it: the default.ipxe was empty, but it shouldn’t!

    Found this in the FOG wiki:
    [COLOR=#000000][FONT=monospace]#!ipxe
    dhcp || reboot
    cpuid --ext 29 && set arch x86_64 || set arch i386
    params
    param mac ${net0/mac}
    param arch ${arch}
    chain [url]http://x.x.x.x/fog/service/ipxe/boot.php##params[/url][/FONT][/COLOR]
    Now the FOG menu is showing up! :)



  • It’s an empty file. Is this right like that?


  • Senior Developer

    what are the content of your /tftpboot/default.ipxe file?



  • See the screenshot:
    [ATTACH]1513[/ATTACH]

    [url="/_imported_xf_attachments/1/1513_command.jpg?:"]command.jpg[/url]


  • Senior Developer

    what do you get when you run:
    [url]http://IP.OF.FOG.SVR/fog/service/ipxe/boot.php[/url]

    In browser?



  • Well, it’s not just a console error: the client doesn’t finish booting from the FOG server. The FOG boot menu never shows up. As I wrote, I already checked the forum but didn’t find a suitable solution. I also checked the wiki.

    I’m booting my Client via PXE. Then my WDS-Server is redirecting to the FOG-Server (using pxechn.c32). From here on, have a look at my screenshot:
    [ATTACH]1509[/ATTACH]

    See also the attached log files.

    [url="/_imported_xf_attachments/1/1509_screenshot.jpg?:"]screenshot.jpg[/url][url="/_imported_xf_attachments/1/1510_error.txt?:"]error.txt[/url][url="/_imported_xf_attachments/1/1511_foginstall.txt?:"]foginstall.txt[/url][url="/_imported_xf_attachments/1/1512_error1.txt?:"]error1.txt[/url]


  • Senior Developer

    What is the exact sequence of errors?

    Console errors are known about and fixed in trunk. This is really the only thing I can think of.

    Also, we have the latest ipxe which should be of version a9376.


Log in to reply
 

426
Online

39.3k
Users

11.0k
Topics

104.3k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.