FOG 1.2.0 - Some machines not joining domain



  • Hi all,

    Firstly to the FOG team, thank you for developing such a fantastic product (I’m sure people always say things like this, but it really is great). I’ve been using FOG for around 5 years now in my school and it’s made life so much easier. Apologies if I’ve done the wrong thing here in creating a new topic. I see there are one or two similar issues hovering around, but I didn’t want to hijack those threads.
    I’ve recently updated to version 1.2.0 from 0.32 - via the update guide, and have come across a problem. Some machines aren’t joining the domain after imaging/deployment. Instead, they join a workgroup of the same name. The name of the machine itself is correct after imaging though, but I’m not sure if this occurs due to entering it when the machine is booting up after sysprep, or if FOG is doing it. This issue appears to be occuring only on laptops though - or at least all the desktops I’ve reimaged since the update have worked.

    I’ve looked into a number of threads on here and dotted around the internet, but have had no luck getting these laptops to join on this latest version. Would someone mind shedding some light on the issue please?

    The two laptop models I’ve been struggling with so far are:

    -RM nBook 4300
    -Dell Vostro 3350

    Some of the things I’ve tried so far include:

    -Removing the domain from the AD username (it seems to work either way for desktops), both globally and on individual hosts.
    -Checking all boxes are ticked for ‘HostNameChanger’ module in the webui (3 locations - although it’s unticked under ‘Service Settings’ on most hosts - which worked fine on previous versions).
    -Reentering the encrypted password via fogcrypt
    -Reinstalling FOG over the top of itself
    -Restarting our FOG Server (how many times do we tell people to try restarting their machines?)
    -Deleting and registering the host again (quick host registration).
    -Tried using a pre-FOG 1.2.0 image in case I’d made a change on the updated image that the machine wasn’t happy with.
    -Different network sockets on our work bench.
    -Removing our wireless network password from the image so the only adapter talking to FOG is the ethernet card.
    -Disabling the wireless adapter (for the same reason as above, just to make sure)
    -Creating a new answer file for sysprep based on a guide on the forums. I’m not 100% this worked correctly though. My current test laptop had a randomly generated name, even though I typed one in. My original answer file that I have used for a few years has the domain details included in it.

    The FOG log has various different messages depending on what ‘Service settings’ I tick for the host. Next, I’ll try to remove the domain details from my original answer file to see if that makes a difference.

    I’m not sure if the fact it’s only some machines having this problem is better or worse than all of them doing it.

    Thank you in advance for reading. I look forward to your replies.

    Grey Fox/James



  • Delayed start tried, but no joy there either I’m afraid.
    I’m going to go through the guide and start fresh with a new, simple image, despite it working fine for the last few years. Just to make sure nothing on the machine could be interferring with anything.
    Failing that I might have to try a completely fresh install on a new server hard drive. Something somewhere is stopping the machines from talking to each other since updating.

    Thanks

    James


  • Developer

    have you tried setting the fog service on the computer to a delayed start?



  • Hmm. I have tried removing some of these devices and registering again. I could export everything, create a new install of FOG and import to see if that makes a difference. But again, it’s just laptops it’s struggling with.

    When I recreated the Sysprep file from the tutorial thread (edited a bit as I’m using 32bit):

    http://fogproject.org/forum/threads/how-to-setup-ubuntu-server-fog-1-2-0-create-univeral-windows-7-image-using-sysprep-step-by-step.11245/

    …my machine had a different name than usual. We use Lanschool, (classroom monitoring software) which is preinstalled on the image. Somehow this is active at the machine naming screen we get after the machine image is deployed. Usually the machine name starts with ‘Win’ (we can see this on the teacher/tech viewer) this test with a new Sysprep file didn’t. I’ll try recreating it. I’m fairly sure it wasn’t the Mac address. Although I have seen that before if one of us changes the image etc, but forgets the name.

    They could be causing issues for these machines. It might just be that one or the other has been working up until now. Although I know FOG has worked, as we’ve typed in one name, then the machine has restarted and the name has been changed to what is on our FOG server. I’ll try creating another answer file though and see.

    Sticking that into my browser gives the following results:

    #!ok=V2Image #AD=1 #ADDom=XXXX.local #ADOU= #ADUser=XXXX.local\administrator #ADPass=XXXX

    Thank you

    James


  • Developer

    unfortunately, the log i’m really needed to see the info in still doesn’t have it. the “all ticked” log is full of entries from guiwatcher and snapinclient, which indicates that the host might not be found in the fog database properly.
    you mentioned that your "current test laptop had a randomly generated name"
    are you sure it’s random and isn’t the mac address? when you quick register a computer in fog, that’s it’s name, the mac address.
    a sysprep answer file and the fog hostnamechanger are two different ways to rename and join a computer to the domain, they’re not really meant to be used together. perhaps they’re causing problems with each other? i don’t know.
    what do you get if you go to <fog-address>/fog/service/hostname.php?mac=58:91:CF:43:07:AB|78:45:C4:C9:0A:A3 ?



  • Hi again,

    Hopefully these are a bit longer. I’ve added an extra 0 to the size in the config file.

    Wireless card left on for both deployments.

    Thank you

    James

    FOG - All ticked.txtFOG - No ticks.txt


  • Developer

    the log files are a bit to short, they cut out before they get to what i wanted to see.
    if you could increase the log file size in the client config and reupload, that would help



  • It is indeed. We use certain names for physical serves and others for Hyper-V clients. But FOG-SERVER was used in testing and I just stuck with it.

    Thanks

    James


  • Senior Developer

    Is your fog server’s hostname really FOG-SERVER?



  • Hi Junkhacker, thank you for your reply. Please find attached two FOG log files. No ticks under ‘Service Settings’, wireless card disabled. The other with all boxes ticked. This one has the original log after first log in, then an additional few entries after a manual restart, wireless card enabled.

    Thank you

    James

    All Ticked.txtNo Ticks.txt


  • Developer

    could you upload a fog.log from a failing client, and have you made sure that hostNameChanger is enabled for all of those hosts on the host management service settings page?


Log in to reply
 

460
Online

38717
Users

10545
Topics

99837
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.