Fog client - HostnameChanger Host name was not found in the database



  • On the client (virtualbox installed) the hostname changer does not find the hostname “HostnameChanger Host name was not found in the database.” But the hostname is in the database.

    When the hostname changer first fails, does the hostname changer search for the hostname or the mac?

    Is it possible to push a hostname change and a domain join from client menu? (basic tasks)

    FOG Version: SVN 2604
    OS Version: Ubuntu 14.04.1

    Clients: Windows 8.1

    [url="/_imported_xf_attachments/1/1500_fog.zip?:"]fog.zip[/url][url="/_imported_xf_attachments/1/1501_fog-client-configini.zip?:"]fog-client-configini.zip[/url]



  • Now its working!! Thanks a lot!
    :):)


  • Developer

    “123”,“5”,“08:00:27:00:b8:07”,"",“0”,“0”,“0”,“0” tells me that it is not a “pending” address, but has been actually confirmed for a client. that is probably your problem. that mac should not be confirmed on any host for identification purposes, as it is shared among multiple computers.
    on host nr 5’s management page, check the checkbox to ignore MAC on client for the virtual adapter, or perhaps delete it.
    if you delete the mac, it should automatically be added back later as pending



  • The mac of the virtualbox network adapter is: 08:00:27:00:b8:07 (always the same)

    It is only once in the hostMAC table:

    “123”,“5”,“08:00:27:00:b8:07”,"",“0”,“0”,“0”,“0”

    i think it is 0 (the last but one entry above)

    The computer with the id 6 has the same virtualbox network adapter with 08:00:27:00:b8:07. But it is not in the table hostMAC.

    host nr 5 has two entries in the hostMAC:

    “123”,“5”,“08:00:27:00:b8:07”,"",“0”,“0”,“0”,“0"
    “1421”,“5”,“08:2e:5f:2b:26:54”,”",“1”,“0”,“0”,“0”

    Should I delete host nr5 ?


  • Developer

    you said you have virtualbox installed. check the mac address of the virtualbox network adapter. does it’s mac address exist more then once in the hostMAC table of the fog database? is it’s hmIgnoreClient value 0 or 1?



  • Is not working:

    Changed the fog service to delayed start.

    Got client fog.log:


    13.11.2014 15:01 FOG Service Engine Version: 3
    13.11.2014 15:01 Starting all sub processes
    13.11.2014 15:01 14 modules loaded
    13.11.2014 15:01 * Starting FOG.AutoLogOut
    13.11.2014 15:01 * Starting FOG.SnapinClient
    13.11.2014 15:01 * Starting FOG.DirCleaner
    13.11.2014 15:01 * Starting FOG.DisplayManager
    13.11.2014 15:01 * Starting FOG.GreenFog
    13.11.2014 15:01 * Starting FOG.GUIWatcher
    13.11.2014 15:01 * Starting FOG.HostNameChanger
    13.11.2014 15:01 FOG::GUIWatcher Starting GUI Watcher…
    13.11.2014 15:01 * Starting FOG.HostRegister
    13.11.2014 15:01 FOG::AutoLogOut Starting process…
    13.11.2014 15:01 FOG::GreenFog Sleeping for 50 seconds.
    13.11.2014 15:01 * Starting FOG.MODDebug
    13.11.2014 15:01 FOG::HostRegister Starting host registration process…
    13.11.2014 15:01 * Starting FOG.PrinterManager
    13.11.2014 15:01 FOG::MODDebug Start Called
    13.11.2014 15:01 FOG::MODDebug Sleeping for 100 Seconds
    13.11.2014 15:01 * Starting FOG.SnapinClient
    13.11.2014 15:01 FOG::ClientUpdater Starting client update process…
    13.11.2014 15:01 FOG::ClientUpdater Sleeping for 170 seconds.
    13.11.2014 15:01 FOG::DisplayManager Starting display manager process…
    13.11.2014 15:01 * Starting FOG.TaskReboot
    13.11.2014 15:01 FOG::PrinterManager Starting interprocess communication process…
    13.11.2014 15:01 FOG::PrinterManager interprocess comm startup: OK
    13.11.2014 15:01 * Starting FOG.UserCleanup
    13.11.2014 15:01 FOG::TaskReboot Taskreboot in lazy mode.
    13.11.2014 15:01 FOG::TaskReboot Starting Task Reboot…
    13.11.2014 15:01 * Starting FOG.UserTracker
    13.11.2014 15:01 FOG::UserCleanup Sleeping for 14 seconds.
    13.11.2014 15:01 FOG::UserTracker Starting user tracking process…
    13.11.2014 15:01 FOG::HostnameChanger Starting hostname change process…
    13.11.2014 15:01 FOG::HostnameChanger Yielding to other subservices for 6 seconds.
    13.11.2014 15:01 FOG::SnapinClient Starting snapin client process…
    13.11.2014 15:01 FOG::PrinterManager Attempting to connect to fog server…
    13.11.2014 15:01 FOG::HostRegister Attempting to connect to fog server…
    13.11.2014 15:01 FOG::UserTracker Attempting to connect to fog server…
    13.11.2014 15:01 FOG::UserTracker Unknown error, module will exit.
    13.11.2014 15:01 FOG::DisplayManager Unknown error, module will exit.
    13.11.2014 15:01 FOG::TaskReboot Unknown error, module will exit.
    13.11.2014 15:01 FOG::TaskReboot No task found for client.
    13.11.2014 15:01 FOG::HostRegister Unknown error, module will exit.
    13.11.2014 15:01 FOG::AutoLogOut Unknown error, module will exit.
    13.11.2014 15:01 FOG::PrinterManager Unknown error, module will exit.
    13.11.2014 15:01 FOG::HostnameChanger Attempting to connect to fog server…
    13.11.2014 15:01 FOG::HostnameChanger Unknown error, module will exit.
    13.11.2014 15:01 FOG::HostnameChanger Host name was not found in the database.
    13.11.2014 15:01 FOG::UserCleanup Starting user cleanup process…
    13.11.2014 15:01 FOG::UserCleanup Attempting to connect to fog server…
    13.11.2014 15:01 FOG::UserCleanup Unknown error, module will exit.
    13.11.2014 15:02 FOG::GreenFog Starting green fog…
    13.11.2014 15:02 FOG::GreenFog Attempting to connect to fog server…
    13.11.2014 15:02 FOG::GreenFog Unknown error, module will exit.
    13.11.2014 15:02 FOG::DirCleaner Starting directory cleaning process…
    13.11.2014 15:02 FOG::DirCleaner Attempting to connect to fog server…
    13.11.2014 15:02 FOG::DirCleaner Unknown error, module will exit.
    13.11.2014 15:03 FOG::MODDebug Reading config settings…
    13.11.2014 15:03 FOG::MODDebug Reading of config settings passed.
    13.11.2014 15:03 FOG::MODDebug Starting Core processing…
    13.11.2014 15:03 FOG::MODDebug Operating System ID: 6
    13.11.2014 15:03 FOG::MODDebug Operating System Minor: 2
    13.11.2014 15:03 FOG::MODDebug MAC ID 0 08:2E:5F:2B:26:09
    13.11.2014 15:03 FOG::MODDebug MAC ID 1 08:00:27:00:B8:07
    13.11.2014 15:03 FOG::MODDebug MAC POST String: 08:2E:5F:2B:26:09|08:00:27:00:B8:07
    13.11.2014 15:03 FOG::MODDebug No user is currently logged in
    13.11.2014 15:03 FOG::MODDebug Hostname: HLWHLW-PJ7QTFB7
    13.11.2014 15:03 FOG::MODDebug Attempting to open connect to: [url]http://192.168.1.14/fog/service/debug.php[/url]
    13.11.2014 15:03 FOG::MODDebug Server responded with: Hello FOG Client
    13.11.2014 15:03 FOG::MODDebug Module has finished work and will now exit.
    13.11.2014 15:04 FOG::ClientUpdater Attempting to connect to fog server…
    13.11.2014 15:04 FOG::ClientUpdater Unknown error, module will exit.
    13.11.2014 15:04 FOG::ClientUpdater Client update will be applied during next service startup.
    13.11.2014 15:04 FOG::ClientUpdater Client update process complete, exiting…


    hostsMac: “1447”,“6”,“08:2e:5f:2b:26:09”,"",“1”,“0”,“0”,“0”


    moduleStatusByHost

    “3646”,“6”,“1”,"1"
    “3653”,“6”,“11”,"1"
    “3654”,“6”,“12”,"1"
    “3647”,“6”,“4”,"1"
    “3648”,“6”,“5”,"1"
    “3649”,“6”,“6”,"1"
    “3650”,“6”,“7”,"1"
    “3651”,“6”,“8”,"1"
    “3652”,“6”,“9”,“1”

    Can somebody help?
    Is there another Hostnamechanger Trick for Windows 8.1?

    Thanks Michael



  • I had this same problem a few months ago. The solution was to set the service to delayed start. See this thread: [url]http://fogproject.org/forum/threads/hostname-changer.10622/#post-29029[/url]


  • Developer

    clients are found by mac address. the client only checks the hostname once on startup, it will check again on the next reboot. if hostnamechange is enabled, it will check on every reboot.


Log in to reply
 

463
Online

38969
Users

10710
Topics

101655
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.