Computer sit at [root@10 /]# when scheduled with any task



  • Hello there,

    I am having a problem with some machines not starting scheduled tasks. It is happening with computers all in one room in a building where other computers are being successfully reimaged. The computers were registered with FOG and then given an image task.

    I am using Fog V1.20 on Ubuntu 14.04 and am trying to load a 32-bit Windows 7 Sysprepped image.
    I am getting this problem on:
    –Dell Optiplex 380
    –HP Compaq Elite 8300

    The computers PXE boot, then load bzimage and init.xz, but instead of starting the image task instead sit at a the linux command prompt [root@10 /]#. If I run “fog”, it goes through the standard checks and says “Task is completed, computer will now restart”, but doesn’t actually do anything. In fact, it doesn’t restart, it just sits at the command prompt still, not giving any errors.

    Things I’ve tried:
    I’ve tried to start the fog debug mode, but again, with any fog task I get the same error. I have checked my apache error log and it does not give any errors for the IPs of the machines that I am trying to image. I’ve also checked that the partitions exist and they do. I’ve also tried unregistering and re-registering the machines with fog, but that has not worked either. I have tried rebooting our fog server, but that doesn’t help. I have tried formatting the hard drives, but that doesn’t seem to help either.

    I did have an issue with breaking our fog server by trying to apt-get phpldapadmin on the same machine (not going to try that again), but have since corrected the problem (as far as I can tell), by removing changes made by apt-get. I have not tried re-installing fog. I’ve searched quite a bit and am not sure of what direction to go in now. Thanks for any and all help.


  • Moderator

    @KarlFife

    What version of FOG?

    This is just a guess, but, because imaging works for you with other systems, that particular motherboard might not be supported by the current kernel / inits that you have.

    You could try other kernels… newer ones… older ones…

    If you find one that works, let us know so we can update our hardware lists:
    https://wiki.fogproject.org/wiki/index.php/WorkingDevices
    https://wiki.fogproject.org/wiki/index.php/ProblematicDevices



  • I’m having the exact same problem.

    In our case the board is a Supermicro MBD-A1SRi-2758F-O Mini ITX Server Motherboard. We’re not having trouble with imaging other hosts.

    Noteworthy:
    I am able to complete a quick registration.
    I am able to boot to Memtest

    Perhaps also noteworthy:
    I get the message
    "tsc: Fast calibration failed"
    just init.xz gets to 100%,
    as in:
    /init.xz…OK
    tsc: Fast calibration failed
    [root@10 /]#

    Any help is much appreciated.



  • How do I check specifically that no debug tasks are scheduled? I have not personally scheduled any, and I’m the only one who’s touched the ones I’m working with.

    I just tried to do a quick image and the computer went to the black screen with the cursor blinking like it was trying for a task, but then again just ended up at the terminal prompt after about 10 seconds.

    I’ve checked that an image is assigned and this is the same image we’ve been using successfully on 75 other computers in this building. It is a sysprepped image created in Virtual Box. Machines of the same model type have worked elsewhere with the same image as well.


  • Senior Developer

    Make sure the system is not setup for debug tasks on the scheduled tasks. The screens should not just boot to the terminal prompt.

    The problem as I’m seeing it though, besides this, is the systems aren’t accepting the image either. Are these special images, is there an image assigned, when where the images that are assigned created?


Log in to reply
 

809
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.