Failed to Mount NFS Volume



  • Recently we overhauled our Fog server to run a newer version of Ubuntu and Fog. Presently we are running Ubuntu 12.04 LTS with Fog 1.2.0.

    Since the upgrade, we’ve run into a number of issues. First was with the changeover to the different Option 67 Bootfile name, then issues with the TFTP service on Ubuntu initializing before the computer had secured its IP address (forced a restart 30 seconds after computer startup), and now having issues with uploading an image to the Fog server. Below is the error I am receiving when attempting to load an image:

    [IMG]http://i.imgur.com/rypPr72.jpg[/IMG]

    I’ve done my share of research on the issue. I’ve [URL=‘http://fogproject.org/wiki/index.php?title=Image_Upload:_Error_Checking_Mount’]added .mntcheck files and modified /etc/exports[/URL] and modified the permissions of the images folder to be fully accessible, yet I’m still receiving the error.

    Unfortunately my coworker set up the server and has been unavailable to assist me in tracking down the issue, thus I am being left to figure this out on my own for the time being. I am versed well enough in Ubuntu to know my way around, but that’s it. Given the error and description I am providing, can anyone come up with what else to try/look into to possibly correct the problem?

    If anything needs further clarification or explanation, please feel free to ask.

    Thanks
    -Tony



  • I made the configuration change (took me a bit to find where to make that change) and started another upload task.

    Results: Seems to be working! I’ll hold off on being certain its fixed until it’s completely uploaded, but I have no reason to believe it won’t right now.

    Thanks for the quick replies. Would have taken me a lot longer to have spotted that configuration error. If anything pops up, I’ll reply here, but this upload won’t be for a while as the hard drive is quite large and I’m only able to upload over a 100MB LAN connection.


  • Developer

    well, /media/images is where your storage node seems to think your images are located. you might check that on the storage management page. the default is just /images, if that directory exists on your server, you may want to try changing that setting on the management page



  • Two things:

    1. The directory /media/images doesn’t appear to exist on the server, at least that I was able to find on the filesystem.
    2. When I go over to my windows PC and attempt to access shared/available folders on the Fog server over the network, nothing comes up.

    Dont know if #2 helps any but thought I’d share it.


  • Developer

    can you navigate to the directory /media/images from server?


Log in to reply
 

510
Online

39.3k
Users

11.0k
Topics

104.5k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.