Older laptop no longer pxe boots



  • Laptop model is Itronix XR-1
    We successfully imaged these with our old Fog 0.32 installation. After replacing that with a fresh 1.2.0 Fog installation, we have found that these no longer will boot correctly. Other laptops and PCs are working well with the new Fog server.

    I took a video of the boot process to troubleshoot this and can offer the following:
    Onboard PXE Boot agent shows as "Argon PXE Boot Agent v2.00 (BIOS Integrated)"
    It gets DHCP options OK and connects to the TFTP service.
    It shows “iPXE initialising devices…ok” followed by “iPXE 1.0.0+ (3a02)” banner and list of features. Then:
    [CODE]Configuring (net0 <MAC addr>)… ok
    /default.ipxe… ok
    [URL]http://<fog[/URL] server>/fog/service/ipxe/boot.php… ok
    [URL]http://<fog[/URL] server>/fog/service/ipxe/bg.png… ok[/CODE]

    That is the last successful statement. The screen clears and shows an error message about I/O error:
    [CODE]Could not configure console: Input/output error (http://ipxe.org/1d8c2139)[/CODE]
    which according to ipxe.org is a vesa frame buffer problem. That makes sense since the next thing should be for the menu to display. It is not yet to the point of trying to load a kernel, is it?

    We tried the solution from the knowledgebase for non-PXE compatible cards using the boot cd from etherboot.org but got the same result.

    I tried changing the DHCP option 67 to point back to different boot files other than undionly.kpxe but no luck. The closest I came to success was using a pxelinux.0.old that I found in the tftpboot directory but had no pxelinux.cfg to tell it what to do next.

    I am trying to work through some of the other things on the wiki but many of them are relevant to the older Fog versions using the pxelinux.0

    We hopefully won’t have these older laptops much longer but I guess I will have to spend a little more time trying to troubleshoot this. Can I just add a pxelinux.cfg file somewhere and segregate these few machines with their separate DHCP option to boot pxelinux.0 instead of undionly.pxe or is there something else that I could try?


  • Developer

    it sounds to me like this might need the same fix that is used for hyper-v virtual machines, disabling certain console features loaded in the ipxe boot menu


Log in to reply
 

776
Online

38981
Users

10712
Topics

101676
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.