Windows 8.1 - Rename and Join Domain with some Clones

  • Hi!

    I have a problem with some cloned clients (windows 8.1). I use sysprep with unattend.xml.
    My problem is:

    • Some clones are not renaming and joining domain.
    • When i rename them manually and join them later i think the fogserver does a unjoin and renames them back to e.g. HLWHLW-0VBF8033
    • they have identical hardware


    • i have virtualbox installed (therefore there is a second network adapter)
      FOG Version: SVN 2505
      OS Version: Ubuntu 14.04.1

    Clients: Windows 8.1

    Can someone help me?

    mysql entry for pc:

    hosts: “47”,“e3-d4c9eff2de4a”,“Created by FOG Reg on October 3, 2014, 12:26 pm\ne3-türreihe1-pc-rechts”,"",“7”,“0”,“2014-10-03 12:26:09”,“2014-10-30 10:10:42”,“FOGREG”,“1”,“HLWSP.HLWSPITTAL.AT”,"",“lehreru”,“fake”,"","","","","",“0”

    hostmac: “194”,“47”,“d4:c9:ef:f2:de:4a”,"",“1”,“0”,“0”,“0”


  • Now I am on svn2547.
    After upgrading from 1.2 no clients is renamed and can join.
    Client log is attached.

    Please help!



  • Tried it today but no reaction.
    in an old version (1.2) i tried to download all snapins (had none) and sometimes the computer was renamed and joined the domain. Is there a possibility to do this in the svn version (have installed 2547 today)? Because in the new version the systems says: There are no snapins.

    Is it possible to get the old clients (fog.log) logs after reboot?

    thanks michael

  • I don’t know what the problem is.

    From the looks of it, the module’s aren’t behaving properly.

    Have you tried removing all the service settings, then readding them?

  • Is it possible to review my request?
    Can i send further information?

    Thanks for help in advance


  • Developer

    rereading your issue, i may have been wrong. the fix was implemented in 2497, so if you’re running 2505 you already have it. sorry

  • thanks, will send a response after testing.


  • Developer

    this may be an issue caused by the virtualbox network adapter. as it is software based and on the base image, all of these machines have a second network adapter with the same mac address. if this is the cause, a fix is implemented in the SVN trunk