Error can't evaluate _crs 12311



  • Hi

    Im working with last version 1.2.0 checking how to clone clients, but Im discovering with Hp clients Im having the error

    pnp 00:05 can’t evaluate _crs 12311

    I discovered a very similar thread, but refered with version 0.32

    [url]http://fogproject.org/forum/threads/errors-trying-to-upload-an-image-to-fog.10126/[/url]

    I don’t know how to resolve the problem because every task blocks the process. Im not sure If use the bzimage refered in the thread, because in the new version not exists. How can i solve the problem?

    Thanks!


  • Senior Developer

    absolutely correct from what I can gather.


  • Developer

    From what I can see in this thread and in other posts when searching for that error on the web it seams to not be a “show stopper”. It’s more like a warning but FOG should still be able to do it’s job. AFAIK the warning doesn’t have to do anything with the GPT issue discussed here. Two unrelated things…



  • Did you get a working solution for this? We’ve just bought our first 8 HP Prodesk 400 G1 PCs. We get the same pnp 00:05 can’t evaluate _crs 12311 error but its registered in the database.

    Did you have to reinstall /repartition with MBR instead of GPT?

    Leaving it pushing an image of the default software to the server over the weekend but any heads up on solutions you may have used/found would be appreciated. Thanks
    C


  • Senior Developer

    Almost definitely.

    I think it’s more related to your systems loaded in an EFI state.

    EFI only allows the hdd’s to be GPT.

    Your older images (the unattended) are likely MBR based.

    Creating of the MBR table is probably working fine, but EFI boot can’t work.

    You didn’t offend me, I was just saying I understand what it does. If anything I’m glad you found the link and posted it.



  • It wasn’t meant to offend you. I’m sorry if my words doesn’t sound as they are ment to.
    Since most/all new HP PCs come with GPT and we nearly only buy HP, I would go with it.

    I already tried to install one of my unattendend images to the ProDesk and get bluescreens right after the Windows 7 logo starts to establish while booting. Could GPT/MBR cause this too?


  • Senior Developer

    I know what fix parts does.

    Are you intending to have an HDD of gpt structure or mbr structure?



  • I think fixparts searches for old GPT data on a disk that was formally GPT but now is used with MBR (I have read it [URL=‘http://www.rodsbooks.com/fixparts/’]here[/URL]).
    However I jumped over the step with fixparts and started fog in debug mode and now it seems to work. It is still uploading.


  • Senior Developer

    I’m guessing you’re not wanting GPT partitioned disk.

    You are more likely wanting an MBR partitioned disk.

    This is what fixparts does for you.

    I don’t know exactly what it’s asking or prompting you for, so I can’t be much help. More or less though you want to confirm the settings it wants to change.



  • When I run fixparts /dev/sda I get the message: "This disk appears to be a GPT disk. USE GNU Partetd or GPT fdisk on it! Exiting!"
    I’m sorry if I have not understood you right. Do I have to change any settings?


  • Senior Developer

    The gpt is the issue, the pnp 00:05 can’t evaluate _crs 12311 is nothing to be majorly concerned about as I understand it.

    Please cancel the current tasking and recreate it as a debug task.

    When in the debug task, you will be presented with the command line rather than it just running through the motions.

    Once at the command prompt (e.g. [ root@192 / ] # ) run fixparts and confirm things (assuming you expect the filesystem to be of legacy methods)

    Once you’re done confirming the actions to take in fix parts, it will present you back with the command prompt. Type fog and hit enter, the imaging process will begin. You will likely have to sit in front of the system to hit enter a few times as it’s debug options are trying to allow you to further debug what’s happening.

    To create an upload - debug task, first cancel the current task from the task management page.

    Go to the Host Management page.

    Search or list all hosts.

    Choose your relevant host.

    Click on the host to edit it

    Choose “Basic Tasks” link on the left hand side.

    Click on Advanced options.

    Look for and click on “Upload - Debug”

    Confirm the tasking.



  • Hi,
    I have similar issues working with an HP ProDesk 490 G1.
    From starting the machine to the FOG bootscreen everything works fine, but when I want to schedule any task I get the message:

    pnp 00:05 can’t evaluate _crs 12311

    It stays for about 30 seconds on my screen untill the task starts. Even when performing a quick or full host inventory.
    The inventory of the machine works, but when I want to pull an image I get the next error.
    Caution: invalid backup GPT header, but valid main header: regenrating backup header from main header.
    [ATTACH]1455[/ATTACH][ATTACH]1456[/ATTACH]

    [url="/_imported_xf_attachments/1/1455_20141030_102128.jpg?:"]20141030_102128.jpg[/url][url="/_imported_xf_attachments/1/1456_20141030_102204.jpg?:"]20141030_102204.jpg[/url]


  • Senior Developer

    What fix? What do you mean the bzImage file is not used in last version?



  • Hi

    Finally I discovered that the error only produce a timeout and pass to execute the process. I don’t know If will affect other tasks, but for now Im clonning.

    How seems to be ACPI problem, can be very useful to update the fix proposed for new versions, bzimage file really is not used in last version.

    Thanks


  • Senior Developer

    Is the error you’re seeing keeping the imaging part of fog from happening or are you just worried about the error and haven’t tried imaging?


Log in to reply
 

340
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.