PXE-E11: ARP timeout



  • Hi,

    at first I have to say that I am new to FOG and Linux in general and have very basic knowledge.
    I have set up an Ubuntu 12.04 LTS Desktop 64Bit with FOG 1.2.0 using the how to by Liam Sullivan
    ( [url]http://fogproject.org/forum/threads/how-to-setup-ubuntu-server-fog-1-2-0-create-univeral-windows-7-image-using-sysprep-step-by-step.11245/[/url] ) as a virtual machine with VMWare ESXI 5.5.0.
    The installation of Ubuntu and FOG worked perfectly fine and I can access the webinterface as well. So before I start creating images etc. I wanted to check if the PXE-Boot is working. So I created a virtual machine to attempt to boot via PXE, but I get the following notifications:

    PXE-E11: ARP timeout
    PXE-E11: ARP timeout
    PXE-E38: TFTP cannot open connection
    PXE-M0F: Exiting Intel PXE ROM.
    Operating System not found

    I checked the configuration of my DHCP Server (Windows Server 2003 R2) multiple times, changed the NIC of my Ubuntu system from VMXNET 3 to E1000, and checked the ARP Anti-Attack settings of my Switch ([IMG]http://192.168.42.19/skin/custom/menu/desk.gif[/IMG]HP V1910 Switch) and just can’t figure out why it will not work.

    I appreciate every small hint that could help me out!

    Greetings,
    Johannes


  • Developer

    DNSMasq takes less than 5 minutes to configure and can save you a mountain of time troubleshooting. There could be a number of reasons you are experiencing this error. Do you have access to manage/edit the DHCP scope?

    DNSMasq alleviates the need to make changes to the entire scope of the DHCP, I would recommend trying DNSMasq as it has helped many others in the past. DNSMasq involves the installation from apt-get, and a single configuration file, and we already created the template for you in the wiki, you copy and paste and change the ip address information to match that of your location.

    Continuing any further without permission of your Network engineer/manager is NOT recommended. You MUST edit the settings at the DHCP server in order for your server to be seen by your network properly.



  • No I have not, but since I have only very limited time at the moment I might give it a shot later on.
    I am configuring the FOG-Server as my graduation project of my apprenticeship and have to finish very soon…


  • Developer

    Have you thought about using DNSMasq?

    I use this in my locations so that I don’t have to worry about the DNS/DHCP settings being changed, or worry about messing up someone else’s settings. I actually HAVE to use this in my Novell environment to help to resolve to my bootfile and server.

    You can look here and give this a shot to see if it helps to alleviate your issue.

    [url]http://fogproject.org/wiki/index.php/Using_FOG_with_an_unmodifiable_DHCP_server/_Using_FOG_with_no_DHCP_server#DNSMASQ_settings_for_iPXE[/url]



  • I managed to find the problem. It was the dhcp server but I have absolutely no idea why. I installed a new one on a Windows 2012 Server with the same configuration and disabled the one on the Windows 2003 Server and now it works! Are there any known issues regarding Win. 2003 Server?
    Anyways, thanks a lot for your support!


  • Developer

    Could be the switch gear, I have a managed and unmanaged switch that do this from time to time. To fix the managed switch I reboot, or try a different port.

    For the unmanaged switch, I find the cable that feeds my unmanaged switch and I move the cable to another port on my managed gear. This may not be the entire cause of your issue, but be aware that the switch gear could be the problem and not your FOG set up.



  • I have no firewall active, neither a dhcpproxy.
    Besides I also tried to boot a machine which worked with an older version of FOG in another network and got the same problem. So I think an issue on the part of the client configuration could be excluded.


  • Developer

    And in the FOG server? Firewalls? dhcpproxy?


Log in to reply
 

411
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.