Adding Raid to Storage Management



  • Hey guys,

    Quick question if you guys had a fog server prepped up for use and wanted to store the images to a Raid array thats already on the machine what steps should I take to configure it.

    4x 500 HDD Hard Drives prepped up in Raid, just need to mount as images, I tried doing the sudo touch but to no success nothing shows up in the folder or simply I’m not as tech savvy with linux to proceed with this. I’ve also followed the guidelines on one of the wiki’s but no info was provided on what to do next on the fog menu. I proceeded with Storage Management menu but no success.

    History
    I’ve installed fog successfully on Ubuntu 14.04 and 10.04 and the best success I had with uploading images is when I used 14.04 with a 500GB hard drive without messing with anything else in an isolated network.

    Network setup - Isolated network
    Storage - 4x 500 GB Hard Drives

    I can pay anyone who is willing to help via paypal who can assist me I’m already 2 weeks in trying to figure this out and need it done quickly, we can chat via skype and I can put this guy on teamviewer for control I can put it back on Isolated and test from there.

    I’ll keep trying until someone messages me.



  • We have Two raid in our server, 1 for Ubuntu and 1 for the images.

    We just create a link between /images and our storage raid.

    And it work really fine.



  • Guys thanks for assisting and thank you Tom for quickly replying and helping out, I’ve figured out that the best option is to install and have everything in one location, no mounting is recommended in my opinion. I saved myself time just by going to micro center and buying a 2TB drive and installing Ubuntu and Fog, I am using 14.04 and it works just fine I bet older versions work well also but the main thing to remember is that when you try to change where your images are stored on fog it’s not going to be easy.

    What I did to get Fog up and running
    For installing Fog on Ubuntu 14.04

    1. I installed 14.04 with the option to install updates checkmark, then after booting I had the updater request for install and did that. (restarted)
    2. Then I downloaded Fog and installed it on a isolated network with 192.168.1.1 with 2 network options to switch from Online to Fog but this will be offline most of the time so I have the Fog option check mark set to automatically connect to this network when available. The Online is unchecked
    3. I then proceeded with a base image of about 8 GB uploading and found to my surprise that the Size on Server said 3.8 and I was super excited to see that.
    4. Set it to download the image and it was done in a matter of minutes.

    Thank you Fog team for helping out and assisting and creating a great product this is needed in the IT world especially in schools for children.

    Best Regards,

    David



  • Thanks Tom your a genius man, I updated those fields.

    Thanks Vincent your right I had it prepped up like that before if the issue persist I’ll look into what os is best to use

    I just found that the fog username had standard permissions, I gave it administrative permissions. I’ll see if that works


  • Moderator

    I have a fog server on a two disk mirror (raid 1) I setup the raid when I installed Ubuntu.

    That way you get the OS on raid as well as images and you don’t need to mess around too much with where to mount things.

    Also, I mainly use Debian 7 for my FOG server nowadays.


  • Senior Developer

    I don’t think you need to reinstall your ubuntu version.

    Your simplest option right now would be to set your fog username and password properly and place that under:

    Storage Management->All Nodes-><Your relevant node>->Management Username and Password

    And Possibly the:

    FOG Configuration->FOG Settings->TFTP Server->FOG_TFTP_FTP_USERNAME and FOG_TFTP_FTP_PASSWORD

    To change the fog user password, open a terminal and type:

    sudo passwd fog
    

    It will ask you to type a password but it will not give and feedback from the terminal. Once you press enter, it will ask you to type it again. If both attempts are the same it should tell you the password was changed successfully. This will be the password you type in the relevant password fields above.



  • Thanks Tom for helping out earlier,

    So I found out that using ubuntu 14.04 it has a GUI where you can format all the drives and set it as a Raid (Clicking on the check mark and selecting all the disks and it will take care of the rest no need to type in several commands) after mounting setting it up on fog for it to communicate was a bit of a challenge but I’m still undergoing that process as I don’t think it’s registering it to fog that the image is there.

    Here’s my notes I gathered

    NFS error (permission issue)
    To troubleshoot this issue its best to say to follow this guide
    http://fogproject.org/wiki/index.php?title=Image_Upload:_Error_Checking_Mount

    Reason is that even after getting a spare hard drive from no matter where its coming from it needs the mount files in the folder and the dev folder, after searching through I found out they were hidden but I hit CTRL+H and I found them there. I kept on with the step two of the process and was not having the NFS error message anymore.

    Another error message that I have encountered was Failed to mount NFS, so NFS was back again
    I proceeded to follow this guide
    http://fogproject.org/wiki/index.php?title=Change_NFS_location

    Although on one step the config.php file was changed to index.php under this location /opt/fog/service/etc, must be the reason why fog is highly recommended to be installed on lower ubuntu versions and I’m starting to agree with that.

    After following the guide it has no issue uploading an image, but I still don’t see it detecting an image size on server with 0.0, I found a link online where someone was trying to figure this out but they managed to fix it by changing the username and password on fog settings or something similar but I stopped there and thought it might be a permission issue although this could be the fix.

    I followed with the sudo chmod 777 -R /image command but still nothing.

    After I try to deploy the image it will give me an error saying must upload image before deploying image.

    I believe I still need to edit the freespace.php file due to this image where it displays the HDD space on pie chart

    The other image displays where it says Image size on client 8 gb’s but nothing on server.

    I’ll keep breaking night trying to figure this out but if nothing keeps working I’ll goto version 10.04 but it crashed after installing mdadm.

    !Screenshot from 2014-10-18 18:11:43.pngScreenshot from 2014-10-18 18:12:33.png


  • Senior Developer

    (* title edited *)

    It’s okay to suggest you’ll pay, but it’s irrelevant to the title of the topic.


Log in to reply
 

414
Online

38920
Users

10688
Topics

101407
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.