Fog 1.2.0 iPXE not functioning properly on some Win7 Machines



  • So to explain we just upgraded from 0.3.2 yesterday to 1.2.0, and let me be clear, I love all the new features and updates. There is a small issue I wanted to raise and see if others have been having it, or if it’s a known issue, I did some quick scans of the problems threads and didn’t see anyone else with the issue. We have some older machines (Dell OPTI 970), probably only 6-7 clients, that are going to iPXE just fine when they start up in the morning, but when the 3 second timeout occurs and they attempt to boot from the hard drive, the screen freezes and the iPXE client locks up. Of course this is completely avoidable by forcing it to boot from the hard drive during bootup, but is there a log file on the client or something I can provide you with that will make it easier to diagnose why this is occuring? I wouldn’t think so because of the nature of iPXE running before the OS. These do have some older BIOS versions and I was going to attempt to update these to see if it’s as simple as updated iPXE client handling in newer versions. Will report back if this fixed the issue.



  • Turns out the problem is with the dc7900 and ipxe. It looks like according to [url]http://www.fogproject.org/wiki/index.php/WorkingDevices[/url] page that there is a known problem with the dc7900. We have a high percentage of those around here yet, so I’m just going to back rev to .32 until I can get the ipxe thing figured out on the dc7900. The other site had dc5800s and Optiplex980s which both worked fine with 1.2.0 I was able to get the 800 G1 to go fine with the 3.8.8 kernel.



  • So I noticed on the [url]http://fogproject.org/wiki/index.php/WorkingDevices[/url] page that dc7900 doesn’t work b/c of Issues with “Loading boot sector… Booting…”. I’ll do some more investigation. I have about 300 of these devices and want to continue using fog for them. The other site had dc5800s and Optiplex 980s which both worked with the new version of Fog / iPXE. I think I might just go back to .32 until I get rid of the 7900s or have more time to play with iPXE on the 7900. It functions for what I need.



  • I have this same problem except that none of the exit options work. I upgraded from 32 to the latest SVN pull. When it exits from ipxe the computers gives me “non system disk or disk error. press any key to continue”. That message usually means that the hard drive is not found or bad. This is on older HP DC7900. When I do Ctrl Alt Del they start into windows fine.

    It seems that a lot of work has been done from .32 to the current version which I’m grateful for. Is there any kind of documentation on what settings need to be changed if you upgraded? I did a new install at another site without many problems. Some new hardware (HP EliteDesk 800 G1) wouldn’t do pxe properly, but other than that it worked well. Is a fresh install recommended vs an upgrade?



  • Changing the exit type to the GRUB loader fixed it, thanks again.



  • Updated BIOS was a no-go, going to try changing the exit type, thanks for the quick reply


  • Developer

    updating bios can solve this. also you can try setting a different FOG_BOOT_EXIT_TYPE


Log in to reply
 

512
Online

39.3k
Users

11.0k
Topics

104.5k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.