FogFTP: Login Failed



  • We started getting an error while trying to upload an image. It says [I]FogFTP: Login Failed, Host: <serverip>, User: fog, Password: <password>.[/I]

    The password it shows is the correct password. Nothing has changed on that server as far as I know. We have a local “fog” user as well as the fog user within the fog maintenance GUI, not sure which its asking about. Both passwords are the same though. Downloading of images, registration, ect works fine.



  • I don’t have fog as owner on my default installation.

    [CODE]drwxrwxrwx 11 root root 4,0K sept. 30 10:23 images
    [/CODE]



  • Also if I should post my own thread let me know but it seems Scott and I have an identical problem.



  • here are the permissions of my images folder, should mine be correct? all of the images listed within /images have the lock icon.

    [url="/_imported_xf_attachments/1/1396_perm.JPG?:"]perm.JPG[/url]


  • Developer

    try changing it to fog:root



  • root:root drwxrwxrwx


  • Developer

    what are the permissions and ownership of /images?



  • [quote=“Tim618, post: 37267, member: 25256”]Scott- could you elaborate on this a little bit please? I’m getting the same error after moving to a new server. What folder did you manually create??? And what permissions? Thanks.[/quote]

    We manually made the directory in /images to match the name of the image. So uploading an image called “HP1234” meant we had to make a folder in /images called HP1234 and grant 777 rights to that folder.



  • Scott- could you elaborate on this a little bit please? I’m getting the same error after moving to a new server. What folder did you manually create??? And what permissions? Thanks.



  • Thank you for the responses. We found that manually creating the directory the new image was going to and granting rights to that folder corrected the issue.



  • There is 2 different FOG account on FOG in my case.

    • storage account AND TFTP/FTP account that is the local fog account
    • GUI account that is an sql account

    The first one can be seen in storage and in options “TFTP Server” at FOG_TFTP_FTP_PASSWORD.
    I can be used on server TTY, for ssh connexion and FTP.



  • I had a similar problem where my passwords were all correct, but the usernames were incorrect. What I did was change the username to the username of the server, in my case it was ubuntu because that is what I called it, and it fixed the problem. Are you logging in under the fog user on the server? If you got to Fog Configuration -> Fog Settings -> TFTP Server -> verify the username and password is correct to the username and password that you are using on the server. Also go to Storage Management -> Click on your Storage Node -> Verify it is the same username and password as in TFTP Server. I am not sure if you set up a password for MySQL or not, but I left mine blank, so you may have to change the username and password in Fog Configuration -> Fog Settings -> Fog Storage Nodes to match that. I seriously had this same issue, but once I figured out that I was using my ubuntu user and changed the appropriate username and password, it all worked just great. Hope that this helps out.


Log in to reply
 

462
Online

38969
Users

10710
Topics

101656
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.