Partition Resizing (expanding) not working. Windows 7 Single Partition (Resizable)


  • [quote=“jmeyer, post: 37196, member: 6537”]Why i feel that Tom is thinking of me when we speak of 100% partition problem ? :D[/quote]

    Your stuff should be perfectly fine now.


  • @nikonaum

    No, I think this is still EXACTLY the case. The issue is the partition size that gets created is outside the size of your written to disk (as specified earlier in the thread.)

    The issue isn’t in the creating of the disk size to contain the data. As does and it writes the data to the disk after. However, when the “parted” system ran, it couldn’t build your disk even to 99% of the new size of the disk because the partition table was outside the size of the real disk. I know, weird.

    If you right click on the partition and tell it to expand within windows, I’ll bet everything will be perfectly fine. I’m also starting to think you have a “resizer” in the unattend that’s telling the windows system the disk is already a specific size?


  • Why i feel that Tom is thinking of me when we speak of 100% partition problem ? 😄


  • @TomElliot: This is not the case, see attached pictures, this time I deployed the image on a different hardware and the outcome is the same. See attached pictures.

    [url="/_imported_xf_attachments/1/1390_FirstMessage_onLogin.jpg?:"]FirstMessage_onLogin.jpg[/url][url="/_imported_xf_attachments/1/1391_HDD_Allocation.jpg?:"]HDD_Allocation.jpg[/url][url="/_imported_xf_attachments/1/1392_FirstMessage_onLogin.jpg?:"]FirstMessage_onLogin.jpg[/url]


  • In FOG 1.2.0, all the way back to 1.0.0, we were running into issues attempting to assign the disk size to 100% because not all disk geometry’s are the same. To maintain some kind of compatibility, we made the 100% not a required thing and so I could ensure all disks worked, we set the disk size to 99% of the size leaving about 1% of the disk unused/unallocated. I’m thinking this is likely what you’re currently seeing.

    We’ve since learned how to deal with the disks on a much nicer side and disks are now back to using the 100% (without literally specifying 100%.) So I think this is likely the issue. You’re not necessarily going to see anything wrong with the disk, you’re just seeing it using 99% of the available disk space rather than 100% as is usually the case.


  • My VirtualBox partition is that small because I have a small 120GB SSD disk in my laptop. And resizing is still not working, Clonezilla does chkdsk first on the newly downloaded image and then the unattended installation continues. Can someone explain me the bizarre situation with Windows saying there is no enough space on partition C:, but windows disk manager says I have one partition on the whole HDD.


  • I understood that @Junkhacker but tell me, why it’s not expanding the partition of Widows 7 to the whole disk space. Widows disk manager shows the size as 34GB of REALSIZE of HDD(500Gb) but File explorer shows it as 34GB used of 35GB – 700MB free. And Clonezilla image is deployed fine, as expected, but fog is not.

  • Developer

    like i said, on resizeable images fog automatically resizes the partition to a minimum size possible for the amount of actual data on the disk. that’s why it’s smaller. clonezilla doesn’t do that. if you’re using resizeable images, it’s safe to use a larger disk when creating your image.


  • OK, let me show you the difference with the following two pictures.
    1st made 3 hours before, one that is accurately deploying made with clonezilla and Partclone 2.70:
    And one made by FOG and partclone 2.69:
    The difference is that the one that deploys correctly is calculated as 37GB by Clonezilla, the other is much smaller.

    [url="/_imported_xf_attachments/1/1386_MadeByClonezilla.jpg?:"]MadeByClonezilla.jpg[/url][url="/_imported_xf_attachments/1/1387_MadeByFog.jpg?:"]MadeByFog.jpg[/url][url="/_imported_xf_attachments/1/1388_MadeByFog.jpg?:"]MadeByFog.jpg[/url]

  • Developer

    why use such a small virtualdisk? when using resizeable image types, the partitions are automatically reduced to the smallest reasonable size to contain the data before an image is pulled, making them deploy-able on drives that are are smaller then the drive you built the image on, so long as the amount of data will fit.


  • I created Universal Image Based on the Windows 7 SAD2 topic in the forum, created custom unattended.xml with some tweaks, basicly regional settings, fake serial number and so on. The image upload and download was working properly and resized the partition accurately to the maximum size of the partition, but recently it stopped doing this (the resizing).

    I’m using VirtualBox for creating the Master Windows Installation. My virtual disk is 35GB and my windows install is 33GB, so I have 1.9GB free space. I began suspecting that the insufficient disk is the reason of the incorrect resizing.

    P.S.: I was making a multipartition Image of the Universal Image with clonezilla, and sometimes I have the same problem. Partclone in Clonezilla shows: “Device Size: 37.5GB” (partclone ver. 2.70), but in fog it shows: “Device Size: 32.7GB” (partclone ver. 2.69).

    So to summarize: My VirtualBox virtual disk size is 35GB, When making the image from VirtualBox and it shows Device Size: 37.5GB the resizing works, but when it shows: “Device Size 32.7GB” it does not work. The interesting thing is that it sometimes does it with clonezilla, which I’m booting via fog server with custom PXE boot menu.


  • Question?

    When the Master Image was setup, did you do it based on a complete fresh install of Windows or did you leave the defaults from the factory?

    Is all actually operating properly?

    I only ask because I’ve tried to replicate this issue. My disks are sized down to 20GB, upload image as resizable. Image to a 50GB disk (sorry I only have vms and limited space). Image correctly expands without issue.

  • Developer

    I use the Unattend.xml to expand my partition to the end of the disk.

303
Online

9.1k
Users

15.7k
Topics

145.8k
Posts