Image Size: ON SERVER Error



  • Hello. I am running FOG 1.2.0 and it has been working great for a few weeks. Today, I did a download unicast to 20 PCs, which worked without any issues. However, when I go into Image Management->List All Images, I see all of my images but under Image Size: ON SERVER, this error message comes up:

    FOGFTP: Login failed. Error: ftp_login (): Login incorrect.

    I uploaded two images last night and did not have this problem. I changed the Storage Node Max Clients from 10 to 20 this morning but I don’t see why that would have changed anything. About 2 or 3 weeks ago, I did go to User Management and changed the password for the fog user but I’ve uploaded several images since that password change.

    Any suggestions on what the problem could be? Thanks for the help!


  • Moderator

    @sagar

    You must also have the local Linux user set with the same credentials.

    There’s an article in the wiki called “Troubleshoot FTP” that will tell you all about it.



  • @Heath-Grim is it ok if i have all 3 passwords same: as in tftp-ftp, fog login and also Storage Management->All Storage Nodes->DefaultMember? I have set all 3 to credentials as: fog/password


  • Senior Developer

    It shouldn’t have changed that password field at all though that’s not to say there couldn’t be an error in the code.



  • I tried uploading a new image and it uploaded up to 99% when the ftp login error message came up and it kept appearing after each failed attempt. Again, I uploaded two images last night without any problems at all. The only thing I changed this morning was the Storage Node Max Clients from 10 to 20.

    Here’s what fixed this issue for me…

    Under User Management->List All Users, I have a ‘fog’ user account and this username/password is what I use to login to FOG Management Console. Under FOG Configuration->FOG System Settings->TFTP Server, I have fields for FOG_TFTP_FTP_USERNAME and FOG_TFTP_FTP_PASSWORD. The username is the same as under User Management but the password is different. I did not set this password so it must have been generated during installation. Now if I go to Storage Management->All Storage Nodes->DefaultMember, there are fields for Management Username and Management Password. The username is the same as the other two but the password was set to the User Management password. Once I changed this password to the FOG_TFTP_FTP_PASSWORD, my image upload immediately finished and all of my images now show a size listed for Image Size: ON SERVER instead of the failed ftp login message.

    It almost seems like by changing the Max Clients from 10 to 20 updated the password to match the password for the fog user account under User Management. It seems strange but changing the password to match that of the FOG_TFTP_FTP_PASSWORD fixed my issue.



  • I have not updated the OS since I installed updates before installing FOG. I’m running FOG 1.2.0 on Ubuntu 13.10.


  • Senior Developer

    Did you do an OS update recently?


Log in to reply
 

439
Online

38939
Users

10697
Topics

101495
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.