Display time in 24 hours in host management



  • Is it possible to change display time to 24 hours:

    example: 23:12

    I have already changed

    date.timezone = Europe/Vienna

    in php.ini.

    So the time is correct.

    This is only wrong in host management. The list in task managment shows the time in 24 hour format.

    Thanks

    Michael


  • Developer

    you may try editing the settings in [code]/etc/php5/cli/php.ini[/code]



  • fogversion 1.20
    Ubuntu 14.04 LTS

    [url]http://pastebin.com/WE0id9kf[/url] (error.log)

    [url]http://pastebin.com/SGZUgXLt[/url] (foginstall.log)

    Already checked wiki and forum.

    thanks

    michael


  • Developer

    [quote=“holzfisch, post: 36898, member: 26225”]ubuntu[/quote]

    what version -.-

    You may also try Tom’s suggestions above.


  • Senior Developer

    If you upgrade to SVN, I’ve changed the formatting of the time settings to display hours, seconds, and minutes, months, days, years.

    It will not display the direct time of deployment. Hopefully this helps give a better understanding of When something occurred vs. What time something occurs. It’d be too much to try figuring out how best to represent the time variables as you’re seeing here.

    The DB stores the data in: YYYY-MM-DD HH:mm:ss mode. Meaning The hours are always stored in the DB as 24 hour format. So depending on how it’s to be displayed it may show the DB value or a “neatly” formatted time setting.

    There’s too many variables to figure out. So I’ve simplified it so it just displays the round about timing it last ran. VS trying to guess how people are going to want to view their times.



  • ubuntu


  • Developer

    what operating system did you install FOG on?


Log in to reply
 

355
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.