Added new NFS node, dont see pie chart - "failed to connec to"



  • Hi there,

    Been using fog for a few months now and all has been good.

    Was on 0.32 and upgraded to 1.2.0. Also added a 1TB node and made it the master node.

    Everything thing is working fine, snaps in, uploads and downloads.

    The only issue i have is i cant see the pie chart that shows the space on the node. Doesnt seem to show transfer speed or “server information” either.

    Anyone got any ideas?

    Many thanks!



  • [IMG]http://s27.postimg.org/4jsxfuugz/Capture.png[/IMG]

    the fog username and password was the one that was given when I ran installfog.sh and setup the node.


  • Senior Developer

    Now, on the main fog server, the node is setup correctly as well?

    Meaning from Storage Management Page -> List all nodes -> (Click the relevant node) the ip, fog username and password, are all correctly setup and functioning?



  • yes seems to connect fine.

    mysql -u’fogstorage’ -p’xxxxxx’ -h’10.1.106.54’ fogReading table information for completion of table and column names
    You can turn off this feature to get a quicker startup with -A

    Welcome to the MySQL monitor. Commands end with ; or \g.
    Your MySQL connection id is 6461
    Server version: 5.5.37-0ubuntu0.13.10.1 (Ubuntu)

    Copyright © 2000, 2014, Oracle and/or its affiliates. All rights reserved.

    Oracle is a registered trademark of Oracle Corporation and/or its
    affiliates. Other names may be trademarks of their respective
    owners.

    Type ‘help;’ or ‘\h’ for help. Type ‘\c’ to clear the current input statement.


  • Senior Developer

    What other steps have you done?

    Have you ensured the Node’s information is all correct?

    From the node, can you connect to the FOG Server?

    From the node, open terminal or console:
    [code]mysql -u’fogstorage’ -p’FOGSTORAGEPASSWORDAS RECEIVED ABOVE’ -h’10.1.1.10’ fog[/code]



  • so changed it too:
    #bind-address = 127.0.0.1

    restarted mysql and still isnt showing harddisk information.


  • Senior Developer

    [quote=“Duncan, post: 36670, member: 26100”]this is the my.cnf file:

    [mysqld]

    * Basic Settings

    user = mysql
    pid-file = /var/run/mysqld/mysqld.pid
    socket = /var/run/mysqld/mysqld.sock
    port = 3306
    basedir = /usr
    datadir = /var/lib/mysql
    tmpdir = /tmp
    lc-messages-dir = /usr/share/mysql
    skip-external-locking

    Instead of skip-networking the default is now to listen only on

    localhost which is more compatible and is not less secure.

    bind-address = 127.0.0.1

    The Config.class.php all seems to be correct.
    DATABASE_HOST
    DATABASE_USER
    DATABASE_PASSWORD

    all seem to be correct.[/quote]

    The bind-address line should be commented out:

    [code]bind-address = 127.0.0.1[/code]

    Should be:
    [code]#bind-address = 127.0.0.1[/code]



  • this is the my.cnf file:

    [mysqld]

    * Basic Settings

    user = mysql
    pid-file = /var/run/mysqld/mysqld.pid
    socket = /var/run/mysqld/mysqld.sock
    port = 3306
    basedir = /usr
    datadir = /var/lib/mysql
    tmpdir = /tmp
    lc-messages-dir = /usr/share/mysql
    skip-external-locking

    Instead of skip-networking the default is now to listen only on

    localhost which is more compatible and is not less secure.

    bind-address = 127.0.0.1

    The Config.class.php all seems to be correct.
    DATABASE_HOST
    DATABASE_USER
    DATABASE_PASSWORD

    all seem to be correct.


  • Senior Developer

    What?

    the my.cnf only affects the mysql server. While the storage node could contain a mysql server, if you installed it as a node it should NOT have any mysql data. The Config.class.php on the Node would need to be 10.1.1.10 for the DATABASE_HOST, the DATABASE_USER should be fogstorage, and the DATABASE_PASSWORD would be typed in. You can get the password from the Main fog server under: FOG Configuration -> FOG Settings -> FOG Storage Nodes -> FOG_STORAGENODE_MYSQLPASS. Click the “eye” and you will see the plain text password. This is the password that should go in the DATABASE_PASSWORD line of the node’s relevant Config.class.php file.

    Did you make sure the bind-address was commented or removed from the 10.1.1.10 server?



  • thanks for the reply.

    I have done that and on the “main” fog machine. lets say the ip is 10.1.1.10 The main on is the 10.1.1.10/fog that i connect too.

    So say the storage node is 10.1.1.20. do i need to point the my.cnf on the storage node to the main fog ip addess?


  • Senior Developer

    Make sure the “main” fog server, the one your node connects to, has it’s my.cnf file with a commented out bind-address = 127.0.0.1.

    I’m going to guess your OS is ubuntu which enforces the bind-address parameter.

    [code]sudo sed -i ‘s/bind-address\ =\ 127.0.0.1/#bind-address\ =\ 127.0.0.1/g’ /etc/mysql/my.cnf[/code]

    I think the above code would work, but you may have better luck just in case by manually editing the file with whatever editor you feel most comfortable with. Once changed, you’ll have to restart the mysql server:
    [code]sudo service mysql restart[/code]


Log in to reply
 

413
Online

38993
Users

10713
Topics

101700
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.