• I have an Ubuntu 10.04.4 LTS server running FOG v 0.32. This was initially just a test run to get FOG working the way I wanted before committing to a better platform (the test-bed only has a 160GB drive). Having gotten FOG up and running with success in uploading and downloading images, I was eager to move forward to a new server

    New server is Ubuntu 14.04 LTS running FOG (I was VERY excited to learn of new versions of FOG!). I’ll be up front and state that I didn’t do due diligence on migration from old FOG to new FOG and probably didn’t do something right. Nevertheless, I did copy all of the system images from old to new and followed the link below to migrate the database from old to new:


    After all of that, I’m able to get PCs to the FOG menu but when I attempt to do a full or quick registration, I get the following message at the end of the prompts:

    [QUOTE]attempting to send inventory… no host found for MAC address xx:xx:xx:xx:xx:xx[/QUOTE]

    Anyone want to shed some light on this? Muchas gracias!

  • Okay, gave up on this since I needed an operational image server to finish deploying PCs that replaced the last of our XP boxes. Uninstalled Fog on 14.04 following these instructions ([B]excluding[/B] the removal of the /images directory):

    Re-installed Fog 1.2.0 on same Ubuntu 14.04 server. Existing images from old Fog server still in /images. I opted not to try to import anything else from the old Fog 0.32 server. Created new image entries and assigned the corresponding image file names. I did a trial run by uploading an image from a Dell OptiPlex 390 with some success. Will be testing more today for functionality and stability.

  • [quote=“zilla1126, post: 36487, member: 25588”]I don’t other people’s experiences, but I and a bonified linux expert spent a few hours trying to get fog 1.2 working with ubuntu 14.

    We gave up and installed Ubuntu 12.04.5 LTS. Worked nearly right out of the box.


    I have Ubuntu 14.04 installed just for the reasons given here. I wanted to replicate what others have seen.

    While I don’t recommend Ubuntu 14 for everybody, I also had no problems and it is now my primary dev box. My dev machine (the one I actually submit code from) is Centos 6.5, my three “test” servers are Centos 6.5, Ubuntu 14.04, and just for fun, a windows box running WAMP. I don’t see any issues with either of them.

  • Banned

    This post is deleted!

  • Correct. I just walked through the process again to be sure. Create New Host -> enter info -> Add. After clicking Add, I go back to the the list of hosts, but no added host.

  • When you say no error, there’s no message at the top of the screen either?

  • Old server host list


    New server host list


    No error messages when trying to manually add via web interface.

    The host name and associated MAC address DID exist on the new server previously (all carried over during the migration from old server to new server). But I deleted that host thinking it might have been causing a problem when I ran into issues trying to get that machine to upload it’s image to the new Fog server. However, as stated, recreating it has been unsuccessful.


  • No errors?

    The hostname you have on record that you’re attempting to assign for this host already exist?

    On that “same” hostname, does it have the MAC of the system stored either as Primary or Registered MAC?

  • [quote=“Tom Elliott, post: 36460, member: 7271”]Hmmm,

    Did a host get created with the right MAC Address that’s being sent?[/quote]

    No, no host entry for that MAC address in the hosts list.

    Interestingly enough, I tried to manually add a host entry for the node in question, and although it accepted the input (and no error messages)… there is no new host entry in the hosts list.

    :: scratching head ::

  • Hmmm,

    Did a host get created with the right MAC Address that’s being sent?

  • Here’s the DHCPD.CONF config file from the DHCP server:


    DHCP Server Configuration file.

    see /usr/share/doc/dhcp*/dhcpd.conf.sample

    This file was created by FOG

    use-host-decl-names on;
    ddns-update-style interim;
    ignore client-updates;
    allow booting;
    allow bootp;

    subnet netmask {
    option subnet-mask;
    range dynamic-bootp;

        option domain-name "mylan.lan";
    option routers;
    option domain-name-servers,;
    option broadcast-address;
        default-lease-time 21600;
        max-lease-time 43200;
        filename "undionly.kpxe";


  • Developer

    FOG where do i get a copy of that?
    did you reconfigure your DHCP server to serve out undionly.kpxe instead of pxelinux.0?