FOG 1.2.0 - Some Win7 images joins AD without permission



  • Hi, I’m using FOG 1.2.0 on Ubuntu 12.0.4 LTS (fresh install).
    I’ve imported some partimage images from the old FOG Server 0.32, without problems. The images is Windows 7 x64 SP1 (updated and SYSprepped correctly, working perfectly on FOG 0.32) for DELL Optiplex 3010 and DELL Latitude E4300.
    Now, I’ve this strange problem: when I restore the Latitude Image, all goes fine.
    When I restore the Optiplex image, after 1 minute or less, the machine reboot and automatically join the domain, regardless of the option to join AD (that is unchecked).

    At this time, the only thing I can do is to delete the default AD settings in FOG GUI / FOG Configuration /Active Directory, to avoid the automatic join of the Optiplex machines, but it’s a workaround and i wish to find a solution.

    Any suggestion?
    Thanks, (FOG rocks!)


  • Developer

    had the window open for a while and posted that without refreshing the thread. happy to hear you figured it out.



  • [quote=“Junkhacker, post: 36456, member: 21583”]is there an unattend file on the optiplex image that is joining the computer to the domain, instead of fog?[/quote]

    no, I’m pretty sure that was the old FOG server… I’ve personally made the master Windows 7 image, I’ve only sysPrepped without any unattend.xml file ;)
    Now the old server is powered off (again) and no issues anymore.

    Thanks anyway


  • Developer

    is there an unattend file on the optiplex image that is joining the computer to the domain, instead of fog?



  • First, thank you for the fast response! The problem is gone, and the explanation is very simple (and stupid):
    a colleague of mine has powered on the VM of the old FOG server without telling me; the old server have the same IP of the new FOG server, and the Auto Join AD flag set to “ON”. So, when I restored the image, the FOGClient takes that setting from the OLD server instead of the new…

    Curiously, even with two servers with the same IP, at boot time the new server always win and load the iPXE image.

    Sorry, my (colleague) fault.
    Many thanks! :)


  • Senior Developer

    When you go to the link:
    [url]http://fogserveriphere/fog/service/hostname.php?mac=XX:XX:XX:XX:XX:XX[/url]

    (Changing XX:XX:XX:XX:XX:XX to the MAC of the weird acting machine, and fogserveriphere to the IP Address of your fog server)
    Does the #AD= flag have a value or is it blank?


Log in to reply
 

442
Online

38948
Users

10699
Topics

101513
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.