Problems installing Fog on Ubuntu 14.04



  • Hi everyone I am new to this forum. I recently installed Ubuntu 14.04 workstation 32bits. No problem there. I am trying to install fog because I am IT in a school that has 5 building and each one has at least 20 pc’s and two of the buildings has 4 computer rooms with 20 pc’s each. So you understand how FOG would help me out very much. So my problem is that pc’s are in a private network that I had to ask to give me a door in one of the switches so that I can connect the machine that will work with the FOG Server. One of the Problems is that the door they gave me doesn’t have internet and no DHCP. And when I install FOG I need internet to install the sql so I install it with outer ip config and after installed I config the network with the final ip, and it won’t work. What am I doing wrong!!!



  • [COLOR=#ff0000][B][SIZE=4]It´s undionly.kpxe any version 1.0.0 or higher:oops: sorry[/SIZE][/B][/COLOR]

    Ubuntu Server to Fog 1.2.0
    ]#### add by racl

    subnet 192.168.212.0 netmask
    255.255.255.0{
    option routers 192.168.212.1;
    option subnet-mask 255.255.255.0;
    option domain-name-servers 80.58.61.250, 80.58.61.254;
    range 192.168.212.8 192.168.212.254;

    filename “undionly.kpxe”;
    next-server 192.168.212.5;


  • Senior Developer

    WHY IS THE FILENAME pxelinux.0 when using 1.0.1 or any version 1.0.0 or higher??



  • Using SmoothWall Express 3.0 to Fog 0.32

    [IMG]http://fogproject.org/forum/attachments/sshot-1-png.753/[/IMG]



  • Could you install fog? or not?, and if you installed it, you test them running locally?

    Fog has two types of installation with DHCP server enabled or disabled.

    You have to consider what kind of DHCP server on the network to configure access to FOG from computers.

    Examples to Linux servers:

    Ubuntu Server to Fog 0.32
    [SIZE=4][B][B][SIZE=3]#### add by racl[/SIZE][/B][/B][/SIZE]

    [SIZE=4][SIZE=4][B][B][SIZE=3]subnet 192.168.212.0 netmask 255.255.255.0{[/SIZE][/B][/B][/SIZE][/SIZE]
    [SIZE=4][SIZE=4][B][B][SIZE=3] option routers 192.168.212.1;[/SIZE][/B][/B][/SIZE][/SIZE]
    [SIZE=4][SIZE=4][B][B][SIZE=3] option subnet-mask 255.255.255.0;[/SIZE][/B][/B][/SIZE][/SIZE]
    [SIZE=4][SIZE=4][B][B][SIZE=3] option domain-name-servers 80.58.61.250, 80.58.61.254;[/SIZE][/B][/B][/SIZE][/SIZE]
    [SIZE=4][SIZE=4][B][B][SIZE=3] range 192.168.212.8 192.168.212.254;[/SIZE][/B][/B][/SIZE][/SIZE]
    [SIZE=4][SIZE=4][B][B][SIZE=3]# Configuracion de un equipo en cuestion con soporte PXE[/SIZE][/B][/B][/SIZE][/SIZE]
    [SIZE=4][SIZE=4][B][B][SIZE=3] filename “pxelinux.0”;[/SIZE][/B][/B][/SIZE][/SIZE]
    [SIZE=4][SIZE=4][B][B][SIZE=3] next-server 192.168.212.5;[/SIZE][/B][/B][/SIZE][/SIZE]
    [SIZE=4][SIZE=4][B][B][SIZE=3]}[/SIZE][/B][/B][/SIZE][/SIZE]


  • Moderator

    pxelinux.0 - sounds like your using the old version of FOG.

    Also, drop in on IRC. there are some good people around who can help with initial stuff.

    I also use FOG in education, saves lots of time, and no need to go to each PC.

    Make sure you try out the Location Plugin. might work for you depending on how fast your links are between buildings.



  • Open a terminal (or ssh into the FOG server) and type “cat /etc/dhcp/dhcpd.conf” (without the quotes) This will dump your current dhcpd configuration.

    To edit from the command line use the text editor of your choice (Example will use nano) like this:

    sudo cp /etc/dhcp/dhcpd.conf /etc/dhcp/dhcpd.conf.old
    sudo nano /etc/dhcp/dhcpd.conf

    At this point the conf file should look something like:

    DHCP Server Configuration file.

    see /usr/share/doc/dhcp*/dhcpd.conf.sample

    This file was created by FOG

    use-host-decl-names on;
    ddns-update-style interim;
    ignore client-updates;
    next-server 123.45.67.5;

    subnet 123.45.67.0 netmask 255.255.255.240 {
    option subnet-mask 255.255.255.240;
    range dynamic-bootp 123.45.67.x 123.45.67.y;
    default-lease-time 21600;
    max-lease-time 43200;

    option domain-name-servers x.x.x.x;

    option routers x.x.x.x;

    filename “undionly.kkpxe”;

    }

    Make your edits, and once finished type ^x (ctrl+x) then y (save file) and enter (with current name)

    Ey3



  • Ok so I got it to work!! Now my problem is the DHCP. They gave me this : Next Server: 10.1.8.1 ; [SIZE=2]Bootfile: pxelinux.0 but I not know how to do it. I have almost no [/SIZE]experience in linux. they say I have to edit the dhcpb.config file but as I said I have no clue. Can Anyone Help me please!!![SIZE=2] [/SIZE]


Log in to reply
 

488
Online

39003
Users

10718
Topics

101766
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.