Reopening network devices...



  • Hello!

    FOG-revision: 1726
    Ubuntu 12.04.5 LTS

    I have new pcs and tried to register them, but the kernel fails after it load for around 7 minutes:
    [CODE]IPConfig: Reopening network devices…[/CODE]

    I looked trough the forum and tried lots of other kernels from the Kernel Update page, but every kernel fails with the same problem.

    specifications of the pc:
    motherboard: B85M-E
    Chipset: [SIZE=12px][FONT=Segoe UI][COLOR=#333333]Intel B85[/COLOR][/FONT][/SIZE]
    [SIZE=12px][FONT=Segoe UI][COLOR=#333333]Graphic: (onboard) [/COLOR][/FONT][/SIZE][FONT=Segoe UI][COLOR=#333333][SIZE=12px]Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller[/SIZE][/COLOR][/FONT]
    [FONT=Segoe UI][COLOR=#333333][SIZE=12px]LAN (onboard): [/SIZE][/COLOR][/FONT][SIZE=12px][FONT=Segoe UI][COLOR=#333333]Realtek 8111F[/COLOR][/FONT][/SIZE]
    [SIZE=12px][FONT=Segoe UI][COLOR=#333333][/COLOR][/FONT][/SIZE]
    Anyone have an idea, what I could try?

    Thanks,
    Lukas



  • Network issues I’ve experienced: STP taking too long to enable forwarding between network stack reloads, poor quality network wire or damaged runs (this is where I experienced your exact error message, it will work on dhcp, but fail on bigger packets), and amazingly enough, bugs in the switches (in my case, Cisco SG200’s with layer3 protection that could not be disabled - a firmware fix is available now) that caused issues with UDP on privileged port ranges (NFS), and slow DHCP servers.


  • Developer

    Sometimes the network issues can be alleviated by using DNSMasq to proxy serve your bootfile.

    It would be worth a shot (because you don’t have to edit anything in your network). I have to use DNSMasq in my environment because it is Novell (which has boot file name limitations,) and I also have a few other imaging methods (such as WDS) that other co-workers feel more comfortable using. So I use the DNSMasq option in my buildings so that everything can resolve to my FOG server instead of the WDS server.

    If you’re interested in seeing if dnsmasq will solve the issue (I know I am!) please use the following guide on the wiki: [url]http://fogproject.org/wiki/index.php/Using_FOG_with_an_unmodifiable_DHCP_server/_Using_FOG_with_no_DHCP_server#DNSMASQ_settings_for_iPXE[/url]

    Good luck and let us know if it works, or how you solve your issue regardless!



  • I tried a test, where I connected the pc and fog server directly over an switch and the problem disappeared, looks like some problems with the network o_O. Will look into that…


  • Senior Developer

    While this is normally considered as a kernel issue, one thing I’d recommend is changing out the undionly.kpxe files with the one in svn.code.sf.net/p/freeghost/code/trunk.

    There were some issues, from what I understood of the ipxe stuff, that the network device wasn’t released properly from undi/ipxe cache in ram after loading into initrd and bzImage. Maybe this can help you out?


Log in to reply
 

467
Online

39.3k
Users

11.0k
Topics

104.5k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.