FOG version 1.2 images will not deploy



  • I am having an issue when we create and upload an image, the image seems to upload fine, but when we deploy it, we get the error “cannor find image store”. I see the image is in the folder named by the upload machine’s mac address in /images/dev, but my storage node is set to /images. Tom Elliot had me upgrade Fog to sub version 2203, but this hasn’t helped. I have ran chown -R fog /images and also set read/write/execute permissions on this folder and all sub folders just to make sure that wasn’t it.

    We are running Fog on Ubuntu 13.10. We really depend on FOG to deploy images for our school system computers and right now we cannot deploy any new images. This was a new install on a vm, but we migrated images from our old 0.32 box.



  • [quote=“neilm, post: 37138, member: 24150”]has this been resolved? i checked all settings and can login to ftp with broswer and filezilla. but images stay in /images/dev until manually moved[/quote]

    Tom Elliott’s post above fixed it for me. You have to edit /etc/vsftpd.conf and then restart the ftp services.



  • has this been resolved? i checked all settings and can login to ftp with broswer and filezilla. but images stay in /images/dev until manually moved



  • Thanks! If it was a snake, I’d be less one nose right now!


  • Developer

    fog configuration>fog settings>fog boot settings> FOG_PIGZ_COMP



  • OK, I must be a complete blind idiot today, because I can’t find that setting anywhere on the FOG settings page. What title should I look for? Thanks a lot!


  • Developer

    that’s the compression. uploads slow, downloads fast. you can turn it down from the default of 9 in the settings page, i keep mine around 6.



  • Let me know if this is an unrelated issue and needs to be on its own thread, but ever since day 1 when we upload an image using the default partclone image, it crawls along at under 500 MB transfer rate on a Gigabit network. When we deploy an older image using partimage, it flys at 2-3 GB transfer rate. Just wondering if this is something that can be adjusted as it now takes forever to upload an image. Deploying the partclone image does seem faster, just the uploads are so slow.


  • Developer

    yes



  • Ah, OK now I can login to ftp via web and see the directory tree. So should I try uploading a new image and see what happens?


  • Senior Developer

    Awesome,

    Edit your /etc/vsftpd.conf file and add the parameter:
    [code]seccomp_sandbox=NO[/code]

    Save and close the file.

    Restart ftp services:
    [code]sudo service vsftpd restart[/code]



  • I just tried going to [url]ftp://10.10.100.218[/url] which is my server’s ip address and get the following error: v500 OOPS: priv_sock_get_int
    .

    Tried using web browser. Sorry I am not more familiar with the fog server’s ftp setup, but usually this works when logging into an internet ftp site.


  • Developer

    have you verified that the username and password can log into the ftp server?



  • I checked my settings: Have the username fog with my password in storage management for the defaultmember management username and password. It is the same in the TFTP settings in FOG settings. I don’t see a setting for FTP, only TFTP server. My username and password are the same in all areas that I know to check.

    For me, when I copied the image over manually from /images/dev/macaddress to /images/imagename, it worked for deploying the image, but this should be an automatic process.

    We use this server in a production environment almost daily, so this is very important to get fixed. thanks!


  • Developer

    you need to check your ftp settings in both the storage management and in fog settings
    make sure the settings match what the password is for the linux user “fog” as well.



  • Revision 2119
    Ubuntu: 12.04.5 LTS

    I can confirm that problem, too.
    Uploading a image with 2 partitions to the server works fine, but the folder of the image name, is not created and then the partition files won’t get moved and I don’t see or get any errors.
    Creating the folder, moving the files and setting the permissions doesn’t help too. I get this error, If I try to do then an download
    [CODE]Download task failed to create for ITFOGWin7 with image test_image
    To setup download task, you must first upload an image[/CODE]
    Should I upgrade to a newer revision or any other ideas?



  • Thanks for that info. Any ideas on how to fix this permanently? I have several users who use this very often, but I am the only one with linux knowledge and the CLI, so a permanent fix is most needed. Again, thanks!



  • For all images run:

    [CODE]mkdir /images/IMAGE_NAME

    mv /images/dev/IMAGE_YOU_JUST_UPLOADED/* /images/IMAGE_NAME

    chmod 777 /images/IMAGE_NAME[/CODE]

    This is a bandaid that will allow you to image right now, it doesn’t fix the root of the problem.


  • Developer

    you are probably having an ftp issue then. the image upload process uploads to /images/dev/<mac> by nfs, then finishes by moving it to /images/<image> by ftp



  • Yes and apparently they are the MAC addresses to the upload machine, because one I was uploading had it’s mac address there.


Log in to reply
 

444
Online

38994
Users

10714
Topics

101705
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.