Fog Client - running snapins should be executed, but doesn't



  • I’ve recently installed a new Debian server with Fog 1.2.0, so the system is quite new.

    I have some problems using the FOG Client.
    Client computer runs Win81, and is basically just a clean install with some drivers, Firefox, Chrome, Hyper-V and .net Framework 3.5 + Updates.

    My Goal is to run some Snap-ins after deployment.
    The snap-ins are nothing more than batch scripts which needs to run as administrator.
    Doubleclicking on the SFX snapin results in a success.
    (it’s a self extracting archive made with “7-Zip SFX maker” that then calls the batch file, I also tried “SFXMaker”)

    Lets take my most simple snap-in batch file as an example.
    [CODE]powercfg -h off[/CODE]

    For those who don’t know it it disables the hibernation, and removes the hibernation file.

    The last entry of the log when deplying a non-sysprepped image (I can’t remember the exact log message but it was siimilar to):
    "Running snap-in"
    It just hangs there indefinately.

    What I read somewhere is that some things won’t run properly when the FOG Service is running as a Local Service, and should run as the local Administrator.
    I think I skipped testing this part on a non-sysprepped image, or I just can’t remember the outcome from last week.

    So now I’m sys-prepping with a simple unattended file that activates the Administrator in the specialize phase + some other cosmetic things like setting user/company info, activation code etc. After OOBE runs the first time the client reboots and hangs indefinately. I found that it’s the FOG Client when it’s set to run as administrator. Running the FOG Client as Local Service, there are no issues in the boot sequence.

    So here’s my dilemma, I can’t execute my batch scripts because the service isn’t running as administrator, I can’t run the service as administrator as it would render my image unusable.

    I do have some little more advanced scripts, so even if I could deactivate hibernation and delete the hibernation file, instead of running the simple “powercfg -h off” I would still need to run batch scripts.

    I did try to have Fog Service running as Local Service, then change it in specialize phase (4) in the unattended file (using WAIK)
    [CODE]sc.exe config “FOG Service” obj= “.\Administrator” password= “somepassword”[/CODE]

    I’d love to hear if anyone has any solutions for this.



  • No, UAC is not disabled, the user doesn’t have administrative permissions either.
    But it should not be the case when a service with credentials executes the scripts.

    But even a simple “copy these files to desktop” batch file doesn’t run.

    For now things are done manually, as it seems the great devs, are in the progress, of making a new service client.


  • Developer

    [quote=“Edgardo Peluffo, post: 35621, member: 1279”]Did you disable UAC ? , I disable UAC on Windows 7 with this batch command running from sfx snapin

    ::DISABLE UAC
    REG ADD HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\System /v EnableLUA /t REG_DWORD /d 0 /f

    You will probably need to research windows 8.1 + batch files on google as it seems to be a problem with your OS[/quote]

    i have never needed to disable UAC to get snapins to work



  • Did you disable UAC ? , I disable UAC on Windows 7 with this batch command running from sfx snapin

    ::DISABLE UAC
    REG ADD HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\System /v EnableLUA /t REG_DWORD /d 0 /f

    You will probably need to research windows 8.1 + batch files on google as it seems to be a problem with your OS



  • No… no change… I also tried adding the batch file without wrapping it in an executable.

    I’m seeing now that the hostname changer doesn’t seem to work either.
    It worked at one point when I deployed a Pre-Sysprepped image, but now it doesn’t change the hostname.



  • There’s no joining of a domain, but the computers are renamed. the message in the fog.log is as I mentioned “running snap-in”

    The sfx is running in %temp% but I can try as you suggest -changing extraction path- tomorrow.
    cheers



  • “Doubleclicking on the SFX snapin results in a success.
    (it’s a self extracting archive made with “7-Zip SFX maker” that then calls the batch file, I also tried “SFXMaker”)”

    Do the snapins run after the computer boots, renames itself and joins the domain ? There should be some kind of message on fog.log giving you some kind of clue ?

    Not sure this is the solution to your batch problem or not but try to set the <Extraction path> to a directory that “everyone” has read/write permissions; for example c:\Windows\temp. I found sometimes that SFX snapins won’t run if you leave the Extraction path to temporary folder box checked.

    Otherwise, I have no clue as I am not running Win 8.1 yet; running windows 7 pro 64bit


Log in to reply
 

396
Online

39.4k
Users

11.1k
Topics

105.5k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.