Fog with NAS issues



  • I know this was brought up a few times even wtihin this forum but most never really had a clear cut way to make this work. I have the Imation DataGuard T5R that I was going to try and use with Fog. I noticed that this NAS doesn’t have NFS capabilities either. Am I pretty much S.O.L. without the NFS service on the NAS?

    I was able to connect just fine mounting as CIFS. Fog even sees the folder and give sme a pie chart and everything but when starting the image upload it definitely wants NFS.

    I’m sorta of noobie at Linux. I can get around pretty good but I’ll try whatever you have suggests for! Thank you :)



  • Nvm, still can’t figure this thing out. About to just go buy parts and RAID 5 my linux machine itself. I know I can get the storage node to work locally. But I just can’t figure out this NAS deal.
    Maybe it’s because it NEEDS a username and password? Not sure how specific NFS is but I know it doesn’t ask for it there when I want to mount the nas. I can mount it just fine with CIFS. Infact when I mount it as a CIFS and add that as a node on fog it even gives me the available space pie chart and all. But all in all we need NFS for all of this to work client side.

    Here’s what I currently did:

    1. On the Imation DataGuard T5R (IP: 192.168.2.201) I made a /Images share out there. This NAS is kind of goofy so it could full well be the NAS. The NAS isn’t on the Active Directory but the computers are. So even though I don’t have the NAS on the AD I still needed to add my username and pass to it as a user and it let me in. So thinking that way I added fog as a user also to see if that could rule it out.

    2. My /etc/exports say:
      [CODE]/fogimages *(ro,sync,no_wdelay,insecure_locks,no_root_squash,insecure,fsid=1,)
      /fogimages/dev *(rw,sync,no_wdelay,no_root_squash,insecure,fsid=2,)
      [/CODE]

    I also added the .mntcheck files in these folders. I never did “Touch” those files so that will be next on the list.

    1. My NAS line in /etc/fstab looks like this:
      [QUOTE]192.168.2.201:/Images /fogimages nfs defaults 0 0
      [/QUOTE]

    2. When I was done with all of that I made sure I did the exportfs command and even restarted services.

    3. When I try to mount again I still get this:
      [CODE]mount -t nfs 192.168.2.201:/Images /fogimages
      mount.nfs: access denied by server while mounting 192.168.2.201:/Images
      [/CODE]

    I have tried doing all of this in Fog itself too. [IMG]http://fogproject.org/forum/gyazo.com/8948a37556ff51c00f362e942e4c0538[/IMG]

    I have tried different variations of the Image Path also. Some forums have mentioned that some NAS systems don’t grab the share correctly. So try to find a more direct path. So I tried /Nas1/Images <-- (Logical Drive/ImageFolder). Nadda. Next I logged into the NAS through SSH and found an even more absolute path. Tried that and still nothing. This is going to haunt me, haha. [IMG]http://gyazo.com/8cf806729d6dbcfcbe45edc7d23deaaa[/IMG]

    I know I can get this working with Clonezilla but I really love the way Fog is laid out. Clonezilla I need to always go to the machine and follow the 15 steps and make sure I even have the correct paths. Fog, you just do it once and after that you click a button to start anything you want. It’s super nice.

    So if anybody has some ideas that maybe I am missing or if I’m SOL with this NAS possibly let me know! Thank you. : )



  • Nevermind. Apparently I was supposed to know that the option “Unix/Linux” meant it was NFS in the NAS. Haha. I’ll research some more on how to get it working though. You can delete this thread if you wish.



  • Sorry. I forgot to add in that I am running on CentOS 6.5 also.


Log in to reply
 

397
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.