TFTP dont accept get from other hosts

  • [I][SIZE=12px]Hello[/SIZE][/I]

    [I][SIZE=12px]i’m trying to make the install but i’m having a lot of troble with the tftp, if i’m in the fog server i can test the transference successful with this command:[/SIZE][/I]
    [I][SIZE=12px]tftp -v -c get undionly.kpxe[/SIZE][/I]

    [I][SIZE=12px]but when i try to do the same from a host i get a time out i already tried two tftp clients for windows and get time out from both, i can connect to the fog and ping it but not use tftp.[/SIZE][/I]

    [I][SIZE=12px]I already tried to disable ufw and i get the same error.[/SIZE][/I]

    [I][SIZE=12px]I’m using Ubuntu server 10.04.4[/SIZE][/I]

  • Developer

    Thanks for letting us know how to solve it!

  • I found the problem in the mikrotik you cant use the options 66 and 67 there are specific filds to configure this options in the setings DHCP > Network, i will upload more datails soon and an image.

  • I tried with the ip and get the same error.

    When i disabled the windows firewall it works very well with ip or dns, i didnt’t think this because i’m geting errors with pxe.

    There are just switches between them, but i tried behind a router and it worked too with the firewall disabled.

    my dhcp is served by a mikrotik the configuration ar the folowing:

    name Code value
    boot-file 67 undionly.kpxe
    next-server 66 fogserver

    i configurate the next-server parameter too

    In the pxe boot i get this error:


  • Developer

    Try using the ip address instead of the, what happens?

    just a heads up in windows you will want to use the following command
    tftp x.x.x.x get undionly.kpxe[/code]

    the -v and -c should not be required.

    Have you also disabled the windows firewall?

    What serves your DHCP?

    what kind of network equipment exists between FOG and the windows machines?

Log in to reply