Upgrade from .32 to 1.2.0 - Problem screen blank



  • I have a blank screen on the web interface when going to update the database. I’ve tried running the installer again and it bombs now. Not sure what is broke.

    PHP 5.2.6 (cli) (built: May 8 2008 08:53:44)
    Copyright © 1997-2008 The PHP Group
    Zend Engine v2.2.0, Copyright © 1998-2008 Zend Technologies

    Here is the part of the log where it bombs.

    Are you sure you wish to continue (Y/N) Y

    Installation Started…

    Installing required packages, if this fails
    make sure you have an active internet connection.

    • Packages to be installed: httpd php php-cli php-common php-gd php-mysql mysql mysql-server dhcp tftp-server nfs-utils vsftpd net-tools wget xinetd tar gzip make m4 gcc gcc-c++ lftp

    • Skipping package: httpd (Already installed)

    • Skipping package: php (Already installed)

    • Skipping package: php-cli (Already installed)

    • Skipping package: php-common (Already installed)

    • Skipping package: php-gd (Already installed)

    • Skipping package: php-mysql (Already installed)

    • Skipping package: mysql (Already installed)

    • Skipping package: mysql-server (Already installed)

    • Skipping package: dhcp (Already installed)

    • Skipping package: tftp-server (Already installed)

    • Skipping package: nfs-utils (Already installed)

    • Skipping package: vsftpd (Already installed)

    • Skipping package: net-tools (Already installed)

    • Skipping package: wget (Already installed)

    • Skipping package: xinetd (Already installed)

    • Skipping package: tar (Already installed)

    • Skipping package: gzip (Already installed)

    • Skipping package: make (Already installed)

    • Skipping package: m4 (Already installed)

    • Skipping package: gcc (Already installed)

    • Skipping package: gcc-c++ (Already installed)

    • Skipping package: lftp (Already installed)

    Confirming package installation.

    • Checking package: httpd…OK
    • Checking package: php…OK
    • Checking package: php-cli…OK
    • Checking package: php-common…OK
    • Checking package: php-gd…OK
    • Checking package: php-mysql…OK
    • Checking package: mysql…OK
    • Checking package: mysql-server…OK
    • Checking package: dhcp…OK
    • Checking package: tftp-server…OK
    • Checking package: nfs-utils…OK
    • Checking package: vsftpd…OK
    • Checking package: net-tools…OK
    • Checking package: wget…OK
    • Checking package: xinetd…OK
    • Checking package: tar…OK
    • Checking package: gzip…OK
    • Checking package: make…OK
    • Checking package: m4…OK
    • Checking package: gcc…OK
    • Checking package: gcc-c++…OK
    • Checking package: lftp…OK

    Configuring services.

    • Setting up and starting MySQL…/lib/redhat/functions.sh: line 489: chkconfig: command not found
      Failed!

    Script done on Mon 11 Aug 2014 12:36:15 PM CDT



  • i have this same issue. i made sure i have the latest php5. help please.


  • Senior Developer

    The FOG Server requires PHP 5.3 or higher because it uses [URL=‘http://php.net/manual/en/functions.anonymous.php’]anonymous functions[/URL] which were introduced in PHP 5.3



  • Apache log:

    [Mon Aug 11 12:44:10 2014] [notice] caught SIGTERM, shutting down
    [Mon Aug 11 12:44:10 2014] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
    [Mon Aug 11 12:44:10 2014] [notice] Digest: generating secret for digest authentication …
    [Mon Aug 11 12:44:10 2014] [notice] Digest: done
    [Mon Aug 11 12:44:10 2014] [notice] Apache/2.2.9 (Unix) DAV/2 PHP/5.2.6 configured – resuming normal operations
    [Mon Aug 11 12:44:19 2014] [error] [client 10.10.30.156] PHP Parse error: syntax error, unexpected T_PAAMAYIM_NEKUDOTAYIM in /var/www/html/fog/commons/init.php on line 201
    [Mon Aug 11 13:00:36 2014] [error] [client 10.10.30.156] File does not exist: /var/www/html/commons
    [Mon Aug 11 13:01:15 2014] [error] [client 10.10.30.156] PHP Parse error: syntax error, unexpected T_FUNCTION, expecting ‘)’ in /var/www/html/fog/commons/schemaupdater/index.php on line 903
    [Mon Aug 11 13:04:57 2014] [notice] caught SIGTERM, shutting down
    [Mon Aug 11 13:04:58 2014] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
    [Mon Aug 11 13:04:58 2014] [notice] Digest: generating secret for digest authentication …
    [Mon Aug 11 13:04:58 2014] [notice] Digest: done
    [Mon Aug 11 13:04:58 2014] [notice] Apache/2.2.9 (Unix) DAV/2 PHP/5.2.6 configured – resuming normal operations
    [Mon Aug 11 13:05:10 2014] [error] [client 10.10.30.156] PHP Parse error: syntax error, unexpected T_FUNCTION, expecting ‘)’ in /var/www/html/fog/commons/schemaupdater/index.php on line 903
    [Mon Aug 11 13:05:15 2014] [error] [client 10.10.30.156] PHP Parse error: syntax error, unexpected T_PAAMAYIM_NEKUDOTAYIM in /var/www/html/fog/commons/init.php on line 201
    [Mon Aug 11 13:06:40 2014] [error] [client 10.10.30.156] PHP Parse error: syntax error, unexpected T_FUNCTION, expecting ‘)’ in /var/www/html/fog/commons/schemaupdater/index.php on line 903
    [Mon Aug 11 13:07:54 2014] [error] [client 10.10.30.156] PHP Parse error: syntax error, unexpected T_PAAMAYIM_NEKUDOTAYIM in /var/www/html/fog/commons/init.php on line 201
    [Mon Aug 11 13:07:54 2014] [error] [client 10.10.30.156] PHP Parse error: syntax error, unexpected T_PAAMAYIM_NEKUDOTAYIM in /var/www/html/fog/commons/init.php on line 201
    [Mon Aug 11 13:08:13 2014] [error] [client 10.10.30.156] PHP Parse error: syntax error, unexpected T_PAAMAYIM_NEKUDOTAYIM in /var/www/html/fog/commons/init.php on line 201
    [Mon Aug 11 13:08:20 2014] [error] [client 10.10.30.156] PHP Parse error: syntax error, unexpected T_PAAMAYIM_NEKUDOTAYIM in /var/www/html/fog/commons/init.php on line 201
    [Mon Aug 11 13:08:28 2014] [error] [client 10.10.30.156] PHP Parse error: syntax error, unexpected T_PAAMAYIM_NEKUDOTAYIM in /var/www/html/fog/commons/init.php on line 201
    [Mon Aug 11 13:08:43 2014] [error] [client 10.10.30.156] PHP Parse error: syntax error, unexpected T_PAAMAYIM_NEKUDOTAYIM in /var/www/html/fog/commons/init.php on line 201


  • Senior Developer

    This post is deleted!


  • Thanks, that has me past the installer bombing but I still am getting a blank web interface when going to do the database update.

    I have even tried going to “[url]http://10.10.30.22/fog/commons/schemaupdater/index.php?redir=1[/url]” directly with no luck. Blank screen.


  • Senior Developer

    From what I can tell chkconfig is in the root PATH variable so you need to enter a root environment before running the install script. To do this run [B]su[/B] and then execute the install script.


Log in to reply
 

457
Online

38968
Users

10709
Topics

101631
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.