PXE Boot Connection Timed Out



  • Hello all,

    New to the forums, but have had FOG running for a couple of months now. Updated to 1.2.0 - fixed database schema issue with wrong username/password in Config.class.php. The problem is when I boot a PC into PXE. It looks like it’s connecting and grabbing the boot.php file from the server, but when it tries to download bg.png, it’s not adding the full path so it fails to download. I’ve attached a screenshot to hopefully help.

    Thanks,

    Terry

    [url="/_imported_xf_attachments/1/1265_iPXE Boot Screen.JPG?:"]iPXE Boot Screen.JPG[/url]


  • Developer

    it looks like you were hit with a big that was identified in 1.1.2, and was actually a large part of the 1.2.0 update. under certain conditions all of the settings could be blanked on the settings page. i’m afraid you’ll just have to set them back manually. but at least it won’t happen again…



  • Thanks Tom!

    After looking through my settings and making the change, it appears that the rest of my configuration settings are blank. I’ve had to re-do my TFTP server settings. So now when I try to send an image, I’m getting “No such file or directory” errors as shown in the screenshot. Is there a configuration file that all of the system settings are saved at?

    Terry

    [url="/_imported_xf_attachments/1/1266_iPXE Boot.JPG?:"]iPXE Boot.JPG[/url]


  • Senior Developer

    It appears to me that the: from gui:

    FOG Configuration->FOG Settings->Web Server->FOG_WEB_HOST and FOG_WEB_ROOT are not set properly. FOG_WEB_HOST should be the IP or hostname of your fogserver. IP is preferred. FOG_WEB_ROOT should be, normally, /fog/ .


Log in to reply
 

476
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.