Getting an operation not supported error.



  • We have been trying to get Fog working on our network for a good bit of a month will some luck. We have fog installed on Ubuntu 12.04 on a VM. We have to set up Fog with as a ProxyDHCP. here is the conf file:
    [CODE]# Sample configuration for dnsmasq to function as a proxyDHCP server,

    enabling LTSP clients to boot when an external, unmodifiable DHCP

    server is present.

    The main dnsmasq configuration is in /etc/dnsmasq.conf;

    the contents of this script are added to the main configuration.

    You may modify the file to suit your needs.

    Don’t function as a DNS server:

    port=0

    Log lots of extra information about DHCP transactions.

    log-dhcp

    Dnsmasq can also function as a TFTP server. You may uninstall

    tftpd-hpa if you like, and uncomment the next line:

    #enable-tftp

    Set the root directory for files available via FTP.

    tftp-root=/tftpboot

    The boot filename.

    dhcp-boot=undionly.kpxe

    rootpath option, for NFS

    dhcp-option=17,/images

    kill multicast

    dhcp-option=vendor:PXEClient,6,2b

    Disable re-use of the DHCP servername and filename fields as extra

    option space. That’s to avoid confusing some old or broken DHCP clients.

    dhcp-no-override

    PXE menu. The first part is the text displayed to the user. The second is the timeout, in seconds.

    pxe-prompt=“Press F8 for boot menu”, 3

    The known types are x86PC, PC98, IA64_EFI, Alpha, Arc_x86,

    Intel_Lean_Client, IA32_EFI, BC_EFI, Xscale_EFI and X86-64_EFI

    This option is first and will be the default if there is no input from the user.

    pxe-service=X86PC, “Boot from network”, undionly

    A boot service type of 0 is special, and will abort the

    net boot procedure and continue booting from local media.

    pxe-service=X86PC, “Boot from local hard disk”, 0

    If an integer boot service type, rather than a basename is given, then the

    PXE client will search for a suitable boot service for that type on the

    network. This search may be done by multicast or broadcast, or direct to a

    server if its IP address is provided.

    pxe-service=x86PC, “Install windows from RIS server”, 1

    This range(s) is for the public interface, where dnsmasq functions

    as a proxy DHCP server providing boot information but no IP leases.

    Any ip in the subnet will do, so you may just put your server NIC ip here.

    Since dnsmasq is not providing true DHCP services, you do not want it

    handing out IP addresses. Just put your servers IP address for the interface

    that is connected to the network on which the FOG clients exist.

    If this setting is incorrect, the dnsmasq may not start, rendering

    your proxyDHCP ineffective.

    dhcp-range=10.180.8.139,proxy

    This range(s) is for the private network on 2-NIC servers,

    where dnsmasq functions as a normal DHCP server, providing IP leases.

    dhcp-range=192.168.0.20,192.168.0.250,8h

    For static client IPs, and only for the private subnets,

    you may put entries like this:

    dhcp-host=00:20:e0:3b:13:af,10.160.31.111,client111,infinite

    [/CODE]

    Every type of computer we tried to network boot will give us a Could not start download: Operation not supported ([url]http://ipxe.org/3c092003[/url]) error.

    We have tried every ipxe boot file we can found on the forums and on the site with the same error.

    Any ideas? Thanks for any help anybody gives.



  • Tom - I have not tried that conf and will give it a try next time we have “down time” at work. Thank you for some input.

    Cadyfish - if this is what is in the wiki, we have tried that. Very time we restart dnsmasq with that other config, it crashes dnsmasq. The system logs really does not give me any input as to why (I could be looking at the wrong logs). That being said, I will also try this just in case I did miss something. THANKS!



  • It looks like you might have missed a couple of things when you changed it to work with 1+ from .32

    [U][B]Update schema[/B][/U]
    [url]http://localhost/fog/commons/schemaupdater/index.php?redir=1[/url]

    [U][B]Add the server IP address[/B][/U]
    dhcp-boot=undionly.kpxe,{server IP}

    [U][B]Comment out the following lines[/B][/U]
    #dhcp-option=17,/images
    #dhcp-option=vendor;PXEClient,6,2b
    #pxe-service=X86PC, “Boot from local hard disk”, 0

    [U][B]Save your file and restart your dnsmasq service with the following command:[/B][/U]
    sudo service dnsmasq restart

    [U][B]Make a symlink for the undionly.kpxe file so dnsmasq can find it.[/B][/U]
    cd /tftpboot
    sudo ln -s undionly.kpxe undionly.0


  • Senior Developer

    Have you tried the ltsp.conf file configuration found in src/ipxe/src?

    While I realize this isn’t exactly intuitive, maybe try that configuration, changing of course the relevant areas of IP for your environment.

    The file I’m specifying hasn’t been tested by me, but was created when we initially implemented ipxe as our “goto” for FOG NBP.

    This was the working configuration, where the only major needed change was to link undionly.kpxe with undionly.0



  • Anyone have another ideas for me to try?



  • the line that sets [FONT=Consolas]dhcp-range is the fog server IP. I forgot were I found that information, but it worked when we were testing Fog .32. HOWEVER! It will not shock me if that is not the case. [/FONT]

    [FONT=Consolas]The client computers will find the Fog server and load from the TFTP server (as far as I can tell).[/FONT]
    [FONT=Consolas][/FONT]


  • Senior Developer

    The dhcp-range line is also the ip of the fog server?


  • Developer

    well, i’ve never used ProxyDHCP, but i don’t see anywhere in the config that the ip of the tftp server is being specified



  • We also tried that, however, every time we change the boot filename to [CODE]dhcp-boot=undionly.kpxe,x.x.x.x[/CODE] it crashes the dnsmasq. we did replace the x.x.x.x with the server IP.


  • Developer

    i think you’re missing some info on this line
    [FONT=Consolas]# The boot filename.
    dhcp-boot=undionly.kpxe[/FONT]
    [FONT=Consolas]the fog wiki on ProxyDHCP has a config that looks like this[/FONT]
    [FONT=Consolas][url]http://www.fogproject.org/wiki/index.php/Setting_up_ProxyDHCP[/url][/FONT]
    [COLOR=#000000][FONT=monospace]# The boot filename, Server name, Server Ip Address
    dhcp-boot=undionly.kpxe,x.x.x.x[/FONT][/COLOR]


Log in to reply
 

404
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.