Schedule Delayed Deployment is not working anymore


  • the Schedule Delayed Deploymen[U][FONT=Ubuntu][COLOR=#555555]t[/COLOR][/FONT][/U] is not working anymore with the actual version of fog (Version 1.2.0).

    With the old 0.32 Schedule Delayed Deployment works fine.

    Any idea or solution !?

  • Moderator

    @john3892 As you see your version of FOG is way newer than the one of the original post here, so please open a new topic and post all your details there.


  • @sebastian-roth thanks for ur relply sir… well my fog version is 1.5.9 the last version and i have installed in debian version 10.6.0 …well wol works only instantly but while scheduling delayed task is doesn’t work

  • Moderator

    @john3892 Best if you open a new topic. Just cross link this forum post here as reference and then send all your details like FOG version, Linux OS/version, steps you took (in detail)…


  • @tom-elliott hi sir this is john from france ur forums helped me a lot now i’m struggling to perform a schedule delayed task …i know that the problem is to change the time but i dont how to fix the issue …and i changed timezone in web gui on fog settings europe/paris …and i used this
    cmd
    nano / etc/php5/apache2/php.ini…ididnt see well as well timezone can you help me pls


  • Sadly That didn’t do the trick. I’m not sure if it did this before I did this or not, but when I start a task with instant deployment it does have the right time. But it still thinks 10 minutes from that time is in the past.


  • Check your php.ini file and make sure you have:
    date.timezone = America/New_York

    Of course changing the timezone to the proper one on your system.

    I’ll look into a better system of getting the time too.

    After you set the timezone restart the apache2 service and once that’s backup restart the FOGScheduler service. It may or may not help, I do not know.


  • I’m having a related problem. The delayed deployment works but the time is wrong. For example if I tell it to deploy anything less than 6 hours from now it says that the time specified is in the past.

246
Online

9.5k
Users

15.9k
Topics

147.5k
Posts