Fog on Fedora 20



  • Hello,

    FOG_1.2.0
    Fedora 20

    I have successfully installed fog 1.2.0 without an issue. The problem I’m facing is that I’m able to access the web interface from the fog server but I’m not able from another computer in the same network. Firewall is disable and I believe the iptables are not install (not sure). This is an upgrade from Fedora 14, which I had working fine.

    Thanks



  • Checking my server, I’m running vsftp version 3.0.2-6.

    Here’s what my vsftp.conf file looks like:

    anonymous_enable=NO
    local_enable=YES
    write_enable=YES
    local_umask=022
    dirmessage_enable=YES
    xferlog_enable=YES
    connect_from_port_20=YES
    xferlog_std_format=YES
    listen=YES
    pam_service_name=vsftpd
    userlist_enable=NO
    tcp_wrappers=YES


    The only other things I can think of are:
    [LIST]
    []to make sure the vsftp service is enabled, not just running, so that when you reboot your server it starts automatically
    [
    ]make sure the username and password are correct, not only under the FOG settings of the web interface, but also under Storage Management and in the your …/fog/comons/config.php file
    [LIST]
    []in the config.php file, make sure the TFTP and STORAGE FTP username and password (the password may be encrypted) are set to your values
    [/LIST]
    [
    ]if your firewall is on, make the appropriate exceptions for vsftp, or you can disable it completely
    [/LIST]
    Hope that helps.


  • Senior Developer

    [quote=“Kronkras, post: 35064, member: 25243”]Hello a1adam12,

    Thanks for your replied, I was able to pass the error message stated before and able to almost upload an image. The only problem is that when it finish to upload the image FOGFTP failed to connect. I verified TFTP and node have the same username and password as well as the IP.

    Thank you[/quote]

    What version of vsftpd do you have? If it’s > 3.1 (i think that’s it) then try adding:
    [code]seccomp_sandbox=NO[/code] To the /etc/vsftpd.conf file and restart with:[code]service vsftpd restart[/code]



  • [quote=“a1adam12, post: 35043, member: 22878”]I have (technically had since I’ve now upgraded) FOG up and running on Fedora 20 without any issues. Took some customizing, but figured it out. I posted a help guide on this thread:

    [url]http://fogproject.org/forum/threads/using-0-32-with-fedora-20.10141/[/url]

    Hopefully it can help you out.[/quote]

    Hello a1adam12,

    Thanks for your replied, I was able to pass the error message stated before and able to almost upload an image. The only problem is that when it finish to upload the image FOGFTP failed to connect. I verified TFTP and node have the same username and password as well as the IP.

    Thank you



  • I have (technically had since I’ve now upgraded) FOG up and running on Fedora 20 without any issues. Took some customizing, but figured it out. I posted a help guide on this thread:

    [url]http://fogproject.org/forum/threads/using-0-32-with-fedora-20.10141/[/url]

    Hopefully it can help you out.


  • Developer

    Ubuntu 10.04, 12.04, 13.10
    CentOS 6.4,6.5 (assumed RHEL of same versions)
    Earlier than Fedora 19
    Debian 7.4, 7.5



  • [quote=“Tom Elliott, post: 34544, member: 7271”]If you got an error, how did everything install “just fine”?

    I realize it didn’t fall out of the installer, but are you also aware we’ve stopped official support for Fedora specifically because we can’t keep up with all of the change’s?[/quote]

    What OS would you suggest?



  • [quote=“madskillz23, post: 34563, member: 8206”]I’m on CentOS 7 (similar architecture to Fedora 20) and haven’t been able to get image upload working properly yet. Best of luck.[/quote]

    Oh well, as you predicted, is not working.

    • Mounting File System …mount: mounting 10.##.#.###:/images/dev/ on /images failed: Operation not supported

    Any toughs?



  • [quote=“Kronkras, post: 34559, member: 25243”]That did the trick.

    I’ll still to test the system, register, upload an image, and deploy unicasts and multicast. I’ll update with the results.

    Thanks guys![/quote]

    I’m on CentOS 7 (similar architecture to Fedora 20) and haven’t been able to get image upload working properly yet. Best of luck.


  • Developer

    [url]http://fogproject.org/wiki/index.php/Tftp_timeout[/url]

    Added Fedora 20 section and added the suggested line of “systemctl stop firewalld.service && systemctl disable firewalld.service”



  • [quote=“madskillz23, post: 34557, member: 8206”]Firewall issue. systemctl stop firewalld.service && systemctl disable firewalld.service

    That should do it.[/quote]

    That did the trick.

    I’ll still to test the system, register, upload an image, and deploy unicasts and multicast. I’ll update with the results.

    Thanks guys!



  • [quote=“Kronkras, post: 34554, member: 25243”]Ok, so I figured out why I was not able to disable selinux, I was missing a D (disable[B]d[/B]). Now is disabled but I’m still unable to reach the website.
    Thasnks[/quote]

    Firewall issue. systemctl stop firewalld.service && systemctl disable firewalld.service

    That should do it.



  • Ok, so I figured out why I was not able to disable selinux, I was missing a D (disable[B]d[/B]). Now is disabled but I’m still unable to reach the website.
    Thasnks



  • [quote=“Tom Elliott, post: 34551, member: 7271”]Did you reboot?[/quote]

    Yes


  • Senior Developer

    Did you reboot?



  • It is disabled but I still getting an enable status

    This file controls the state of SELinux on the system.

    SELINUX= can take one of these three values:

    enforcing - SELinux security policy is enforced.

    permissive - SELinux prints warnings instead of enforcing.

    disabled - No SELinux policy is loaded.

    SELINUX=disable

    SELINUXTYPE= can take one of these two values:

    targeted - Targeted processes are protected,

    minimum - Modification of targeted policy. Only selected processes are protected.

    mls - Multi Level Security protection.

    SELINUXTYPE=targeted


  • Senior Developer

    [code]/etc/selinux/config[/code]

    Disable the line in there.



  • I just checked SElinux, Although I’m setting SELINUX=disable in /etc/selinux/config, when I run [I]$ /usr/sbin/sestatus[/I] it says that is enable, any toughs?

    [SIZE=6]From /etc/selinux/config folder:[/SIZE]

    [I]# This file controls the state of SELinux on the system.[/I]
    [I]# SELINUXTYPE= can take one of these two values:[/I]
    [I]# targeted - Targeted processes are protected,[/I]
    [I]# minimum - Modification of targeted policy. Only selected processes are protected. [/I]
    [I]# mls - Multi Level Security protection.[/I]
    [I]SELINUXTYPE=targeted[/I]

    [SIZE=6][B]From terminal:[/B][/SIZE]

    [root@10-21-0-110-ccca-internal Admin]# /usr/sbin/sestatus
    SELinux status: enabled
    SELinuxfs mount: /sys/fs/selinux
    SELinux root directory: /etc/selinux
    Loaded policy name: targeted
    Current mode: enforcing
    Mode from config file: error (Success)
    Policy MLS status: enabled
    Policy deny_unknown status: allowed
    Max kernel policy version: 28
    [root@10-21-0-110-ccca-internal Admin]#


  • Senior Developer

    If you got an error, how did everything install “just fine”?

    I realize it didn’t fall out of the installer, but are you also aware we’ve stopped official support for Fedora specifically because we can’t keep up with all of the change’s?


  • Developer

    fyi you can always post your install log. This log is located at /var/log/foginstall.log

    It may give more insight than your quick copy paste.


Log in to reply
 

382
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.