IPXE - default.ipxe - download issues



  • Hi guys,

    Ok, I find this an odd issue that I cannot work out.
    This has been going on since I installed fog but I did get a work around going using pxelinux (temp fix)

    What seems to be happening is that the tftp-server does not want to allow downloading of the default.ipxe file.
    SELinux and iptables are disabled so that isn’t the issue.

    When trying to download the default.ipxe file I am seeing the error (/var/log/messages)

    in.tftpd[18556]: tftpd: read(ack): Connection refused
    

    What is odd is if I move the /tftpboot/default.ipxe file to /tftpboot/default or /tftpboot/default.txt or /tftpboot/default.ipxe.0 I can download the file at the new location. if I create a new file called default.ipxe I cannot download this new file, if I move it to another location I can download it fine. Permissions are all correct as far as I can tell.

    Not sure if this is a bug with tftpserver or some other issue I cannot work out.

    I’d rather get this fixed so when doing fog upgrades I can update without having to move my fixes back into place.

    Cheers,


  • Senior Developer

    Is it reporting, Console error, then the IO error?



  • After testing this for about an hour and downloading every file but the default.ipxe I worked out it was the client.
    I tried this on several machines with the same error :\ tested it with a different client and it works fine.

    I thought I was on to something but I’m still getting the original error 0x3d126001 (Error: Inappropriate I/O control operation)

    :\


  • Developer

    what is the output of ls -a in /tftpboot ?


Log in to reply
 

506
Online

38916
Users

10685
Topics

101347
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.