FOGFTP: failed to connect undefined index conn



  • Hi, i’m having this problem after uploading an image:

    [B]FOGFTP: failed to connect. Host: 192.168.1.100 Error: Undefined Index Conn[/B]

    The IP [B]192.168.1.100[/B] is where I have my Storage Node Default.

    [COLOR=#000000]In FOG Settings —>TFTP Server---->[FONT=Ubuntu][B]FOG_TFTP_HOST[/B] i have [B]192.168.1.1[/B][/FONT][/COLOR]
    [COLOR=#000000][FONT=Ubuntu]In Config.class[/FONT][/COLOR][COLOR=#000000][FONT=Ubuntu][COLOR=#555555][COLOR=#000000].php—>[/COLOR][/COLOR][/FONT][FONT=Ubuntu]FOG_TFTP_HOST is 192.168.1.1[/FONT][/COLOR]

    [FONT=Ubuntu][COLOR=#000000]Why FOGFTP is searching files in 192.168.1.100?[/COLOR][/FONT]

    [FONT=Ubuntu][COLOR=#000000]Thank you![/COLOR][/FONT]



  • In 192.168.1.100 host I do " aptitude search ftp " and says that ftp is installed

    I have Debian 7.

    It could be happening that FOG has no permision to read/write in storage host 192.168.1.100?
    Disk Information in FOG web page is not available too


  • Developer

    fog needs ftp access to both the location where the tftp files are stored and the storage server


  • Senior Developer

    T FTP host does not need to be.100 your storage node does but on the thing that’s actually storing your images you also need FTP



  • [quote=“Tom Elliott, post: 34163, member: 7271”]The node is where it places the image so the node needs to have FTP[/quote]

    OK, thank you and sorry about the time losted, so:

    [FONT=Ubuntu][COLOR=#000000]FOG_TFTP_HOST must be 192.168.1.100?[/COLOR][/FONT]
    [FONT=Ubuntu][COLOR=#000000][/COLOR][/FONT]
    [FONT=Ubuntu][COLOR=#000000]I have to do another change?[/COLOR][/FONT]


  • Senior Developer

    The node is where it places the image so the node needs to have FTP



  • [quote=“Tom Elliott, post: 34159, member: 7271”]That’s why it’s trying to ftp to 192.168.1.100[/quote]

    Yes but the TFTP_HOST is configured in 192.168.1.1 . I want 192.168.1.100 works only as a Image Repository

    I must have the same address for the Storage Node and the TFTP server?


  • Senior Developer

    That’s why it’s trying to ftp to 192.168.1.100



  • [quote=“Tom Elliott, post: 34156, member: 7271”]Your storage node’s IP is set to 192.168.1.100?[/quote]

    Yes


  • Senior Developer

    [quote=“pives del t3, post: 34152, member: 25180”]No, I only change the Storage Host.
    My server IP is 192.168.1.1 and my Storage Node Default is 192.168.1.100
    192.168.1.1/FOG/management is working perfectly[/quote]

    Your storage node’s IP is set to 192.168.1.100?



  • No, I only change the Storage Host.
    My server IP is 192.168.1.1 and my Storage Node Default is 192.168.1.100
    192.168.1.1/FOG/management is working perfectly


  • Developer

    did you change your server’s IP after installing?



  • Fog 1.1.2
    Fresh Install
    Only one Storage node


  • Developer

    what version of fog are you running?
    was this an upgrade or a fresh install?
    do you have more then one storage node?


 

547
Online

41.9k
Users

12.5k
Topics

117.6k
Posts