Unable to start task; Unable to connect to TFTP server



  • I set up fog .32 on a Debian Wheezy box a few months ago, and I’m just to the point where I can use it.

    PXE booting works fine and I can inventory a host no problem.

    But when I go to upload an image I get the message above “Unable to start task” “Unable to connect to tftp server”

    I’ve been prowling google all day, and I’ve searched these forums up and down. I see it’s not an uncommon problem but I’ve yet to find a solution. I’ve changed all the passwords to match, as per this wiki article http://www.fogproject.org/wiki/index.php/Unable_to_connect_to_TFTP and no dice.

    I can ftp into the box fine using the fog credentials, and my host shows online in the host management console. I’m running out of steam on this one and I don’t know what to try next.

    Any suggestions would be helpful. And any questions are welcome with open arms.

    Edit: Another tidbit of information, looking through the logs I see
    [QUOTE]%(#333333][05-02-14 1)[ * [05-02-14 1:01:57 pm] Checking if I am the group manager.]
    %(#333333][05-02-14 1)[ * [05-02-14 1:01:57 pm] I don’t appear to be the group manager, I will check back later.][/QUOTE]
    Not sure if this is related or not. But I couldn’t find any information on this, and it didn’t seem related.



  • @Tom Elliott, post: 34055, member: 7271 said:

    As you’re running 0.32, I believe you need to make the password change in /var/www/fog/commons/config.php as well.

    Sorry, left for home yesterday. I’ve already done this, it’s stated in the wiki.


  • Senior Developer

    As you’re running 0.32, I believe you need to make the password change in /var/www/fog/commons/config.php as well.



  • Changed all the passwords to remove the asterisk. That wasn’t it.


  • Senior Developer

    THey are not a problem, but it’s likely not set in the VALID CHARS Setting.



  • @David Herrington, post: 34047, member: 3549 said:

    And the password for your storage node is the same as the one in the Fog configuration?
    I may be wrong but I believe that password also has to be the same for the user “fog”

    I’ve changed the password for everything except for the web UI. Whenever I try to change the web password it tells me that it’s invalid.

    Now that I think about it, are special characters a problem in the passwords? I have an asterisk in there.


  • Senior Developer

    Upgrading fixes many things but may not fix everything for you.

    Do you start getting internet if you run:

    sudo echo "8.8.8.8" > /etc/resolv.conf
    


  • And the password for your storage node is the same as the one in the Fog configuration?
    I may be wrong but I believe that password also has to be the same for the user “fog”



  • That didn’t help in the slightest…

    And sorry for the triple post in here.



  • This post is deleted!


  • Interestingly enough, since I’ve rebooted, I’ve now lost internet connectivity on the Wheezy box.

    I can still ssh into the box, and wheezy can see my desktop, but it doesn’t see the laptop I’m trying to image. Before I rebooted everything was fine…

    Edit:
    Okay… So this may have been the problem. There was a typo in my /etc/networking/interfaces.

    I had gatewau, instead of gateway… Here’s to hoping. (How I got to google before I have no idea)



  • I’m trying it now, I’ll let you know shortly



  • Did you try what I suggested in my last post?



  • [QUOTE]easiest way? just download the installer and run it. it will detect the settings you used installed oringinally with and use those.[/QUOTE]
    Thank you, and noted.

    But realistically, is there any reason that this issue would be fixed by updating? I’m almost certain it’s something set incorrectly, or a problem with our network. I’m just not sure where that problem would be.

    After the hassle I went through to get PXE booting working the first time, I’m not looking forward to starting from scratch… But if I could get everything working on .32 I would feel better about upgrading. Seeing as how .32 was the version everyone was using from 2011 until a few months ago I feel like it’s not something broken in the release.


  • Developer

    easiest way? just download the installer and run it. it will detect the settings you used installed oringinally with and use those.
    best way? build a new server, migrate your files and host list over
    either way, pay attention to the inline documentation, there have been a few changes.



  • I’m very much aware, the new version was released after I had this one setup. .32 is all I could find at the time that was considered stable if I recall.

    Also, I remember when version 1 was released another user I know said it broke everything for him. So I was a bit wary.

    But that was another question I had, what is the easiest way to go about upgrading?



  • Why did you use such an old version?
    1.2 was just released on the 21st

    Anyways, open your Fog web interface, click “Fog Configuration” and then “FOG Settings” and copy the password for “FOG_TFTP_FTP_PASSWORD” into the config file
    Restart the server and see if it starts working for you


Log in to reply
 

366
Online

38719
Users

10547
Topics

99847
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.