Client shows uploading but server says no image



  • I have a Debian 7.5 OS with fog 1.2.0, I have changed permission to /images for fog to 755 and /images/dev to 777. I am able to register the Client PC associated a image with it, and tasked it to upload it starts and goes through the upload process as shown in the attached photo. Also the management screen shows the size of the client disk but the size on server shows 0. When I open the images/dev folder there is one folder named f8bc12770f94 which is the MAC of the pc I upload the image from and 3 folders (assume for the 3 partitions on the image). I don’t think it is associating that with the image profile I created in image management. Thoughts questions, concerns. I am just getting back into Linux so be gentle please. Any help or suggestions are appreciated.[ATTACH=full]1206[/ATTACH][ATTACH=full]1207[/ATTACH][ATTACH=full]1208[/ATTACH]

    [url="/_imported_xf_attachments/1/1206_fog_image.png?:"]fog_image.png[/url][url="/_imported_xf_attachments/1/1207_fog upload.jpg?:"]fog upload.jpg[/url][url="/_imported_xf_attachments/1/1208_fog_image_folder.png?:"]fog_image_folder.png[/url]


  • Developer

    now it’s an ftp problem. it could be the password on the storage management page. if your images are being stored on the same server as the fog web server, then it should match the value stored in fog settings>tftp server>FOG_TFTP_FTP_PASSWORD (assuming that one is correct)



  • Your the best…it is now uploading the image to the fog server but it still wants to put it in the /images/dev folder…thoughts, if nothing else I can always rename and move it.

    [url="/_imported_xf_attachments/1/1232_image_dev.png?:"]image_dev.png[/url]


  • Developer

    the first picture shows the problem. it’s trying to boot to a kernel named DEFAULT, but no such file exists. unless you have uploaded a custom kernel that you wish to use with a computer, that field should be blank



  • I have attached the 2 screenshots

    [url="/_imported_xf_attachments/1/1229_host_page.png?:"]host_page.png[/url][url="/_imported_xf_attachments/1/1230_image_page.png?:"]image_page.png[/url]


  • Developer

    check on the profile page for that host. is DEFAULT in the Host Kernel field?



  • [quote=“Junkhacker, post: 34346, member: 21583”]what do you see if you go to this address [url]http://172.25.0.99/fog/service/ipxe/boot.php?mac=<mac[/url] address of the computer you’re trying to image>&arch=x86_64[/quote]

    [url="/_imported_xf_attachments/1/1228_boot.php.htm?:"]boot.php.htm[/url]



  • [quote=“Brad Schumann, post: 34342, member: 471”][ATTACH=full]1226[/ATTACH][/quote]

    [ATTACH=full]1227[/ATTACH]

    [url="/_imported_xf_attachments/1/1227_ls-la.png?:"]ls-la.png[/url]


  • Developer

    what do you see if you go to this address [url]http://172.25.0.99/fog/service/ipxe/boot.php?mac=<mac[/url] address of the computer you’re trying to image>&arch=x86_64


  • Senior Developer

    What if you run LS – L a



  • [ATTACH=full]1226[/ATTACH]

    [url="/_imported_xf_attachments/1/1226_ipxe_permission.png?:"]ipxe_permission.png[/url]


  • Developer

    what do the permissions look like on those files?



  • I am sorry, like I said yesterday was a bad day to be the net/sys admin. Below it what the ipxe folder looks like.
    [ATTACH=full]1225[/ATTACH]

    [url="/_imported_xf_attachments/1/1225_ipxe.png?:"]ipxe.png[/url]


  • Developer

    if you see the same files in /tftpboot and /var/www/fog/service/ipxe
    then you have problems



  • [B]This is what I see when I go to /tftpboot basically the same when I go to /var/www/fog/service/ipxe.[/B]

    e [ATTACH=full]1220[/ATTACH]

    [B]Also what my FOG setting looks like.[/B]

    [ATTACH=full]1221[/ATTACH]
    FYI, I love this software, and haven’t really had to touch it for a couple years.

    [url="/_imported_xf_attachments/1/1220_bzimage.png?:"]bzimage.png[/url][url="/_imported_xf_attachments/1/1221_fog_setting.png?:"]fog_setting.png[/url]


  • Senior Developer

    Location of the filenames to make sure are set properly:

    FOG Configuration->FOG Settings->TFTP Server->FOG_TFTP_PXE_KERNEL (this should be bzImage)
    FOG Configuration->FOG Settings->TFTP Server->FOG_TFTP_PXE_KERNEL_32 (this should be bzImage32)
    FOG Configuration->FOG Settings->TFTP Server->FOG_PXE_BOOT_IMAGE (this should be init.xz)
    FOG Configuration->FOG Settings->TFTP Server->FOG_PXE_BOOT_IMAGE_32 (this should be init_32.xz)


  • Senior Developer

    If you can change it to bzImage, and see if you get better luck. it sounds to me like it’s loading file names it can’t find, which would explain the error you’re seeing.



  • that is an excellent question…I don’t know, what should it be? Sorry if I seem a bit “blonde”, been a bad sys admin day. I don’t have any images labeled default, the only thing I have labeled/listed "default is the Storage Group


  • Senior Developer

    Why is your bzImage labeled as: DEFAULT



  • tanks Junk that is good to know, I tried to upload another image like Driver had asked and the PC is flashing this error at me. The PC was able to register just fine. Would you like me to start a different thread for this?

    [ATTACH=full]1219[/ATTACH]

    [url="/_imported_xf_attachments/1/1219_fog upload error.jpg?:"]fog upload error.jpg[/url]


Log in to reply
 

366
Online

38982
Users

10712
Topics

101678
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.