Problem changing the image of folder / dev to / images



  • I use the fog since version 00:32 did the update to version 1.1.2.

    I have a virtual disk apart and have the need to change the folder / images to / mnt / imagensfog and / mnt / imagensfog / dev at 0:32 version worked fine.

    I edited the file / var / www / fog / lib / fog / Config.class.php

    "

           define ('STORAGE_DATADIR', '/ mnt / imagensfog /'); 
           define ('STORAGE_DATADIR_UPLOAD', '/ mnt / imagensfog / dev /'); 
    

    "

    also edited the file / opt / fog / .fogsettings

    "

    # Created by the Installer FOG

    # Version: 1.1.1

    # Install time: Wed 09 Jul 2014 12:51:43 EDT

    ipaddress = “172.16.17.250”;
    interface = “eth0”;
    routeraddress = "option routers 172.16.17.254;"
    plainrouter = “172.16.17.254”;
    dnsaddress = "option domain-name-servers 172.16.17.252;"
    dnsbootimage = “172.16.17.252”;
    password = “f7e1e1”;
    OSID = “2”;
    OSName = “Debian”;
    dodhcp = “C”;
    bldhcp = “0”;
    installtype = “N”;
    snmysqluser = ""
    snmysqlpass = “essa1234”;
    snmysqlhost = “”;

    "

    I edited the file / etc / exports

    for

    / mnt / imagensfog * (ro, sync, no_wdelay, insecure_locks, $ no_ro
    / mnt / imagensfog / dev * (rw, sync, no_wdelay, no_root_squash, insec $

    Apparently everything works fine, but the problem that when I attempt to update a client machine.

    the system begins by placing the image with mac address in / mnt / imagensfog / dev folder, but when the process finishes the OS images are not placed in the folder / mnt / imagensfog.

    I used these commands because of permissions but the problem continues.

    I do not know what I should try to

    the image error appears.

    error_fog.jpg



  • Hello Elliott!

    thanks for the reply, after many attempts I decided to install it again to a new virtual machine with 'ubuntu 14:04 LTS.

    I installed the new version fog '1.2.0 and reconfigured with the footsteps of my previous posts.

    I’ve tested and everything works perfectly including the / mnt / imagensfog the virtual disk that is where I have the images of the OS.

    I exported the ‘cvs the old machine with 143’ hosts made ​​the link to the images of the OS already had, and everything works OK now.

    from the old machine do not know where the problem lay not know if it would be for version 12 ‘ubuntu even if it was for doing the installation over some old version of’ DB fog or even problems in version 'fog 1.1 .2.

    what I am sure is that FTP works in the old machine. because I can access the fog machine via FTP (Fillezila) client with user credentials’ fog
    created when you install the 'ubuntu. I can edit, create pictures from the / mnt / imagensfog and / mnt / imagensfog / dev

    How it works now I think we can now close the POST, the posts that I put the changes that are needed to mount another hard work.

    Thank you for everything

    \ GF


  • Senior Developer

    I need more information in a clear fashion.

    You’re sure ftp is working, but it doesn’t appear that it is working.

    I don’t care if you can access the machine via ssh, as that’s not FTP.

    What do you mean by:
    “Basically the image created in the /mnt/imagensfog/dev is not placed in the folder /mnt/imagensfog, the stop system in 99.98% and the folder is not created with the name of the OS image.”

    You mean it’s not ftp-ing the file from dev to the images directory? That’s performed by FTP which is why we keep asking you about ftp.

    What do you mean that the system stops at 99.98%? The task progress bar rarely goes fully to 100% so that is not an indicator of a problem. The fact that it’s not ftping the file, and my guess is the system isn’t rebooting, is indicative of a problem. Most likely a problem with FTP.

    The information you provide from numbers 2-6 of your above post. Out of all of them, did you update this information in the Storage Management Page. The Values you changed in the Config.class.php file have nothing to do with anything if this was a “re-install” or upgrade from a previously installed FOG system. Are the represented values correct in Storage Management Page. That all said, i think these settings are already correct because you’re able to mount the proper directory without issues and it performs the upload properly up until the image needs to be FTP’d to the /mnt/imagensfog folder after it’s done. Again, can you please verify that FTP is actually working. Not SCP, Not SSH, not nfs, not anything [b]except[/b] FTP.



  • Hello guys! thanks for the answers

    Thanks for the replies, but still could not solve the problem.

    I use the fog '0 .32 in the same condition works perfect, but I needed to migrate the system to new versions by now bearing the win 8 and 8.1.

    I use the fog installed in a virtual machine with ubuntu '12 .04.3.

    1 - did the 'mount a virtual disk '500 GB I am sure that the disk is mounted and that works well.

    2 - I edited the file '/ var / www / fog / lib / fog / Config.class.php

    for

    define (‘STORAGE_DATADIR’, ‘/ mnt / imagensfog /’);
    define (‘STORAGE_DATADIR_UPLOAD’, ‘/ mnt / imagensfog / dev /’);

    3 - I edited the file '/ opt / fog / fogsettings.

    # Created by the Installer FOG

    # Version: 1.1.1

    # Install time: Wed 09 Jul 2014 12:51:43 EDT

    ipaddress = “172.16.17.250”;
    interface = “eth0”;
    routeraddress = "option routers 172.16.17.254;"
    plainrouter = “172.16.17.254”;
    dnsaddress = "option domain-name-servers 172.16.17.252;"
    dnsbootimage = “172.16.17.252”;
    password = “f7e1e1”;
    OSID = “2”;
    OSName = “Debian”;
    dodhcp = “C”;
    bldhcp = “0”;
    installtype = “N”;
    snmysqluser = ""
    snmysqlpass = “essa1234”;
    snmysqlhost = “”;

    4 - also I edited the file / etc / exports to

    '
    / Mnt / imagensfog * (ro, sync, no_wdelay, insecure_locks, $ no_ro
    / Mnt / imagensfog / dev * (rw, sync, no_wdelay, no_root_squash, insec $

    5 - I changed the folder permissions to

    sudo chown-R fog: root / mnt / imagensfog /
    sudo chown-R fog: root / mnt / imagensfog / dev /

    and

    '
    sudo chmod-R 777 / mnt / imagensfog /
    sudo chmod-R 777 / mnt / imagensfog / dev /

    6 - I changed the privileges of the user ‘fog automatically created in the installation’ fog 1.1.2 for 'Administrator

    7 - I schedule the task in your browser to upload the OS of a machine, a fire starts uploading the image begins to be created in the folder / mnt / imagensfog / dev with the 'mac client machine

    8 - ‘Jaymes I can access the machine via client 172.16.17.250’ ftp user with the ‘fog and password’ and e7f1f1 can do to create your folder in / mnt / imagensfog and / mnt / imagensfog / dev test.

    Ie I’m sure that ftp is working.

    9 - I can access the machine 'fog via ssh and manage the entire machine.

    10 - I’ve tried everything but the problem seems continues, please asking for your help.

    11 - Basically the image created in the / mnt / imagensfog / dev is not placed in the folder / mnt / imagensfog, the stop system in 99.98% and the folder is not created with the name of the OS image.



  • This post is deleted!

  • Developer

    Let make sure your ftp is working correctly.

    Can you create an upload-debug task from the advanced options during task deployment and run fog.

    When at the command prompt type:

    
    ftp 172.16.17.250
    

    Then it should ask you for the username to connect as. Type fog.

    Then it should as you to enter the password. Type f7e1e1.

    If you can connect to FTP with your credentials, try to make a folder in there.

    
    cd /mnt/imagensfog
    mkdir test123
    

    Did it all work?



  • hello Elliott !!

    the file complete is

    "

    <?php
    /**

    • Class Name: Config
    • Initializes default settings.
    • Most notably the sql connection.
      /
      class Config
      {
      /
      *
      * Calls the required functions to define the settings.
      * method db_settings()
      * method svc_setting()
      * method init_setting()
      /
      public function __construct()
      {
      self::db_settings();
      self::svc_setting();
      self::init_setting();
      }
      /
      *
      * db_settings()
      * Defines the database settings for FOG
      * @return void
      /
      private static function db_settings()
      {
      define(‘DATABASE_TYPE’, ‘mysql’); // mysql or oracle
      define(‘DATABASE_HOST’, ‘localhost’);
      define(‘DATABASE_NAME’, ‘fog’);
      define(‘DATABASE_USERNAME’, ‘root’);
      define(‘DATABASE_PASSWORD’, ‘essa1234’);
      }
      /
      *
      * svc_setting()
      * Defines the service settings.
      * (e.g. FOGMulticastManager,
      * FOGScheduler,
      * FOGImageReplicator)
      * @return void
      */
      private static function svc_setting()
      {
      define( “UDPSENDERPATH”, “/usr/local/sbin/udp-sender” );
      define( “MULTICASTLOGPATH”, “/opt/fog/log/multicast.log” );
      define( “MULTICASTDEVICEOUTPUT”, “/dev/tty2” );
      define( “MULTICASTSLEEPTIME”, 10 );
      define( “MULTICASTINTERFACE”, “eth0” );
      define( “UDPSENDER_MAXWAIT”, null );
      define( “LOGMAXSIZE”, “1000000” );
      define( “REPLICATORLOGPATH”, “/opt/fog/log/fogreplicator.log” );
      define( “REPLICATORDEVICEOUTPUT”, “/dev/tty3” );
      define( “REPLICATORSLEEPTIME”, 600 );
      define( “REPLICATORIFCONFIG”, “/sbin/ifconfig” );
      define( “SCHEDULERLOGPATH”, “/opt/fog/log/fogscheduler.log” );
      define( “SCHEDULERDEVICEOUTPUT”, “/dev/tty4” );
      define( “SCHEDULERSLEEPTIME”, 60 );
      }

    /**
    * init_setting()
    * Initial values if fresh install are set here
    * NOTE: These values are only used on initial
    * installation to set the database values.
    * If this is an upgrade, they do not change
    * the values within the Database.
    * Please use FOG Configuration->FOG Settings
    * to change these values after everything is
    * setup.
    * @return void
    */
    private static function init_setting()
    {
    define(‘TFTP_HOST’, “172.16.17.250”);
    define(‘TFTP_FTP_USERNAME’, “fog”);
    define(‘TFTP_FTP_PASSWORD’, “f7e1e1”);
    define(‘TFTP_PXE_KERNEL_DIR’, ‘/var/www/fog/service/ipxe/’);
    define(‘PXE_KERNEL’, ‘bzImage’);
    define(‘PXE_KERNEL_RAMDISK’,127000);
    define(‘USE_SLOPPY_NAME_LOOKUPS’,true);
    define(‘MEMTEST_KERNEL’, ‘memtest.bin’);
    define(‘PXE_IMAGE’, ‘init.xz’);
    define(‘PXE_IMAGE_DNSADDRESS’, “172.16.17.252”);
    define(‘STORAGE_HOST’, “172.16.17.250”);
    define(‘STORAGE_FTP_USERNAME’, “fog”);
    define(‘STORAGE_FTP_PASSWORD’, “f7e1e1”);
    define(‘STORAGE_DATADIR’, ‘/mnt/imagensfog/’);
    define(‘STORAGE_DATADIR_UPLOAD’, ‘/mnt/imagensfog/dev/’);
    define(‘STORAGE_BANDWIDTHPATH’, ‘/fog/status/bandwidth.php’);
    define(‘UPLOADRESIZEPCT’,5);
    define(‘WEB_HOST’, “172.16.17.250”);
    define(‘WOL_HOST’, “172.16.17.250”);
    define(‘WOL_PATH’, ‘/fog/wol/wol.php’);
    define(‘WOL_INTERFACE’, “eth0”);
    define(‘SNAPINDIR’, “/opt/fog/snapins/”);
    define(‘QUEUESIZE’, ‘10’);
    define(‘CHECKIN_TIMEOUT’,600);
    define(‘USER_MINPASSLENGTH’,4);
    define(‘USER_VALIDPASSCHARS’, ‘1234567890ABCDEFGHIJKLMNOPQRSTUVWZXYabcdefghijklmnopqrstuvwxyz_()^!#-’);
    define(‘NFS_ETH_MONITOR’, “eth0”);
    define(‘UDPCAST_INTERFACE’, “eth0”);
    define(‘UDPCAST_STARTINGPORT’, 63100 ); // Must be an even number! recommended betw$
    define(‘FOG_MULTICAST_MAX_SESSIONS’,64);
    define(‘FOG_JPGRAPH_VERSION’, ‘2.3’);
    define(‘FOG_REPORT_DIR’, ‘./reports/’);
    define(‘FOG_UPLOADIGNOREPAGEHIBER’,true);
    define(‘FOG_DONATE_MINING’, “1”);
    }
    }

    I really need to solve this problem Thanks TOM

    "


  • Senior Developer

    I’m on my cell phone and can’t provide specific details sorry.


  • Senior Developer

    What? Very the FTP user and password. User is fog and password, according to the file is f7e1e1



  • I do not understand what is going send the image of the FOG 1.1.2 as you can verify the update crashes in 99.98%

    Captura de ecrã de 2014-07-21 17:22:22.png


  • Senior Developer

    Where’s the rest of the file?? That said did you test FTP?



  • and this is te configurations of TFTP server

    Captura de ecrã de 2014-07-21 17:16:50.png



  • This post is deleted!


  • This post is deleted!


  • hello !

    this is the configuration of config.class.php

    "
    private static function init_setting()
    {
    define(‘TFTP_HOST’, “172.16.17.250”);
    define(‘TFTP_FTP_USERNAME’, “fog”);
    define(‘TFTP_FTP_PASSWORD’, “f7e1e1”);
    define(‘TFTP_PXE_KERNEL_DIR’, ‘/var/www/fog/service/ipxe/’);
    define(‘PXE_KERNEL’, ‘bzImage’);
    define(‘PXE_KERNEL_RAMDISK’,127000);
    define(‘USE_SLOPPY_NAME_LOOKUPS’,true);
    define(‘MEMTEST_KERNEL’, ‘memtest.bin’);
    define(‘PXE_IMAGE’, ‘init.xz’);
    define(‘PXE_IMAGE_DNSADDRESS’, “172.16.17.252”);
    define(‘STORAGE_HOST’, “172.16.17.250”);
    define(‘STORAGE_FTP_USERNAME’, “fog”);
    define(‘STORAGE_FTP_PASSWORD’, “f7e1e1”);
    define(‘STORAGE_DATADIR’, ‘/mnt/imagensfog/’);
    define(‘STORAGE_DATADIR_UPLOAD’, ‘/mnt/imagensfog/dev/’);
    define(‘STORAGE_BANDWIDTHPATH’, ‘/fog/status/bandwidth.php’);
    define(‘UPLOADRESIZEPCT’,5);
    define(‘WEB_HOST’, “172.16.17.250”);
    define(‘WOL_HOST’, “172.16.17.250”);
    define(‘WOL_PATH’, ‘/fog/wol/wol.php’);
    define(‘WOL_INTERFACE’, “eth0”);
    define(‘SNAPINDIR’, “/opt/fog/snapins/”);
    define(‘QUEUESIZE’, ‘10’);
    define(‘CHECKIN_TIMEOUT’,600);
    define(‘USER_MINPASSLENGTH’,4);
    define(‘USER_VALIDPASSCHARS’, ‘1234567890ABCDEFGHIJKLMNOPQRSTUVWZXYabcdefghijklmnopqrstuvwxyz_()^!#-’);
    define(‘NFS_ETH_MONITOR’, “eth0”);
    define(‘UDPCAST_INTERFACE’, “eth0”);
    define(‘UDPCAST_STARTINGPORT’, 63100 ); // Must be an even number! recommended betw$
    define(‘FOG_MULTICAST_MAX_SESSIONS’,64);
    define(‘FOG_JPGRAPH_VERSION’, ‘2.3’);
    define(‘FOG_REPORT_DIR’, ‘./reports/’);
    define(‘FOG_UPLOADIGNOREPAGEHIBER’,true);
    define(‘FOG_DONATE_MINING’, “1”);
    }

    "

    is the same of the storage management

    Captura de ecrã de 2014-07-21 17:15:04.png


  • Senior Developer

    Have you verified the FTP password is correct? That’s the f7e1e1 part you see in the fogsettings file.



  • the permission of folder

    sudo mkdir -pv /mnt/imagensfog/dev
    sudo touch /mnt/imagensfog/{.mntcheck,dev/.mntcheck}
    sudo chown -R fog:root /mnt/imagensfog
    sudo chmod -R 777 /mnt/imagensfog


Log in to reply
 

429
Online

38715
Users

10543
Topics

99813
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.