Not deploying after reboot



  • Hello - I am encountering a problem with my Ubuntu 12.04.4 FOG server running version 1.1.0. I have an image for a Dell 7010 and am attempting to send the image to another 7010 on the same small 8-port switch (it is not connected to the Internet). I am able to PXE boot and to get to the server menu, and host registry works perfectly fine. However, when the computer to be imaged is rebooted by the registration process, it boots straight to Windows 7 (the currently installed OS). Even when I manually activate PXE booting, I am only able to get to the FOG menu again and no image gets deployed.

    I am not sure that this is a related problem, but I cannot access the debug mode or the quick image option either. I have only one password set for all options on the FOG server for simplicity’s sake, but the password I have used does not work for either of these options.

    Thanks all for your help.


  • Senior Developer

    Change the kernel back to just plain jane bzImage.64.

    As you’re not deploying to the point where it even downloads that, my suspicion is in the boot parameters.

    To test this is going to be difficult and I may just request a remote session if at all possible where I can connect and tweak a few file on your fog server.



  • It was set to bzimage.64. I just now set it to /var/www/fog/service/ipxe/bzimage.64 to see if anything would change, but there hasn’t been any change.


  • Senior Developer

    is the options set to bzImage.64 or bzImage?



  • The bzimage.64 kernel is located in fog/service/ipxe, and the fog options under confirm TFTP options confirm that it’s in use. I haven’t modified it.


  • Developer

    i see a reference to kernel bzimage.64 in your boot.php output, does does this file exist with this exact name, in the fog/service/ipxe directory of the web server? what have you done to update or modify the kernel being used?



  • Still experiencing this problem - any new insights?



  • [quote=“Tom Elliott, post: 33687, member: 7271”]Try:
    [code]mysql -u root fog
    select * from hosts where hostID=‘0’;
    [/code][/quote]

    Returns: Empty set (0.00sec)


  • Senior Developer

    Try:
    [code]mysql -u root fog
    select * from hosts where hostID=‘0’;
    [/code]



  • [quote=“Junkhacker, post: 33672, member: 21583”]it sounds like your boot order isn’t set up correctly.
    also, try going to [url]http://<address[/url] of fog server>/fog/service/ipxe/boot.php?mac=<mac address of computer>&arch=x86_64
    and let us know what you see[/quote]
    This is what I see:

    #!ipxe
    kernel bzimage.64 root=/dev/ram0 rw ramdisk_size=127000 ip=dhcp dns=10.1.1.15 keymap= web=10.1.57.10/fog/ consoleblank=0 loglevel=4 mac=(mac address) ftp=10.1.57.10 storage=10.1.57.10:/images/ storageip=10.1.57.10 web=10.1.57.10/fog/ osid=5 loglevel=4 consoleblank=0 irqpoll chkdsk=0 img=Student imgType=n imgid=1 imgLegacy=1 PIGZ_COMP=-9 hostname=7010-blank type=down
    imgfetch init.xz
    boot
    [quote=“Jaymes Driver, post: 33654, member: 3582”]Is your BIOS by chance set to fast boot?

    And not to beat a dead horse, but is there a “boot menu” you can call by pressing F11 or F12 during boot? If selecting this while a task is active for the machine does it display the DHCP information like it is looking to pxe boot and just skip over it?[/quote]

    I have it currently set to boot straight to the LAN, so I don’t need to press f12 each time I need to test it. It does display the DHCP info for about a tenth of a second before launching straight to the FOG menu. That doesn’t seem to be the problem I am having.

    [quote=“Wolfbane8653, post: 33650, member: 3362”]try a:
    [CODE]#mysql -u root

    mysal> select * from hosts where hostid=0;
    [/CODE]

    Please post the results.[/quote]

    Entering this information into the terminal gives me this: ERROR 1046 (3D000): No database selected


  • Developer

    it sounds like your boot order isn’t set up correctly.
    also, try going to [url]http://<address[/url] of fog server>/fog/service/ipxe/boot.php?mac=<mac address of computer>&arch=x86_64
    and let us know what you see


  • Developer

    Is your BIOS by chance set to fast boot?

    And not to beat a dead horse, but is there a “boot menu” you can call by pressing F11 or F12 during boot? If selecting this while a task is active for the machine does it display the DHCP information like it is looking to pxe boot and just skip over it?


  • Developer

    try a:
    [CODE]#mysql -u root

    mysal> select * from hosts where hostid=0;
    [/CODE]

    Please post the results.



  • [quote=“Wolfbane8653, post: 33644, member: 3362”]Take me step-by-step here. You boot the machine then what does it go to? Directly to windows? Nothing about getting DHCP or iPXE Configuring?[/quote]

    [quote=“x23piracy, post: 33645, member: 3982”]Hi,

    he registers a host, then in the meantime he creates a task with an image assigned, else he couldn’t plan a task.
    Then when the machine will be network booted, it enters only the pxe menu instead of starting imaging immediatelly.

    Regards[/quote]

    Well, I create the machine using the full registration tool, then watch my Ubuntu server, where it creates a task for itself. Then I reboot, and it boots to Windows without any pause for PXE recognition or anything. Manually booting via the NIC or setting the NIC as the first bootable device only gets me back to the FOG boot menu. If I attempt to do the full registration again, I get an error saying that the device is registered (which it is, as I can see it on the server) and the computer reboots, only to start the cycle again.

    EDIT I should add that if I add the machine and then manually create a task for it, it still does not image.



  • Hi,

    he registers a host, then in the meantime he creates a task with an image assigned, else he couldn’t plan a task.
    Then when the machine will be network booted, it enters only the pxe menu instead of starting imaging immediatelly.

    Regards


  • Developer

    [quote=“Ron L, post: 33633, member: 24685”]Still unable to get the reboot to start the image automatically - just boots straight to windows.[/quote]

    Take me step-by-step here. You boot the machine then what does it go to? Directly to windows? Nothing about getting DHCP or iPXE Configuring?



  • Hi,

    in the end do not forget what Wolfbane8653 told you to do…

    [quote=“Wolfbane8653, post: 33629, member: 3362”]Check your version of BIOS and confirm you have the most up-to-date version downloaded from the Dell support page. Then confirm your settings for PXE boot and turn off the LAST STATE settings.[/quote]

    [url]http://www.tomshardware.co.uk/forum/106815-30-what-power-last-state-bios[/url]

    Regards X23



  • [quote=“x23piracy, post: 33640, member: 3982”]Hi,

    i think debugging this step by step will bring the bug out of his hole but i don’t know enough about the internals how fog actually acts.
    Lets wait for someone more skilled ;)

    Regards X23[/quote]

    You stumbled upon my devious plan all on your own! Thank you for your suggestions, though. :) I appreciate your time. Anyone else wanna take a stab at this? I’m about ready to hire a fortune teller to divine why it’s failing.



  • Hi,

    i think debugging this step by step will bring the bug out of his hole but i don’t know enough about the internals how fog actually acts.
    Lets wait for someone more skilled ;)

    Regards X23



  • [quote=“x23piracy, post: 33636, member: 3982”]Hi,

    maybe the task creation does not work or fire right?
    I don’t know how but you need to check if the task creation is ok.

    With pxelinux it was possible to save a file named with the mac of the machine in pxelinux’s boot folder, that was triggered if the matching mac tried to boot, then you know your task should work but i think this changed with current fog version.

    I think today it boots to ipxe and after boot, tasks will be checked by http with php script that will fire actions to the client maybe iam wrong here but then i don’t know what is needed to check the task creation is doing all fine.

    Regards X23[/quote]

    The task shows up in Task Management. Pressing the Force button also has no effect. Even when I make the task myself, nothing happens, only boots to the menu if I prompt it.


Log in to reply
 

340
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.