Fog 1.1.2 - Capable of Ignoring a MAC address completely?



  • I have an HVAC Controller on the Network that PXE boots. Recently had a power flicker, Controller reboots, The Device hangs. Pull the Controller off the network and reboot; Everything works fine. Repeat on the network; Hangs.

    Can I have fog ignore a mac address or will this have to be done using an ACL over the network?



  • I’m in process to see if I can disable but They have it bios locked.



  • I do not. The HVAC Technician uses PXE to boot to the device when making a trouble call.



  • Its an issue with your current network configuration. You might be able to filter that MAC address in DHCP from PXE booting. Also why does it need PXE boot enabled if its not PXE booting from fog? Do you have multiple PXE servers on that subnet?


  • Developer

    if ipxe loading at all is the problem, then you’ll have to take care of it on the network before it ever gets to fog
    if it’s the exit type of ipxe trying to boot to a hard drive, and the embeded system doesn’t understand, you could try changing the boot menu exit type
    also, you could try the following edit to your default.ipxe file

    iseq ${net0/mac} <HVAC MAC> && exit ||
    chain http://<fog ip address>/fog/service/ipxe/boot.php##params[/CODE]



  • The Controller needs the PXE boot enabled. It is undesirable to have the fog server communicate with it at all.

    It is xp embedded but I don’t have a way to visually see the boot up.


  • Developer

    do you mean that it needs to pxe boot, or that it defaults to pxe boot if it’s available and that is undesirable?
    do you have any means of detecting at what point it hangs?


Log in to reply
 

420
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.