Fog_1.1.2 - Ubuntu 12.04.1 - tftp open time out....



  • Hi,

    I had a FOG server 1.1.2 on Ubuntu 12.04.1.
    When clients boot to the network they are able to get a DHCP address but then gets an open timeout error on TFTP.

    I tried :
    [SIZE=12px]sudo service tftpd-dpa stop, start, restart… (works in 0.32)[/SIZE]
    tftp -v 10.1.X.X -c get undionly.kpxe
    sudo ufw disable

    and… tftp… open timeout :mad:

    I searched in the forum but I have not found the solution but I have seen this message :
    [quote=“Tom Elliott, post: 31468, member: 7271”]I don’t have a clue what the problem is. I’m aware of a problem with tftpd-hpa starting on bootup issues which we have a workaround fix for. I’ve never heard of it just randomly stopping at periods of time.[/quote]

    What is this famous solution please ?

    [SIZE=12px][/SIZE]


  • Developer

    Well, is tftpd-hpa service running when you reboot the machine?

    If so then the fix won’t help you. If the service is not starting there is a way to make the service wait until the machine is booted and then it starts the service.

    Incase it is the later of the two, the resolve is:

    Change the line
    [code]
    start on runlevel [2345][/code]
    in /etc/init/tftpd-hpa.conf to

    [code]
    start on (local-filesystems and net-device-up IFACE!=lo)
    [/code]
    And it is not a fault of FOG, this is a known issue with Ubuntu 12.04, and 14.04

    You could try re-installing the tftpd-hpa service and see if that solves the issue:

    [code]
    sudo apt-get remove --purge tftpd-hpa
    sudo apt-get update
    sudo apt-get install tftpd-hpa
    [/code]


Log in to reply
 

365
Online

38982
Users

10712
Topics

101678
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.