FOG Advance Menu Configuration hiren iso not starting



  • Hi guys!
    I’m trying to add the Hiren iso to the pxe advance menu.
    I have check the wiki link [url]http://www.fogproject.org/wiki/index.php/Advanced_Boot_Menu_Configuration_options[/url] in order to check that i’m not missing something.
    Also i have read the post [url]http://fogproject.org/forum/threads/how-to-modify-the-pxe-boot-menu-to-allow-the-booting-of-iso-files.154/[/url] .

    But when i select the option Hiren on the advanced menu i just take me back to the main Menu.

    This is what i have on the Advanced Menu Configuration option:

    [PHP]#!ipxe
    cpuid --ext 29 && set arch x86_64 || set arch i386
    colour --rgb 0xff6600 2
    cpair --foreground 7 --background 2 2
    console --picture http://${fog-ip}/${fog-webroot}/service/ipxe/bg.png --left 100 --right 80

    :MENU
    menu
    item --gap – ---------------- Advance boot menu ----------------
    item hiren Hiren Boot CD
    item hostinfo Detalles del Host
    item return return to previous menu
    choose --default return --timeout 5000 target && goto ${target}

    :hiren
    initrd http://${fog-ip}/${fog-webroot}/ISO/hiren.iso
    chain memdisk iso raw ||
    goto MENU

    :hostinfo
    echo This computer : ||
    echo MAC address…${net0/mac} ||
    echo IP address…${ip} ||
    echo Netmask…${netmask} ||
    echo Serial…${serial} ||
    echo Asset number…${asset} ||
    echo Manufacturer…${manufacturer} ||
    echo Product…${product} ||
    echo BIOS platform…${platform} ||
    echo ||
    echo press any key to return to Menu ||
    prompt
    goto MENU

    :return
    chain http://${fog-ip}/${fog-webroot}/service/ipxe/boot.php?mac=${net0/mac} ||
    prompt
    goto MENU[/PHP]

    can anyone point me on the right direction?
    I’m Using FOG 1.1.2
    PD: Sorry for my bad English, it is not my native language.



  • Hello, guys!

    Really sorry about the time frame. I was able to boot Hiren correctlly usinng the latest version. 15.2.

    Thanks everyone for the Help, and let me apologies again for the time i took to reply.

    regards,



  • [quote=“thc3pt3r, post: 33149, member: 24771”]Wondering if maybe is the version of hiren? I’m using Hiren 15.0.[/quote]

    Did you get yours to work? Pls let us know dude! This post of yours helped me fix my issue.

    [url]http://fogproject.org/forum/threads/what-files-to-edit-to-change-the-new-undionly-kpxe-pxe-boot-menu-in-fog-1-1-2.11185/#post-33575[/url]



  • Well i was able to boot another iso image , but not this one from Hiren. Wondering if maybe is the version of hiren? I’m using Hiren 15.0
    I’m gonna try a different one and let you know.



  • This post is deleted!


  • [quote=“x23piracy, post: 33140, member: 3982”]Hi,

    try to reach[COLOR=#000000][COLOR=#0000bb][CODE]http://${fog-ip}/${fog-webroot}/ISO/hiren.iso[/CODE][/COLOR][/COLOR]with a browser.
    Remember linux ist case sensitive!

    What happens?

    Regards X23[/quote]

    [COLOR=#0000bb][FONT=Consolas]It gives me: “Page can not be display” message[/FONT][/COLOR]
    [COLOR=#0000bb][FONT=Consolas]So i change it to [url]http://10.210.279/fog/ISO/hiren.iso[/url] and it gives me the download from the ISO[/FONT][/COLOR]
    [COLOR=#0000bb][FONT=Consolas]Whit this change, it not redirecting me to the main Menu,but instead is giving me a black screen.[/FONT][/COLOR]


  • Developer

    [quote]
    But when i select the option Hiren on the advanced menu i just take me back to the main Menu.
    [/quote]
    typically that means that it failed to find the file

    try this line substitution
    [COLOR=#0000bb][FONT=monospace]initrd http[/FONT][/COLOR][COLOR=#007700][FONT=monospace]:[/FONT][/COLOR][COLOR=#ff8000][FONT=monospace]//${fog-ip}/${fog-webroot}/ISO/hiren.iso || echo file not found && prompt[/FONT][/COLOR]



  • Hi,

    try to reach[COLOR=#000000][COLOR=#0000bb][CODE]http://${fog-ip}/${fog-webroot}/ISO/hiren.iso[/CODE][/COLOR][/COLOR]with a browser.
    Remember linux ist case sensitive!

    What happens?

    Regards X23



  • This post is deleted!

Log in to reply
 

422
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.