Unable to upload first image



  • Hi,

    This is my first attempt with FOG and Linux and I need some help uploading an image.

    I have followed all the guides and installed the latest FOG version on Ubuntu 13:10. I have created a virtual XP machine as a test image, sys-prepped it etc and followed the guides on the FOG wiki to register and upload the image.

    Now I am getting one of two problems. The first is that the image upload halts at the command line:

    /bzImage32…ok
    /init_32.xz…93%

    Or it fail completely with a kernal panic, failed to initalise, then the VM quits out.

    What am I doing wrong? is it my FOG image settings or is there something I am missing. I have followed the wiki guides to the letter so far.


  • Senior Developer

    Did you not try doing a “Bridged” adapter?



  • Just a quick update but I got the system to work.

    I reinstalled from scratch this morning, Ubuntu and Fog and avoided using virtual machines. I made an image on a physical PC, it uploaded fine and it deployed to an old client PC we had spare.

    it must have been the virtual PC’s that had the issue.

    Thanks for the help though :)



  • OK tried that. Same issue. It now says:

    tsc: Fast TSC calibration failed then doesn’t do anything before displaying the kernel panic again


  • Senior Developer

    That’s okay,

    Follow the second line then.



  • Yes, the line:

    sudo mv /tftpboot/pxelinux.0 /tftpboot/pxelinux.0.WORKS

    fails as it says pxelinux.0 does not exist


  • Senior Developer



  • Yeah I have tried reinstalling 3 times now since Friday.

    The command line you gave didn’t work as it says I have no PXElinux.0 file. Only a pxelinux.0.old file. Im just so frustrated with this but we desperately need it in my work :(



  • Have you tried to reinstalling Ubuntu? I have not seen a Kernel Panic using FOG before, but I have had a bad install of Ubuntu for no reason.


  • Senior Developer

    My guess is your pxelinux.0 method isn’t chaining properly to ipxe. That and the file is properly really old. A sneaky method you could try is to link the undionly.kpxe file to pxelinux.0:
    [code]sudo mv /tftpboot/pxelinux.0 /tftpboot/pxelinux.0.WORKS
    sudo ln -s /tftpboot/undionly.kpxe /tftpboot/pxelinux.0[/code]

    Then try booting.

    It sounds to me like it’s trying to boot the init_32.xz with the bzImage which won’t work. That or it’s vice-versa trying to boot the init.xz with the bzImage32.



  • Please, has anyone seen this before?

    I need to figure out why this Kernel Panic keeps happening or this project will be scrapped by my manager :(

    I have tried building images on both VM and physical machines but each time I get this kernel panic. I managed to upload an image once but when I tried to deploy it I got the same ‘failed to sync’ error. This happened on both virtual and physical machines.



  • I have managed to get a screengrab of the kernal panic error. Sorry for the size

    [url="/_imported_xf_attachments/1/1164_Kernal Panic.png?:"]Kernal Panic.png[/url]


Log in to reply
 

369
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.