Force reboot from server?



  • Hi All,

    Things are starting to come together and look amazing with the FOG server setup. I just need to figure out the next step. I’ve searched the forums everywhere and cant find exactly what im looking for. So here goes.

    I am looking for when I create a task in the server interface, that it will send a reboot command to the PC to reboot. I thought this was already installed but cannot seem to get it working. so here’s what I do.

    1. From the server, Host Management > List All Hosts
    2. Select ‘upload’ on desired host (which is Windows 7)
    3. Schedule Instant Deployment > Create Upload Task
    4. Wait and nothing happens.

    All hosts have been ran with FOGPrep, FOGService, and FOGCrypt

    Once the task is created, should it not automatically reboot itself and start the image process?



  • Having the same problem. Images upload and download nicely, just no luck with getting hosts to reboot with instant image task scheduled. Reboot service is enabled everywhere and client installed. WoL is not working either, even though it’s enabled in bios and Windows drivers.



  • ok, still no luck.

    I install a clean/fresh windows 7 OS and then installed Fogservice/prep/crypt

    All the setting are correct. Disabled ‘task reboot’ globally and for host settings. Enabled ‘task reboot’.

    Bios is set to WOL/magic packet

    Thought I read somewhere, do I need to set up a generic user specific for FOG?
    Does the host PC need to be in sleep state or idle for x number of time?

    FOG v 1.1.2
    Ubuntu 12.04



  • I was able to get a .bat file to run in the snapin to reboot the PC. (shutdown -r)



  • Thanks for all this help Tom,

    I did as you asked with no luck. This is what its saying again when I create an image task after the reboot reset.

    7/17/2014 11:15 PM FOG::SnapinClient Module is active…
    7/17/2014 11:15 PM FOG::SnapinClient No Tasks found for: F8:B1:56:A4:55:A9
    7/17/2014 11:21 PM FOG::SnapinClient Attempting to connect to fog server…
    7/17/2014 11:21 PM FOG::SnapinClient Module is active…
    7/17/2014 11:21 PM FOG::SnapinClient No Tasks found for: F8:B1:56:A4:55:A9
    7/17/2014 11:26 PM FOG::SnapinClient Attempting to connect to fog server…
    7/17/2014 11:26 PM FOG::SnapinClient Module is active…
    7/17/2014 11:26 PM FOG::SnapinClient Will NOT perform any snapin tasks because an image task exists for this host.
    7/17/2014 11:31 PM FOG::SnapinClient Attempting to connect to fog server…
    7/17/2014 11:31 PM FOG::SnapinClient Module is active…
    7/17/2014 11:31 PM FOG::SnapinClient Will NOT perform any snapin tasks because an image task exists for this host.
    7/17/2014 11:36 PM FOG::SnapinClient Attempting to connect to fog server…
    7/17/2014 11:36 PM FOG::SnapinClient Module is active…
    7/17/2014 11:36 PM FOG::SnapinClient Will NOT perform any snapin tasks because an image task exists for this host.


  • Senior Developer

    Can you try unsetting the service modules for the host. Save/update, then enable them all and save/update host.



  • Its enabled on the “Host Management > Host Name > Service Settings > Service Configuration” tab on the server.

    It is checked globally also.

    Is there one on the host I need to find?

    I have all services check on the host service tab.


  • Senior Developer

    To check if it’s globally active, goto:
    Service Management Page (looks like DJ volume knobs) Click Task Reboot link. Is the checkbox checked?

    To check if it’s on the host, goto:
    Host Management Page -> search/list all -> choose the host you are having issues with to edit (click the hostname) -> Service Settings link. Is the Task Reboot service checked there?



  • think so but not sure how to exactly check.


  • Senior Developer

    Is it enabled globally as well?


  • Senior Developer

    Is TaskReboot enabled on the host?



  • ok, so after creating the task to upload/download an image on the server, the host pc will not automatically reboot.

    I have let it sit for 12 hours and no luck. Here is the log and what’s its doing.

    7/17/2014 4:00 AM FOG::SnapinClient Attempting to connect to fog server…
    7/17/2014 4:00 AM FOG::SnapinClient Module is active…
    7/17/2014 4:00 AM FOG::SnapinClient No Tasks found for: F8:B1:56:A4:55:A9
    7/17/2014 4:05 AM FOG::SnapinClient Attempting to connect to fog server…
    7/17/2014 4:05 AM FOG::SnapinClient Module is active…
    7/17/2014 4:05 AM FOG::SnapinClient No Tasks found for: F8:B1:56:A4:55:A9
    7/17/2014 4:10 AM FOG::SnapinClient Attempting to connect to fog server…
    7/17/2014 4:10 AM FOG::SnapinClient Module is active…
    7/17/2014 4:10 AM FOG::SnapinClient Will NOT perform any snapin tasks because an image task exists for this host.
    7/17/2014 4:15 AM FOG::SnapinClient Attempting to connect to fog server…
    7/17/2014 4:15 AM FOG::SnapinClient Module is active…
    7/17/2014 4:15 AM FOG::SnapinClient Will NOT perform any snapin tasks because an image task exists for this host.
    7/17/2014 4:20 AM FOG::SnapinClient Attempting to connect to fog server…
    7/17/2014 4:20 AM FOG::SnapinClient Module is active…
    7/17/2014 4:20 AM FOG::SnapinClient Will NOT perform any snapin tasks because an image task exists for this host.
    7/17/2014 4:26 AM FOG::SnapinClient Attempting to connect to fog server…
    7/17/2014 4:26 AM FOG::SnapinClient Module is active…
    7/17/2014 4:26 AM FOG::SnapinClient Will NOT perform any snapin tasks because an image task exists for this host.

    How do I get it to reboot and start the image process?



  • Thanks x23 for the response.

    unfortunately that doesn’t seem to be working. I set the BIOS to wake on magic packet. I have the FOG service installed.

    Does the computer need to be in sleep state or can I be on the Desktop for it to auto reboot and start the imaging?



  • Hi,

    the machine to image will only reboot if fog service is installed, else the image will only proceed after the next network boot. if the machine is switched of an instant deploy generates a wake up on lan magic paket that will boot the desired machine, on some computers you have to enable wake up on lan and for some notebooks you have to enable wol without AC if not charging.

    Regards X23



  • Sorry, Specs:

    Server:
    Ubuntu 12.04LTS
    Dell XPS with dual NIC

    Hosts:
    Dell OptiPlex 990
    Windows 7 64bit


Log in to reply
 

413
Online

38722
Users

10550
Topics

99863
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.