Fog menu won't show after pxe restart



  • I set up a ubunt12 + fog 0.32, and when i start the client pc through PxE (to register the host in fog) instead of the expected fog menu (with several choices) I get this one (see file). any idea what is missing?

    image.jpg


  • Testers

    Thats right, all you would need to change is “bootfile pxelinux.0” to “bootfile undionly.kpxe”.

    As for which version I would recommend 1.2 personally, I switched our systems about a month ago and the changes have all been positive for me: I found the linux handling is vastly improved and iPXE seems much more flexible. The front page of the wiki (http://fogproject.org/wiki/index.php/Main_Page) has a summary of some of the more important changes.

    Incidentally when I put up my fog server I also thought I wouldn’t be using it a lot, but I ended up using it ways I wasn’t expecting (system rescue, “backing up” or migrating hardware), I leave it up all the time now :-)


  • Senior Developer

    You can do this:

    sudo ln -s /tftpboot/undionly.kpxe /tftpboot/pxelinux.0
    

    This is a hack if you can’t simply get the dhcp file setup.



  • Well, than that is the info I will have to ask to the central service of the ministry of education. You know I had to ask them to set a certain switch door to these configs:
    next-server 10.1.8.1
    bootfile pxelinux.0

    So you are saying that if I want to use fog 1.X I have to substitute the pxelogfile with the undionly.kpxe ?

    Is there a real advantage in having the fog 1.2 version? I ask this cause we probably will use the fog server only once a year (at the end of a schoolyear) or if there is a need to reset a machine. Other than that, the server will be down.


  • Testers

    From your screenshot it looks like the filename was wrong when trying fog 1.X. Fog 0.32 use pxelinux.0 and fog 1.x uses undionly.kpxe, if you want to use fog 1.X you have to make that change in your DHCP.



  • Sorry guys, the problem is solved ;) In the pxe boot menu configuration (fog server) I set up a masterpassword for the graphic type and suddenly it worked. I have normal acces to the fog menu when I reboot the host through pxe, where I can choose to register, etc…

    Why I use 0.32 version? I tried the 1.2 version but everytime I tried to restart the host through pxe I got error messages. Even after restarting tftp I still would get the pxe error that you can see in the foto. Since I did not know what to do, and all my firends couldn’t help me either, I decided to setup the 0,32 version.

    My fog server is in a school, and our network is run by a central system belonging to the ministry of education. So there are things that we have to ask them to set up. I know that this fog server works in other schools, but with the 0.32 version. I’m probably the first who tried to set it up with the 1.2 version, but it didn’t work. As long as the 0.32 version does what we need, I don’t mind.

    10552006_1426284424326019_1211090989_n.jpg



  • Hi,

    why do you try the old 0.32?

    Regards X23


Log in to reply
 

371
Online

38719
Users

10548
Topics

99848
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.