WINDOWS 7 WILL NOT BOOT AFTER DEPLOY



  • Thanks in advance everyone !!!

    i have been using for for years and had no issues with XP, however 7 is driving me crazy.

    I had try both SINGLE DISK(NTFS ONLY, RESIEZABLE) and MULTIPLE PARTITION IMAGE - SINGLE DISK (NOT RESIZABLE). I am able to upload the image to the FOG server ( Release 1.1.2 ) on a Ubuntu Desktop 64 bit with no problem from a GIGABYTE GA-H61M-S2PV but after a deploy the image to another PC with the same board, windows will simply wont boot.

    What have i done to sysprep the image before uploading

    1.- upload the image right after installing, updating and installing drivers ( no sysprep, nothing )

    2.-
    [SIZE=4][B][FONT=sans-serif][SIZE=17px][COLOR=#000000]Windows Vista and Windows 7[/COLOR][/SIZE][/FONT][/B][/SIZE]

    [FONT=sans-serif][COLOR=#000000]Right before uploading the image the MountedDevices registry key must be cleared. If it is not, the master image and subsequent deploys will result in this problem: [URL=‘http://www.fogproject.org/wiki/index.php/Vista_Image_says_0xc000000e_\windows\system32\winload.exe_can_not_be_loaded’][COLOR=#5a3696]Vista Image says 0xc000000e \windows\system32\winload.exe can not be loaded[/COLOR][/URL][/COLOR][/FONT]
    [FONT=sans-serif][COLOR=#000000]This can be accomplished by [I]any [U]one[/U][/I] of the following methods:[/COLOR][/FONT]
    [LIST=1]
    []use Sysprep with the /generalize switch
    [
    ]run [URL=‘http://www.fogproject.org/wiki/index.php?title=FOGprep&action=edit&redlink=1’][COLOR=#a55858]FOGprep[/COLOR][/URL].exe ( I HEARD THIS IS NOT NEEDED ANYMORE, DIDN’T RUN IT)
    []manually delete the [FONT=monospace]??\volume{…}[/FONT] keys in the registry under “HKLM\SYSTEM\MountedDevices”
    [
    ]run the following from an administrator’s console:
    [/LIST]
    [COLOR=#000000][FONT=monospace]bcdedit /set {bootmgr} device boot
    bcdedit /set {default} device boot
    bcdedit /set {default} osdevice boot[/FONT][/COLOR]

    still No luck !!!

    Please correct me if am wrong, i know that at some point i have to create an unattended.xml file for better deployment, but i at least want to make sure that i can deploy images.

    What am i missing ?
    Do i have to do something to the bios ( UFEI ) ?

    again very much appreciated.



  • Not to confuse anyone i will start a new thread as i go because they are different threads

    please see [url]http://fogproject.org/forum/threads/uefi-vs-legacy-bios-gpt-vs-mbr-single-partition-resizable-vs-multiple-partition-notresizable.11124/[/url]

    • Since FOG does not fully support UEFI i suggest just to disable this feature in the Bios before even installing the OS. If someone can * make it work with no issues with UEFI please share it so that i/we can understand it better.


  • SUCCESS !!!
    Well now i want to find out exactly what the problem is. I believe now i have different variables :

    • I did disable UEFI and used Legacy Only.

    • I installed Windows 7 64 b Only, No updates, No drivers. ( Tom mentioned something about unsigned drivers )

    • I used “debug-upload” which alert me of :
      Found valid MBR and GPT. Which do you want to use?
      As Tom suggested i
      (CTRL + C)
      # fixparts /dev/sda
      # y
      # w
      # y
      # fog ( to start upload )

    further testing !!!

    • I am going to update windows plus drivers and try to upload. i have a feeling is going to work, just curious.
    • Re install Windows 7 again with UEFI but in “debug-upload” mode to see if it complains about the partitions.

    again guys very much appreciated. I will keep posting my findings hopefully it will save some time for someone !!!
    [ATTACH=full]1152[/ATTACH][ATTACH=full]1153[/ATTACH][ATTACH=full]1154[/ATTACH]

    [url="/_imported_xf_attachments/1/1152_IMAG0081.jpg?:"]IMAG0081.jpg[/url][url="/_imported_xf_attachments/1/1153_IMAG0082.jpg?:"]IMAG0082.jpg[/url][url="/_imported_xf_attachments/1/1154_IMAG0083.jpg?:"]IMAG0083.jpg[/url]


  • Senior Developer

    um Break out (CTRL + C)

    Run fixparts then press w



  • Guys,
    i have a new PC with the same hardware, no updates and also i disable UEFI, is using legacy. please see the pic … What should i answer ?[ATTACH=full]1149[/ATTACH]

    [url="/_imported_xf_attachments/1/1149_FreshInstallNoUpdatesNoUEFI.jpg?:"]FreshInstallNoUpdatesNoUEFI.jpg[/url]



  • Awesome Tom, i am actually building a complete new installation on a different PC same hardware GIGABYTE GA-H61M-S2PV

    and do as you suggest. I’ll let you know my findings

    Thanks a lot to both of you for taking time and help the community. Fog is an awesome product and like i mentioned before but i had not response. My IT manager is all for donating money to the project but i need to get it working like a charm as i did for XP. We have a massive upgrade to do and on a day to day basis support .


  • Senior Developer

    Also, before re pushing the image to a system.

    Can you reboot, choose boot to disk, and IMMEDIATELY after selecting, keep pressing the f8 key until you see the Windows Multi menu?

    Try “Last Known Good Configuration”?


  • Senior Developer

    Can you create a separate image but without the
    [quote=“AlonsoP, post: 32599, member: 24925”]1.- upload the image right after installing, updating and installing drivers ( no sysprep, nothing )

    [LIST=1]
    []use Sysprep with the /generalize switch
    [
    ]manually delete the [FONT=monospace]??\volume{…}[/FONT] keys in the registry under “HKLM\SYSTEM\MountedDevices”
    [*]run the following from an administrator’s console:
    [/LIST]
    [COLOR=#000000][FONT=monospace]bcdedit /set {bootmgr} device boot[/FONT][/COLOR]

    [FONT=monospace]bcdedit /set {default} device boot[/FONT]
    [FONT=monospace]bcdedit /set {default} osdevice boot[/FONT][/quote]

    BCD commands or registry key edit? My suspicion is it can’t find the device because it’s been removed. Normally BCD will attempt to find it (when it’s generalized) but I’m starting to think the removal of the MountedDevices is part of the problem. it has no idea where to look for the drives. It knows the boot system exists, and probably even knows the location of the “data” partition, but because it doesn’t know about the mounted devices, it fails thinking the device doesn’t exist.



  • i just did :

    • full windows 64 b pro
    • windows updates
    • motherboard drivers

    No additional software !!!


  • Senior Developer

    Your issues appear to me to be more likely related to AVG or some form of antivirus has a driver installed that’s unsigned


  • Senior Developer

    Based on the pictures you provided your systems are not booting in Uefi mode because uefi enforces GPT partitions your partitions do not have any GPT set up



  • [SIZE=12px]Junkhacker[/SIZE]

    [SIZE=12px]UEFI was enable in the bios on my source computer, i did the whole installation with the UEFI enable.[/SIZE]

    [SIZE=12px]Tom[/SIZE]

    [SIZE=12px]It does the same thing windows will not boot, with the commands you guys gave me i was able just to see it step by step but same result.[/SIZE]

    [SIZE=12px]To be quit hones and again you guys are the experts but i think it has something to do with :[/SIZE]

    [SIZE=12px]* UEFI which i don’t fully understand but i think i read it on a different post.[/SIZE]
    [SIZE=12px]* GPT and MBR [/SIZE]

    [SIZE=12px]just to try i am going to disable UEFI and re-install windows completely on a third computer ( same hardware )[/SIZE]


  • Senior Developer

    What happens if you tell it to run normally


  • Developer

    you mentioned UEFI, was that enabled in the bios when the system was working, before you pulled an image from it?



  • yeap didn’t work

    [ATTACH=full]1143[/ATTACH][ATTACH=full]1144[/ATTACH][ATTACH=full]1145[/ATTACH][ATTACH=full]1146[/ATTACH][ATTACH=full]1147[/ATTACH][ATTACH=full]1148[/ATTACH]

    [url="/_imported_xf_attachments/1/1143_IMAG0073.jpg?:"]IMAG0073.jpg[/url][url="/_imported_xf_attachments/1/1144_IMAG0074.jpg?:"]IMAG0074.jpg[/url][url="/_imported_xf_attachments/1/1145_IMAG0075.jpg?:"]IMAG0075.jpg[/url][url="/_imported_xf_attachments/1/1146_IMAG0076.jpg?:"]IMAG0076.jpg[/url][url="/_imported_xf_attachments/1/1147_IMAG0077.jpg?:"]IMAG0077.jpg[/url][url="/_imported_xf_attachments/1/1148_IMAG0078.jpg?:"]IMAG0078.jpg[/url]



  • it did run, i will send you guys pics ones done so that you can see that windows just won’t boot…

    it does create the 100 MB Windows reserved partition
    and is creating the actual windows installation partition.


  • Senior Developer

    Now run fog


  • Developer

    i believe that at this point, tom would ask you to enter the command “fog” and report on if the download succeeds.



  • download-debug !!![ATTACH=full]1135[/ATTACH][ATTACH=full]1136[/ATTACH]

    [url="/_imported_xf_attachments/1/1135_IMAG0071.jpg?:"]IMAG0071.jpg[/url][url="/_imported_xf_attachments/1/1136_IMAG0072.jpg?:"]IMAG0072.jpg[/url]



  • Yes Sir,

    Will do !!!


Log in to reply
 

380
Online

38982
Users

10712
Topics

101677
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.