Help - Invalid Mac Address



  • Hi,

    Have been using fog version 1.1.2 now for over a week. Everything has been running smoothly and I have been abled to upload and download images using part clone etc. This morning when I was testing the options within the fog menu I used the Quick Host Deletion option as the host I wanted to send an image to had already been registered. After I had used this option the host was deleted. Upon trying to send an image to the machine I then received the message invalid mac address. I tested on other machines and now this message is appearing on all. I am able to register the host and it gets as far as checking in before saying invalid mac address.

    The other change I made this morning was testing a storage node. I changed the IP address of the node as I wanted to test from this building before configuring for another building with a different ip range. I have since changed the IP address back to what it was previously and removed from the network as I feared this was another reason for the invalid mac address error.

    Not sure if either of those changes have caused this is anyone able to shed some light please?

    Thank you
    Scott



  • Working great now after moving to the Trunk. I was pleasantly surprised with how well the upgrade process worked. All I had to do after the update was reconfigure some of my settings for dnsmasq and then I was up and running.

    Thank you for your help @Wayne-Workman !


  • Moderator

    @csavo Nope. It will function exactly how it is now. FOG doesn’t bother with your dnsmasq configuration - but I’d still make a copy of the configuration just because it’s good practice to have copies of configurations.



  • @Wayne-Workman

    Just as a little background, I am using my FOG server with dnsmasq as I do not have access to the DHCP server on the network I am working with. Is there any known issues with updating to the FOG Truck and using it with dnsmasq?


  • Moderator

    @csavo The fix is to update to FOG Trunk - that will likely fix it.

    However understand that FOG Trunk is the developmental version of FOG, it is what WILL be FOG 1.3.0 some day. Right now things are very stable IMHO and it’s getting close to release, but that’s not to say there is no possibility of bugs. FOG Trunk gets updated many times a day - and most bugs are minor, and if you find them, just report them here so we can fix them and get to FOG 1.3.0 faster.

    If you would like to upgrade to trunk, you can pick one of the methods described here, I would recommend GIT:
    https://wiki.fogproject.org/wiki/index.php?title=Upgrade_to_trunk



  • Scott, Tom,

    I am having a similar issue to this using fog Version 1.20.

    I had an HP Elitebook that was not able to be registered at all. I updated the Kernal to the most recent bzImage files (posted on 2015-07-13) and then it booted into the screen to add the host but I got the “Invalid Mac Address Issue” (similar to this post): https://forums.fogproject.org/topic/4755/invalid-mac-address)

    Wondering if I should try the update mentioned in this ticket or if this was something already built into 1.20. Any help would be greatly appreciated.

    Thanks!

    • Chris


  • I have uploaded the new files and the issue has now been resolved fog is recognising the correct mac address. Thank you for taking the time to look at this. :)



  • Thank you - will give it a go. Appreciate your help and will let you know the results.


  • Senior Developer

    Yes, they’re just overwriting. If you want to upload yourself you most certainly can.



  • Are these commands just overwriting the files:

    /var/www/fog/service/Pre_Stage1.php
    /var/www/fog/service/Post_Stage2.php
    /var/www/fog/service/Post_Stage3.php
    /var/www/fog/service/Post_Wipe.php

    If so can I download new files from:

    https://svn.code.sf.net/p/freeghost/code/trunk/packages/web/service/Post_Stage2.php
    https://svn.code.sf.net/p/freeghost/code/trunk/packages/web/service/Post_Stage3.php

    and then upload to /var/www/fog/service/ myself?



  • Ok thanks - going to give this a go. Will the commands mean that only a single mac address will be added as the host as opposed to both mac addresses?

    Also not 100% how to make the change to SVN - where can I find this to edit? Is it easy enough to complete?


  • Senior Developer

    Alright All is posted to svn. These commands below should get you back to an operational state.

    wget -O /var/www/fog/service/Pre_Stage1.php https://svn.code.sf.net/p/freeghost/code/trunk/packages/web/service/Pre_Stage1.php
    wget -O /var/www/fog/service/Post_Stage2.php https://svn.code.sf.net/p/freeghost/code/trunk/packages/web/service/Post_Stage2.php
    wget -O /var/www/fog/service/Post_Stage3.php https://svn.code.sf.net/p/freeghost/code/trunk/packages/web/service/Post_Stage3.php
    wget -O /var/www/fog/service/Post_Wipe.php https://svn.code.sf.net/p/freeghost/code/trunk/packages/web/service/Post_Wipe.php
    


  • Ah right ok I see - thanks that would be great appreciate it :)



  • Another update (Sorry lol). Have now managed to get the machines to send the image by disabling one of the NICs in the BIOS menu. This means that the only mac address being picked up in the logs is for the one which is enabled. However I have previously sent images to the same machines, all the same make and model, with two NICS with both being enabled in the bios. Is it possible that IPXE doesn’t like having two NICS enabled on a machine and since I have only been using this method this week is why I have been having problems?


  • Senior Developer

    That explains the mac issue.

    I’ll fix the Pre_Stage1.php.

    Basically, right now, it doesn’t parse through an array of MAC’s. So the “Singular” mac systems shouldn’t have any issues.

    This will take a just a couple minutes. When done I’ll let you know and give you the steps you need to “fix” this issue.



  • No changes have been made to the boot.menu.class.php

    Logs under apache2 show the correct mac address of the machine as below:

    10.0.4.67 - - [09/Jul/2014:11:32:31 +0100] “GET /fog/service/Pre_Stage1.php?mac=80:ee:73:96:71:27|80:ee:73:96:71:26&type=down HTTP/1.1” 200 314 “-” “Wget”

    Only thing I am noticing from above log is that it has two mac address ? It does have two NICS but only one is connected. Also checking the logs from the same make and model of machine with two NICS from yesterday it only shows one mac address

    10.0.4.24 - - [08/Jul/2014:14:27:56 +0100] “GET /fog/service/Pre_Stage1.php?mac=80:ee:73:83:a0:46&type=down HTTP/1.1” 200 299 “-” “Wget”



  • Quick update also - whenever I add the host in and select the image and download it adds to the database. When I boot the machine it looks as if it is about to send the image and goes through the process. However it then gets so far and comes back with the error “No host found for this mac address” when trying to send to inventory. Even thought the host has been added through the fog console using that mac address.


  • Senior Developer

    Quick Host Deletion deletes the host from FOG Completely. It rely’s on the MAC Address during any of the imaging phases to “find” the host.

    If it’s been deleted from the database, then the MAC can’t be found which would then make sense as to “Invalid MAC”, but it could also be how it’s sending the mac address. Did you make any changes to the BootMenu.class.php file in how it sends the MAC address on boot? What do your access logs (/var/log/httpd/access_log, /var/log/apache2/access.log) show it’s sending for those macs?


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.