Renaming makes makes renaming work?



  • So after being infuriated with the fog client not renaming and adding to the domain I went in and manually renamed a computer and restarted. The computer came back up and then WTH!?!?! It restarted again coming back up with the correct name and then restarted again after joining the domain. Hooray! But why? After playing with it more I’m 98% positive that the simple act of renaming the computer somehow unlocks it for fog? Anybody else expierence this, have any idea why it does this, or better yet a fix so I don’t have to rename it manually for fog to rename it?



  • Cool thanks for your help through this guys.


  • Developer

    tom may have found a small flaw in the hostname change early method, an experimental new method is now in the svn.
    it comes down to there being a 3rd location in the registry that the hostname is listed, that may be relevant for some situations but not relevant in others. previously we were changing the hostname in 2 locations, but not the third.



  • After disabling early hostname changer and trying another batch of machines they renamed successfully. WOOHOO!!!


  • Developer

    it sounds to me like your computers are loading controlset002 instead of controlset001
    fog hostname change early only edits the hostname listing in controlset001, which typically gets loaded as currentcontrolset when windows loads, and controlset002 is the “last known working” set.
    for some reason, your machines seem to be loading that one instead. this suggests that while creating the image, you encountered some kind of crash event.



  • I’ve tried restarting the hosts numerous times - no effect

    The image is sysprepped but not generalized.

    I use an unattended answer file that as far as I can tell works perfectly and I know it makes no attempt to add the computer to the domain as i haven’t added in any of these options.

    I am deploying to machines that have identical hardware.

    The image is not taken while on the domain and the image has never been on the domain before deployment.

    Re-installing the fog client after imaging seems to have no effect.

    Nothing in that forum has helped me because all of my active directory settings work perfectly after I manually rename the host, I have no antivirus installed at this point of the imaging process, windows firewall is turned off, and the fog log gives no errors when contacting the server.


  • Senior Developer

    Can you give the information found in this thread a shot?
    http://fogproject.org/forum/threads/hostname-changer-not-working-since-moving-to-1-0-1.10502

    Also, is the hostname changed or not? Is your sysprep with interaction or not? If you’re seeing the “issue” and perform a reboot, does it work without changing the hostname?



  • yes the image is sysprepped

    No the unattend file shouldn’t add to the domain and I’m actually deploying an image that has never associated to the domain beofer the fog client adds it. Lastly I have made sure the preexisting computer profiles for these computers were deleted for AD.

    the client says it’s version .1

    Yes and after my manual renaming it seems to join that OU fine.


  • Senior Developer

    Is this image sysprepped?

    I ask because that error means “The step (Join Domain or Workgroup) must be running in full OS”

    So is your sysprep file joining the system to the domain?

    Also, what version of the FOG Client are you running on your hosts?

    Also, are you trying to have host automatically join to OU?



  • Yes hostname early is enabled I just disabled it to see what happens.
    Yes, after I manually rename the computer to anything, the fog client for some reason starts working and renames it again to the proper name listed in fog. I’ve played with this for hours and tried numerous different things. The only way I can get the fog renaming service to “kick in” is to first rename the computer myself. I’ve tested lots of different variables and I’m sure it doesn’t matter what I manually rename it to or what the computer is named before I manually rename it. Simply the act of renaming the computer somehow “unlocks” the fog client. I’m attaching the fog log that is generated before I manually rename the computer. If you read it you can see that for some reason the hostname changer thinks that the name is already correct until I change the name to anything else and then it works fine.

    fog.log.txt


  • Senior Developer

    Is hostname early enabled, and the hostname is set to the proper hostname?

    Or is hostname still shows up as your “jumbled letters and numbers”?



  • Another update, Just to be 100% sure, I named the computer a random jumble of letters and numbers and took another image and deployed it to 10 more machines. I checked the fog client log and according to it, even with the random jumble name it checks in with the fog server and returns that the host name is correct. Obviously it’s not. When I rename the machine manually to anything else, even another random jumble of letters, and restart the computer the fog client checks in again and this time returns an incorrect host name and renames it just like it should.



  • Nope. The image was taken from a computer that had never been on the domain during the entire image building process. All of the machines are named “rename” from the image and are not associated with the domain. I even went as far as to delete their old computer profiles in AD. If you change the name to anything else it then checks in with fog properly and renames back to what it’s supposed to be in fog. It doesn’t matter what you rename it but for some reason the act of renaming the machine lets fog re-rename it and add to the domain properly.


  • Senior Developer

    I have not experienced this. The only guess I have is the host was joined to domain under that hostname. Renaming told fog that it needed to change the name/join with the new name.


Log in to reply
 

475
Online

38710
Users

10537
Topics

99776
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.