This is not partclone image



  • I have updated fog from 0.32 to 1.1.1 and than to 1.1.2. All the images on the server were created with 0.32. Now when trying to deploy with 1.1.2 i get this error (Partclone>This is not partclone image.).

    I get it that because image was created with older version of fog now it can’t deploy. How can i solve this, besides from obvious uploading all the images with new version of fog. Thank you.



  • Just to update with the solution. I downloaded 1.1.2 files again and than I ran 1.1.2 setup again; nothing more and now it works, thank you for pointing me in the right direction.


  • Senior Developer

    For a partimage image the imgType should read as:
    [code]imgLegacy=1[/code] If it is set to 1 then the image is partimage. My, best guess, is that it’s not working because we had to push 1.1.2 out quickly due to a rather large bug. Check the /var/www/fog/lib/fog/BootMenu.class.php file and make sure the references to imgLegacy are changed to imgFormat. Looking at the source code shows that imgLegacy is not set in there, but I did have to retag and regenerate the tar.gz files, so it’s possible you got one that was broken with regards to the imgFormat/imgLegacy setting.



  • It was for sure i also tried another image, same result. As i said in Image Management under Image Manager it is set as PartImage. What else can i do.

    This is first deployment that i tried after upgrade. Maybe something went wrong when upgrading. Evertyhing went well other than updating database from 1.1.1 to 1.1.2 i had to use [URL=‘http://fogproject.org/forum/threads/fog-upgrade-1-1-1-1-1-2-database-error.10956/#post-31683’]this [/URL]soulution.


  • Developer

    you said this image was made in fog 0.32, but you do not have this image set to partimage format



  • At [url]http://<fog-server>/fog/service/ipxe/boot.php?mac=XX:XX:XX:XX:XX:XX[/url] i see:
    [code]#!ipxe
    kernel bzImage32 root=/dev/ram0 rw ramdisk_size=127000 ip=dhcp dns=“MYDNS” keymap= web=“FOGIP”/fog/ consoleblank=0 loglevel=4 mac=xx:xx:xx:xx:xx:xx ftp=“FOGIP” storage=“FOGIP”:/images/ storageip=“FOGIP” web=“FOGIP”/fog/ osid=5 loglevel=4 consoleblank=0 irqpoll chkdsk=0 img=win7master imgType=mpa imgid=1 imgLegacy= PIGZ_COMP=-9 hostname=hptst type=down
    imgfetch init_32.xz
    boot[/code]


  • Developer

    if you create a download task, and go to [url]http://<fog-server>/fog/service/boot.php?mac=XX:XX:XX:XX:XX:XX[/url] for the mac address of the computer you are trying to image, what do you see?



  • Yes i am downloading and i have recreated the job multiple times.


  • Developer

    if this is a download job that you created before you enabled that setting, you will need to cancel it and recreate the job.


  • Senior Developer

    Are you uploading or downloading?



  • I see, but when deploying it still goes to same error (partclone), despite being partimage in image type.



  • If it’s a 0.32 image, it’s partimage.
    Partclone is only used since version 1.0 of Fog



  • Ok i checked the box for FOG_FORMAT_FLAG_IN_GUI i did not find the FOG_LEGACY_FLAG_IN_GUI. Image type was already Partimage i changed it back and forth to be sure but it still somehow goes to Partclone.


  • Senior Developer

    Go to:

    FOG Configuration (? icon) -> FOG Settings -> General Settings -> Enable FOG_LEGACY_FLAG_IN_GUI or FOG_FORMAT_FLAG_IN_GUI and check the box and save settings. Go to the Image Management page and select the image or images you need to edit. Edit the Image Type flag from Partclone to Partimage.



  • You need to enable FOG_FORMAT_FLAG_IN_GUI in General Settings and set image to partimage instead of partclone.


Log in to reply
 

422
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.