Windows 7 without system partiton under Fog 1.x



  • Hello,

    I try since few days to upload images (we have around 150 images made this way) of a Windows 7 were i made partitions myself.
    As i did it myself, there is no the 100mb system partition and it was starting at sector 63.
    All was fine under Fog 0.32 and partimage.

    I find out that under Fog 1.x, I can only upload it as Windows XP because of the 63th sector but i haven’t try to download it yet.
    I made modification to put the partition at the sector 2048 as it should be under Windows 7 still without the 100mb partition.
    I tried to use Vista, Other and XP (but this last only want 63th sector) as Windows 7 image type but without success.
    It like Fog 1.x is looking for the system partition and the sector 2048 as start in all case to upload a Windows 7.

    The only solution is to backup data and restore them under a normal Windows partition type but this will take too much time and much more when i have to download them using for 0.32 and block use of a computer.

    Thank you for your ideas and possibilities.



  • This post is deleted!


  • This is a short answer. :p
    I tried to copy the rec.img.000 to the directory of my single partition windows and i have the same problem.
    It restore well the system partition but it still fail to restore the sys.img.000
    It says “funcs.sh: line 88: 3438 Aborted” and there is not log in status.fog


  • Senior Developer

    Yes.



  • I come back to this topic after reading that you use a BCD from a generalized image.
    As this one should handle a Windows with a system partition and starting a sector 2048.
    Shouldn’t Fog also own the system partition instead of backing up it each time ?
    Shouldn’t Fog backup only data in the 2nd partition ?

    As Acronis can restore only data without MBR, after having test, I can remake a “generalized” Windows using only my single partition data and restoring it to the 2nd partition of a normal install.
    So, if i copy the image of the system partition from an other Windows (rec.img.000) and put it in the same directory of my single partition image, shouldn’t Fog be able rebuild it as “generalized” windows and put my single partition as 2nd one automatically ?



  • System was sysprep and i boot directly on live CD at next reboot so it should be fine.

    I think i have gave the version starting at 63s, if this change something for you, i can get the one starting at 2048 later.


  • Developer

    this BCD file should be correct, so long as windows did not boot after being sysprep /generalized
    thank you



  • Here is the file.
    I hope i didn’t do wrong because i used a live CD.

    BCD.zip


  • Senior Developer

    This is correct. It is assuming partition start 2048 for image types that are “Resizable” but this same action occurs in FOG 0.32. Only difference in 0.32 is it wasn’t trying to use a BCD file, so my suspicion is that this is where the “difference” is occurring. I don’t think it matters the 63 or 2048 start sector, but it’s the BCD that we’re using is from a Generalized default base image. So my guess this is why you’re seeing an issue.

    I’m going to make a request if you can do it for me.

    If you’re sysprepping your single partition system in this case, before the image download occurs, can you try to get me your BCD file?

    It will be located on the only partition you have under:
    Boot/BCD

    Best means, is from the system you’re trying to upload the file from:

    Run these commands:

    mkdir /images2
    mount -o nolock,proto=tcp,rsize=32768,wsize=32768,intr,noatime <FOGSERVERIP>:<PATHTO /images/dev> /images2;
    mkdir /bcdstore
    ntfs-3g -o force,rw /dev/sda1 /bcdstore &> /tmp/bcdstore-mount-output;
    cp /bcdstore/Boot/BCD /images2/BCDSINGLE
    

Log in to reply
 

353
Online

38746
Users

10569
Topics

100052
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.