Can't join domain in 1.1.2

  • Fresh install of Fog 1.1.2 on Ubuntu 14.04.
    I can upload and download images fine. I can run snapins.
    However, I cannot join a domain. I can ping the domain from the newly imaged machine, I can do DNS lookups for the domain services, and I can join the domain manually. But joining automatically doesn’t work. I have the “Join domain after image task” box checked. I put credentials in the host configuration, and it won’t join. I put the credentials in the Fog AD Defaults and it won’t join. I put the credentials in both the host config and defaults section and no luck. The domain is correct, the username is “Administrator”, the password is encrypted, and the OU is set to the blank for default. Any thoughts?

  • Axel12, thanks for pointing out the obvious to me. 🙂 I looked through the log and it turns out I had disabled the Auto Log Out module for the client service. (Evidently, that’s important…) I enabled all modules and, voila! Joined the domain. Thanks for the help.

  • can you post a log from one of the clients … should be “c:\fog.log” [ have NO idea where the log file on linux machine would be ]

    specifically - include enough of the log for “hostnamechanger” … it will have some stuff about errors joining to the domain.

    also make sure to fog-crypt your password - cannot use your domain password by typing it into fog settings. you MUST provide an encrypted version of it. also, for my domain (for example) sometimes it works by adding “.local” at the end … or using a different version of the credentials, such as “domain\adminuser” instead of “adminuser”

Log in to reply